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‭XI  - CHAPTER - 1‬

‭FUNDAMENTALS OF COMPUTER‬
‭1.കമ്പ്യൂട്ടർ നിർവ്വചിക്കുക  Define computer :‬ ‭അസംസ്‌കൃത ഡാറ്റ ഇൻപുട്ടായി സ്വീകരിക്കുകയും‬

‭നിർദ്ദേശങ്ങൾക്ക് അനുസരിച്ചു പ്രോസസ്സ് ചെയ്യുകയും ഫലം ഔട്ട്‌പുട്ടായി നിർമിക്കുവാൻ‬

‭ഉപയോഗിക്കുന്ന ഇലക്ട്രോണിക് ഉപകരണമാണ് കമ്പ്യൂട്ടർ.‬

‭1.1. ഡാറ്റ :‬‭പ്രോസസ്സ് ചെയ്യാവുന്ന അസംസ്‌കൃത വസ്‌തുക്കളും അക്കങ്ങളും.‬

‭1.2. ഇൻഫർമേഷൻ:‬‭പ്രോസസ്സ് ചെയ്ത ഡാറ്റയെ ഇൻഫർമേഷൻ എന്നറിയപ്പെടുന്നു.‬

‭***1.3.ഡാറ്റയും ഇൻഫർമേഷനും തമ്മിലുള്ള വ്യത്യാസം‬‭Distinguish between data & information‬

‭ഡാറ്റ‬ ‭ഇൻഫർമേഷൻ‬

‭അസംസ്കൃത വസ്തുതകളും അക്കങ്ങളും‬ ‭പ്രോസസ്സ് ചെയ്ത ഡാറ്റ‬

‭നേരിട്ട് ഉപയോഗിക്കാൻ കഴിയില്ല‬ ‭തീരുമാനങ്ങൾ എടുക്കാൻ സഹായിക്കുന്നു‬

‭കൃത്യവും വ്യക്തവുമായ ആശയം നൽകുന്നില്ല‬ ‭വ്യക്തവും അർത്ഥപൂർണ്ണവുമാണ്‬

‭2. ഡാറ്റ പ്രോസസ്സിംഗ് :‬‭ഡാറ്റയെ വിവരങ്ങളാക്കി ( ഇൻഫർമേഷൻ ) മാറ്റുന്ന പ്രക്രിയ.‬

‭***2.1.ഡാറ്റ പ്രോസസ്സിംഗിൽ ഉപയോഗിക്കുന്ന ഘട്ടങ്ങൾ‬ ‭Data Processing Steps‬

‭Step 1: ഡാറ്റയുടെ ശേഖരണം             /   Capturing data ( Collection of data )‬

‭Step 2: ഡാറ്റയുടെ ഇൻപുട്ട്‬ ‭/    Input Data‬

‭Step 3: ഡാറ്റയുടെ സംഭരണം           /      Storage of Data‬

‭Step 4: ഡാറ്റയുടെ പ്രോസസ്സിംഗ്       /      Processing Data‬

‭Step 5: ഇൻഫർമേഷൻ ലഭ്യമാക്കുക   /      Output of Information‬

‭Step 6: ഇൻഫർമേഷൻ വിതരണം ചെയ്യുക  /  Distribution of information‬

‭***3.ഒരു കമ്പ്യൂട്ടറിന്റെ 4 പ്രവർത്തന യൂണിറ്റുകൾ (  Functional units of a computer )‬

‭3.1‬‭ഇൻപുട്ട് യൂണിറ്റ്‬‭( Input Unit )  :‬
‭➤ കമ്പ്യൂട്ടറിലേക്ക് ഡാറ്റയും നിർദ്ദേശങ്ങളും സ്വീകരിക്കുന്നു.‬

‭➤ഈ ഡാറ്റയും നിർദ്ദേശങ്ങളും  കമ്പ്യൂട്ടറിന് മനസിലാകുന്ന ഭാഷയിലേക്ക് പരിവർത്തനം ചെയ്യുന്നു.‬

‭➤പരിവർത്തനം ചെയ്ത ഡാറ്റയും നിർദ്ദേശങ്ങളും പ്രോസസ്സിംഗിനായി കമ്പ്യൂട്ടറിലേക്ക് നൽകുന്നു.‬

‭3.2‬‭സെൻട്രൽ പ്രോസസ്സിംഗ് യൂണിറ്റ്‬ ‭( CPU )  :‬

‭➤‬‭കമ്പ്യൂട്ടറിന്റെ തലച്ചോറായ CPUയിലാണ് എല്ലാ പ്രധാന പ്രവർത്തനങ്ങളും നടക്കുന്നത്.‬

‭3 ഭാഗങ്ങളുണ്ട് : Arithmetic Logic Unit(ALU), Control Unit(CU) and Registers.‬

‭ALU‬‭: ഗണിതക്രിയകൾ, ലോജിക്കൽ ഓപ്പറേഷനുകൾ,തീരുമാനമെടുക്കൽ എന്നിവ ചെയ്യുന്നു.‬

‭CU‬‭: കമ്പ്യൂട്ടറിന്റെ വിവിധ യൂണിറ്റുകളെ ഏകോപിപ്പിക്കുകയും നിയന്ത്രിക്കുകയും ചെയ്യുന്നു.‬

‭Registers‬‭: ഇത് CPU ന്റെ ഉള്ളിലുള്ള താത്കാലിക മെമ്മറി ആണ്.‬

‭3.3‬‭സ്റ്റോറേജ് യൂണിറ്റ്‬ ‭( Storage unit )  :‬

‭പ്രോസസ്സിംഗിന് ആവശ്യമായ എല്ലാ ഡാറ്റയും,നിർദ്ദേശങ്ങളും,റിസൾട്ട് എന്നിവ സംഭരിക്കുന്നു.‬

‭പ്രൈമറി മെമ്മറി & സെക്കണ്ടറി മെമ്മറി എന്നിങ്ങനെ 2 തരം ഉണ്ട്.‬

‭3.4‬‭ഔട്ട്പുട്ട് യൂണിറ്റ്‬ ‭( Output unit )  :‬

‭➤‬‭പ്രോസസ്സ് ചെയ്തു ലഭിച്ച റിസൾട്ട് കമ്പ്യൂട്ടർ ഭാഷയിൽ സ്വീകരിക്കുന്നു.‬

‭➤‬‭പിന്നീട് മനുഷ്യർക്ക് വായിക്കാവുന്ന രൂപത്തിലേക്ക് പരിവർത്തനം ചെയ്യുന്നു.‬

‭➤‬‭റിസൾട്ട് ( ഇൻഫർമേഷൻ )  പുറം ലോകത്തിന് നൽകുന്നു.‬
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‭***4.കമ്പ്യൂട്ടറുകളുടെ സ്വഭാവ സവിശേഷതകൾ (  Characteristics of computers )‬

‭സവിശേഷതകൾ /ഗുണങ്ങൾ  :‬‭വേഗത,കൃത്യത,ശ്രദ്ധ,ഉയർന്ന മെമ്മറി,വൈവിധ്യം.‬

‭ന്യൂനതകൾ :‬‭മനുഷ്യനെപോലെ ചിന്താശേഷി,സ്വയം തീരുമാനം എടുക്കാനുള്ള ശേഷി,‬

‭വികാരങ്ങൾ തുടങ്ങിയവയില്ല‬

‭5. നമ്പർ സിസ്റ്റം (  Number System )‬

‭സംഖ്യകളെ പ്രതിനിധീകരിക്കുന്നതിനോ പ്രകടിപ്പിക്കുന്നതിനോ ഉള്ള ഒരു മാർഗമാണ് നമ്പർ സിസ്റ്റം.‬

‭**5.1.കമ്പ്യൂട്ടറുമായി ബന്ധപ്പെട്ട നമ്പർ സിസ്റ്റം (  Different Number Systems )‬

‭നമ്പർ സിസ്റ്റം‬ ‭ബേസ്‬
‭( Base )‬

‭ചിഹ്നം‬
‭Symbols used‬

‭ഉദാഹരണം‬

‭ബൈനറി‬‭( Binary ) :‬‭കമ്പ്യൂട്ടറിന്റെ ഭാഷ.‬ ‭2‬ ‭0, 1‬ ‭(1101)‬‭2‬

‭ഒക്ടൽ‬‭( Octal ) :‬‭UTF8 നമ്പറുകളെ‬
‭പ്രതിനിധീകരിക്കുന്നു.‬

‭8‬ ‭0, 1, 2, 3, 4, 5, 6, 7‬ ‭(236)‬‭8‬

‭ഡെസിമൽ‬‭( Decimal ) :‬‭മനുഷ്യർക്ക്‬
‭എളുപ്പത്തിൽ വായിക്കാവുന്നതും‬
‭കൈകാര്യം ചെയ്യുവാനും.‬

‭10‬ ‭0, 1, 2, 3, 4, 5, 6, 7, 8, 9‬ ‭(5876)‬‭10‬

‭ഹെക്സ-ഡെസിമൽ‬ ‭( Hexadecimal )‬
‭മൈക്രോപ്രൊസസർ പ്രോഗ്രാമിംഗിൽ‬
‭ഉപയോഗിക്കുന്നു.‬

‭16‬ ‭0, 1, 2, 3, 4, 5, 6, 7, 8, 9,‬
‭A , B , C , D , E , F‬

‭( A , B , C , D , E , F represents‬
‭10, 11, 12, 13, 14, 15 respectively )‬

‭(12 AF )‬‭16‬

‭***‬‭ഒരു നമ്പർ സിസ്റ്റത്തിൽ ഉപയോഗിക്കുന്ന ചിഹ്നങ്ങളുടെ എണ്ണത്തെ ബേസ് / റാഡിക്സ് എന്ന് വിളിക്കുന്നു‬

‭Bit‬‭stands for‬‭: Bi‬‭nary digi‬‭t     |‬ ‭MSD - Most Significant Digit  |  LSD - Least Significant Digit‬

‭??‬ ‭5876-‬‭ൽ MSD, LSD എന്നിവ എഴുതുക? ഉത്തരം :  MSD-5 &  LSD-6‬

‭6.കമ്പ്യൂട്ടർ മെമ്മറിയിൽ നമ്പർ പ്രതിനിധാനം ചെയ്യുന്നത്‬ ‭(  Representation of Numbers in Memory )‬

‭i)Sign and magnitude representation    /   സൈൻ & മാഗ്നിറ്റൂഡ്‬

‭ii) 1's complement representation‬ ‭/    1’s കോംപ്ലിമെൻറ്‬

‭iii)2's complement representation.‬ ‭/      2’s കോംപ്ലിമെൻറ്‬

‭***7.കമ്പ്യൂട്ടർ മെമ്മറിയിൽ അക്ഷരങ്ങൾ പ്രതിനിധാനം ചെയ്യുന്നത്‬‭(Representation of Characters in Memory )‬

‭7.1. ASCII‬‭( അമേരിക്കൻ സ്റ്റാൻഡേർഡ്‬

‭കോഡ് ഫോർ ഇൻഫർമേഷൻ‬

‭ഇന്റർചേഞ്ച് )‬

‭7 bit - 128‬
‭അക്ഷരങ്ങൾ&‬
‭8 bit - 256‬
‭അക്ഷരങ്ങൾ‬

‭ഓരോ അക്ഷരത്തിനും ഓരോ പൂർണ
‭സംഖ്യ നൽകുന്നു.‬

‭7.2. ISCII‬‭( ഇന്ത്യൻ‬ ‭സ്റ്റാൻഡേർഡ് കോഡ്‬

‭ഫോർ ഇൻഫർമേഷൻ ഇന്റർചേഞ്ച് )‬

‭8 bit - 256‬
‭അക്ഷരങ്ങൾ‬

‭ഇന്ത്യൻ ഭാഷകളിലെ അക്ഷരങ്ങളെ‬
‭പ്രതിനിധാനം ചെയ്യുന്നു.‬

‭7.3. EBCDIC‬‭( എക്സ്റ്റൻഡഡ്‌ ബൈനറി‬
‭കോഡെഡ് ഡെസിമൽ ഇന്റർചേഞ്ച് കോഡ്)‬

‭8 bit - 256‬
‭അക്ഷരങ്ങൾ‬

‭7.4. Unicode‬‭( യൂണികോഡ്  )‬
‭**Universal character representation standard

‭16 bit - 65536‬
‭അക്ഷരങ്ങൾ‬

‭ലോകത്തുള്ള എല്ലാ മനുഷ്യ‬
‭ഭാഷകളെയും പ്രതിനിധീകരിക്കുന്നു‬
‭( എൻകോഡ് ചെയ്യുന്നു )‬
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‭XI  -  CHAPTER - 2‬

‭COMPONENTS OF THE COMPUTER SYSTEM‬

‭1.കമ്പ്യൂട്ടർ ഹാർഡ്‌വെയറുകൾ‬ ‭: ഇൻപുട്ട്, ഔട്ട്പുട്ട്, സംഭരണം, ആശയവിനിമയം, പ്രോസസ്സിംഗ്‬

‭പ്രവർത്തനങ്ങൾ നിർവഹിക്കാൻ പ്രാപ്‌തമാക്കുന്ന ഉപകരണങ്ങളാണ് ഹാർഡ്‌വെയർ‬

‭1.1 പ്രോസസ്സറുകൾ :‬‭കമ്പ്യൂട്ടറിൽ എല്ലാ കണക്കുകൂട്ടലുകൾ,തീരുമാനങ്ങൾ എടുക്കുന്നതും മറ്റു‬

‭പ്രവർത്തനങ്ങൾ ഏകോപിപ്പിക്കുന്നതും ചെയ്യുന്ന സർക്യൂട്ടാണ് പ്രോസസർ.‬

‭രജിസ്റ്റർ :‬‭CPUനുള്ളിലെ താൽക്കാലിക സ്റ്റോറേജ് ലൊക്കേഷനുകളാണ്‬‭രജിസ്റ്ററുകൾ.‬

‭രജിസ്റ്റർ‬ ‭ഉപയോഗം‬

‭അക്യൂമുലേറ്റർ ( Accumulator )‬ ‭ഗണിത, ലോജിക്കൽ പ്രവർത്തനങ്ങളുടെ ഫലങ്ങൾ‬
‭സംഭരിച്ചിരിക്കുന്ന ALU- യുടെ ഭാഗമാണിത്.‬

‭മെമ്മറി അഡ്രെസ്സ് രജിസ്റ്റർ‬
‭( MAR )‬

‭പ്രോസസ്സ് ചെയ്യേണ്ട ഡാറ്റയുടെ മെമ്മറി ലൊക്കേഷന്റെ‬
‭അഡ്രെസ്സ് ഇത് സംഭരിക്കുന്നു.‬

‭മെമ്മറി ബഫർ രജിസ്റ്റർ(MBR )‬
‭or മെമ്മറി ഡാറ്റ രജിസ്റ്റർ‬

‭പ്രോസസിംഗ് സമയത് ഡാറ്റയുടെ പെട്ടെന്നുള്ള ആക്‌സസ്സിനായി‬
‭താത്കാലികമായി സ്റ്റോർ ചെയ്യുന്നിടം.‬

‭ഇൻസ്ട്രക്ഷൻ രജിസ്റ്റർ  ( IR )‬ ‭പ്രൊസസർ എക്സിക്യൂട്ട് ചെയ്യേണ്ട നിർദ്ദേശങ്ങൾ സ്റ്റോർ‬
‭ചെയ്യുന്നിടം.‬

‭പ്രോഗ്രാം കൗണ്ടർ ( PC )‬ ‭പ്രോസസ്സ് ചെയ്യേണ്ട അടുത്ത നിർദേശത്തിന്റെ അഡ്രെസ്സ്‬
‭സ്റ്റോർ ചെയ്യുന്നു.‬

‭1.2 മദർബോർഡ്‬‭:‬‭ഇത് പ്രിന്റഡ് സർക്യൂട്ട് ബോർഡാണ് ( PCB )‬
‭*1.2.1 മദർബോർഡ് പോർട്ടുകളും ഉപയോഗവും‬

‭പോർട്ട്‬ ‭ഉപയോഗം‬

‭USB പോർട്ട് ( Universal Serial Bus )‬ ‭അതിവേഗ ഡാറ്റാ ആശയവിനിമയം സാധ്യമാക്കുന്നു‬

‭ഓഡിയോ പോർട്ട് ( Audio port )‬ ‭സ്പീക്കറുകൾ,മൈക്രോഫോൺ പോലെയുള്ള‬
‭ഓഡിയോ ഉപകരണങ്ങളെ ബന്ധിപ്പിക്കാൻ‬

‭VGA പോർട്ട്  (വീഡിയോ ഗ്രാഫിക്സ്‬
‭അറേ)‬

‭മോണിറ്ററോ പ്രൊജക്ടറോ കമ്പ്യൂട്ടറുമായി‬
‭ബന്ധിപ്പിക്കുന്നു.‬

‭LAN പോർട്ട്  / Ethernet port / Network‬
‭port‬

‭വയർഡ് കണക്ഷൻ ( RJ45 ) ഉപയോഗിച്ച് കമ്പ്യൂട്ടറിനെ‬
‭ഒരു നെറ്റ്‌വർക്കിലേക്ക് കണക്റ്റുചെയ്യാൻ‬

‭PS/2 പോർട്ട്  ( Personal System/2 )‬ ‭മൗസ്,കീബോർഡ് കണക്ട് ചെയ്യുവാൻ IBM‬
‭കണ്ടെത്തിയ പോർട്ട്. USB യെക്കാൾ വേഗത കുറവ്.‬

‭HDMI ( ഹൈ ഡെഫനിഷൻ‬
‭മൾട്ടിമീഡിയ ഇന്റർഫേസ് ) പോർട്ട്‬

‭ഉയർന്ന നിലവാരമുള്ള വീഡിയോ,ഓഡിയോ ഒരു‬
‭സിംഗിൾ കേബിളിലൂടെ കൈമാറാൻ സാധ്യമാക്കുന്നു‬
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‭**മെമ്മറി അളക്കുന്ന യൂണിറ്റുകൾ‬

‭Binary Digit = 1 Bit‬ ‭1 Nibble = 4 Bits‬ ‭1 Byte = 8 Bits‬ ‭1 KB (Kilo Byte) = 1024 Bytes‬

‭1 MB (Mega Byte) = 1024‬
‭KB‬

‭1 GB (Giga Byte) = 1024‬
‭MB‬

‭1 TB (Tera Byte) =‬
‭1024 GB‬

‭1 PB (Peta Byte) = 1024 TB‬

‭1.3 മെമ്മറി‬‭:‬ ‭ഡാറ്റ,നിർദ്ദേശങ്ങൾ,റിസൾട്ട് താൽക്കാലികമായോ സ്ഥിരമായോ സ്റ്റോർ ചെയ്യുന്നിടം.‬
‭മെമ്മറികൾ 2 തരം :‬
‭1.3.1. പ്രൈമറി മെമ്മറി :‬‭കമ്പ്യൂട്ടർ റൺ ചെയ്യുമ്പോൾ ഉള്ള ഡാറ്റയും,നിർദ്ദേശങ്ങളും,‬
‭പ്രോഗ്രാമുകളും താൽക്കാലികമായി സൂക്ഷിക്കുന്ന കമ്പ്യൂട്ടറിന്റെ ഘടകമാണിത്. ഉയർന്ന‬
‭വേഗതയിൽ ഡാറ്റ അയയ്ക്കാനും സ്വീകരിക്കാനും കഴിയുന്നു.‬‭പ്രൈമറി  മെമ്മറികൾ 3 തരം :‬

‭1.3.1.A  RAM(റാൻഡം ആക്സസ് മെമ്മറി)‬ ‭1.3.1.B  ROM ( റീഡ് ഓൺലി മെമ്മറി )‬

‭താത്കാലിക സ്റ്റോറേജ്  മെമ്മറി‬ ‭സ്ഥിരമായ സ്റ്റോറേജ്‬

‭ഇത് റോമിനേക്കാൾ വേഗതയുള്ളതാണ്‬ ‭ഇത് റാമിനെക്കാൾ വേഗത കുറവാണ്‬

‭വോളടൈൽ മെമ്മറി‬ ‭നോൺ-വോളടൈൽ മെമ്മറി ( പവർ ഓഫ്‬
‭ചെയ്യുമ്പോൾ സ്റ്റോർ ചെയ്തവ നഷ്ടമാകില്ല )‬

‭കമ്പ്യൂട്ടർ പ്രവർത്തിക്കാൻവേണ്ട  ഓപ്പറേറ്റിംഗ്
‭സിസ്റ്റം, റൺടൈം അപ്ലിക്കേഷൻ‬
‭പ്രോഗ്രാം,ഡാറ്റ എന്നിവ സ്റ്റോർ ചെയ്യുന്നു‬

‭കമ്പ്യൂട്ടർ ബൂട്ട് ചെയ്യാൻ ആവശ്യമായ പ്രോഗ്രാം‬
‭സ്റ്റോർ ചെയ്യുന്നു.‬

‭1.3.1.C കാഷെ മെമ്മറി ( Cache memory )‬‭:‬‭പ്രോസസറിനും റാമിനും ഇടയിലുള്ള ചെറുതും‬
‭വേഗതയേറിയതുമായ മെമ്മറിയാണിത്.‬

‭1.3.2.സെക്കണ്ടറി മെമ്മറി ( ഓക്സിലറി മെമ്മറി )‬‭:‬‭പ്രൈമറി മെമ്മറിയേക്കാൾ സ്റ്റോറേജ് കപ്പാസിറ്റി‬
‭കൂടുതലും,എന്നാൽ വേഗത കുറവും, ഡാറ്റ/ഇൻഫർമേഷൻ സ്ഥിരമായി സ്റ്റോർ ചെയ്യാൻ‬
‭സാധിക്കുന്നതുമായ നോൺ-വോളടൈൽ മെമ്മറിയാണിത്.‬
‭3 തരം സെക്കണ്ടറി മെമ്മറി :‬

‭1.3.2.A. മാഗ്നെറ്റിക് സ്റ്റോറേജ് ഡിവൈസ് :‬‭കാന്തിക സ്വഭാവമുള്ള പദാർത്ഥങ്ങൾ കൊണ്ട് പൊതിഞ്ഞ‬

‭പ്ലാസ്റ്റിക് ടേപ്പ് അല്ലെങ്കിൽ മെറ്റൽ/പ്ലാസ്റ്റിക് ഡിസ്കുകളിൽ ഡാറ്റ സ്റ്റോർ ചെയ്യാൻ ഉപയോഗിക്കുന്നു.‬

‭ഉദാഹരണം :‬

‭1.മാഗ്നെറ്റിക് ടേപ്പ് :‬‭കാന്തിക സ്വഭാവമുള്ള പദാർത്ഥങ്ങൾ കൊണ്ട് പൊതിഞ്ഞ പ്ലാസ്റ്റിക് ടേപ്പ്‬

‭2.ഹാർഡ് ഡിസ്ക് :‬‭കാന്തിക സ്വഭാവമുള്ള പദാർത്ഥങ്ങൾ കൊണ്ട് പൊതിഞ്ഞ മെറ്റൽ ഡിസ്കുകൾ‬

‭1.3.2.B. ഒപ്റ്റിക്കൽ സ്റ്റോറേജ് ഡിവൈസ് :‬‭പ്ലാസ്റ്റിക് ഡിസ്കുകൾക്കിടയിൽ അലുമിനിയം‬

‭ഫോയിൽ ചേർത്തുവെച്ചു, കുറഞ്ഞ ശക്തിയുള്ള ലേസർ ബീം ഉപയോഗിച്ചു ഡാറ്റയുടെ റീഡ്‬

‭& റൈറ്റ്  സാധിക്കുന്നു.‬

‭ഉദാഹരണം :‬

‭1.കോംപാക്റ്റ് ഡിസ്ക് ( CD ) :‬‭700 MB ഡാറ്റ വരെ സംഭരിക്കാൻ കഴിവുണ്ട്.‬

‭2.ഡിജിറ്റൽ വെർസറ്റൈൽ ഡിസ്ക് (DVD):‬‭4.37 ജിബി മുതൽ 15.9 ജിബി വരെ ഡാറ്റ‬

‭വരെ സംഭരിക്കാൻ കഴിവുണ്ട്.‬

‭3.ബ്ലൂ-റേ ഡിവിഡി :‬‭ഹൈ ഡെഫനിഷൻ (HD) വീഡിയോയുടെ വലിയ അളവിലുള്ള ഡാറ്റ‬

‭സംഭരിക്കുന്നു.രണ്ടു ലേയറുകളിലായി 50GB ഡാറ്റ സ്റ്റോർ ചെയ്യാം.‬

‭1.3.2.C. സെമി കണ്ടക്ടർ സ്റ്റോറേജ് ( ഫ്ലാഷ് മെമ്മറി ) :‬‭ഇലട്രിക്കലി ഡാറ്റ എറേസ് ചെയ്യാനും, റീപ്രോഗ്രാം ചെയ്യാനും‬

‭കഴിയുന്ന കുറഞ്ഞ ചെലവിലുള്ള പോർട്ടബിൾ നോൺ-വോളടൈൽ സ്റ്റോറേജ് ചിപ്പാണിത്.‬

‭ഉദാഹരണം :‬‭1. USB ഫ്ളാഷ് ഡ്രെവ്  ( Pen Drive ) :‬‭മനുഷ്യന്റെ വിരലിന്റെ വലിപ്പമുള്ള ഡിവൈസ്.‬

‭2.‬‭ഫ്ലാഷ് മെമ്മറി കാർഡുകൾ :‬‭സാധാരണ, ഫോണുകളിലും ക്യാമറകളിലും കണ്ടു വരുന്നു.‬
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‭1.4 ഇൻപുട്ട് ഡിവൈസ്:‬
‭കമ്പ്യൂട്ടറിലേക്ക് ഡാറ്റ,ഇൻസ്ട്രക്ഷൻ നൽകുന്നതിന് ഉപയോഗിക്കുന്ന ഉപകരണം.‬

‭ഇൻപുട്ട്‬
‭ഉപകരണം‬

‭വിശദീകരണം‬

‭കീബോർഡ്‬ ‭കമ്പ്യൂട്ടറിൽ അക്ഷരങ്ങളും,അക്കങ്ങളും ഉൾപ്പെടെയുള്ള ഡാറ്റ നൽകുവാൻ‬
‭സാധിക്കുന്നു‬

‭മൗസ്‬ ‭ഡിസ്‌പ്ലേ സ്‌ക്രീനിലെ ഏതൊരു സ്ഥലത്തേക്കും ചലിക്കാൻ ഉപയോഗിക്കുന്ന‬
‭പോയിന്റിംഗ് ഉപകരണം‬

‭മൈക്രോഫോ‬
‭ൺ‬

‭ശബ്ദം റെക്കോർഡ് ചെയ്യുന്നതിനായി ഉപയോഗിക്കുന്നു‬

‭ടച്ച് സ്ക്രീൻ‬ ‭ഇലക്ട്രോണിക് വിഷ്വൽ ഡിസ്പ്ലേയിൽ സ്പർശിച്ചുകൊണ്ട് ഇൻപുട്ട് സാധ്യമാക്കുന്നു

‭സ്കാനർ‬ ‭പ്രിന്റ് രൂപത്തിലുള്ള ചിത്രങ്ങളോ, ടെക്സ്റ്റ് ഡാറ്റകളോ കമ്പ്യൂട്ടറിൽ സ്റ്റോർ ചെയ്യാൻ‬
‭സാധിക്കുന്നു.‬

‭ലൈറ്റ് പെൻ‬ ‭ലൈറ്റ് സെൻസിറ്റീവ് ഡയറക്റ്റിംഗ് കമ്പ്യൂട്ടർ ഇൻപുട്ട് ഉപകരണമാണ്.‬

‭1.5 ഔട്ട്പുട്ട് ഡിവൈസ് :‬
‭ഒരു കമ്പ്യൂട്ടറിൽ നിന്ന് ഔട്ട്‌പുട്ട് പ്രദർശിപ്പിക്കുന്ന/പ്രിന്റ് ചെയ്യുന്ന ഉപകരണം.‬

‭ഔട്ട്‌പുട്ട്‬
‭ഉപകരണം‬

‭വിശദീകരണം‬

‭1.5.1 Visual Display Unit (VDU)‬

‭കാഥോഡ് റേ‬
‭ട്യൂബ് (CRT)‬

‭ഒരു ഇലക്ട്രോൺ ബീം ഫോസ്ഫോറസെന്റ് പ്രതലത്തിൽ അടിക്കുമ്പോൾ‬
‭ചിത്രങ്ങൾ നിർമ്മിക്കുന്ന ഒരു പ്രത്യേക വാക്വം ട്യൂബ്‬

‭ഫ്ലാറ്റ് പാനൽ‬
‭മോണിറ്റർ‬

‭CRT മോണിറ്ററുകളുമായി താരതമ്യം ചെയ്യുമ്പോൾ കനം കുറഞ്ഞതും, ഭാരം‬
‭കുറഞ്ഞതും, കുറഞ്ഞ വൈദ്യുതി ഉപഭോഗം ചെയ്യുന്നതും, കുറഞ്ഞ ചൂട്‬
‭പുറപ്പെടുവിക്കുന്നതുമാണ്.‬

‭ലിക്വിഡ് ക്രിസ്റ്റൽ‬
‭ഡിസ്പ്ലേ (LCD )‬
‭മോണിറ്ററുകൾ‬

‭രണ്ടു പ്ലാസ്റ്റിക് പ്ലേറ്റുകൾക്കിടയിൽ ലിക്വിഡ് ക്രിസ്റ്റൽ‬
‭അടങ്ങിയിരിക്കുന്നു. ഇലക്ട്രിക്ക് കറന്റ് ഇതിലൂടെ‬
‭കടന്നുപോകുമ്പോൾ ഇമേജുകളായി പ്രത്യക്ഷപ്പെടുന്നു.‬

‭ലൈറ്റ് എമിറ്റിംഗ്‬
‭ഡയോഡ് ( LED )‬
‭മോണിറ്ററുകൾ‬

‭ഇമേജ് പ്രകാശിപ്പിക്കുന്നതിന് ലിക്വിഡ് ക്രിസ്റ്റൽ ഡിസ്‌പ്ലേയ്ക്ക്‬
‭( LCD ) പിന്നിൽ നേരിട്ട് എൽഇഡി ഉപയോഗിക്കുന്നു. മെച്ചപ്പെട്ട‬
‭നിലവാരം, വ്യക്തത, വൈദ്യുതി ലാഭിക്കൽ എന്നതാണ്‬
‭ഗുണങ്ങൾ.‬

‭പ്ലാസ്മ‬
‭മോണിറ്ററുകൾ‬

‭രണ്ടു ഗ്ലാസ് പ്ലേറ്റുകൾക്കിടയിൽ നിയോൺ/സെനോൺ‬
‭വാതകം അടങ്ങിയിരിക്കുന്നു. അതിനുമുകളിലായുള്ള‬
‭ഇലെക്ട്രോഡുകളുള്ള ഗ്ലാസ് പ്ലേറ്റിലൂടെ വോൾട്ടേജ് പൾസ്‬
‭കടന്നുപോകുന്നതിന്റെ ഭാഗമായി വാതകം വ്യത്യസ്ത‬
‭നിറങ്ങളിൽ പ്രകാശിക്കുന്നു.‬

‭ഓർഗാനിക്‬
‭ലൈറ്റ് എമിറ്റിംഗ്‬
‭ഡയോഡ് (OLED)‬
‭മോണിറ്ററുകൾ‬

‭ദശലക്ഷക്കണക്കിന് ചെറിയ എൽഇഡികൾ കൊണ്ടാണ്‬
‭ഒഎൽഇഡിയുടെ പാനൽ നിർമ്മിച്ചിരിക്കുന്നത്. ഭാരം കുറവ്,‬
‭മികച്ച നിലവാരമുള്ള ചിത്രങ്ങൾ നിർമ്മിക്കുക, മികച്ച‬
‭വീക്ഷണകോണുകൾ, കുറഞ്ഞ വൈദ്യുതി ഉപഭോഗം.വളരെ‬
‭ചെലവേറിയവയാണ്.‬
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‭1.5.2 പ്രിന്റർ ( Printer )‬

‭ഡോട്ട് മാട്രിക്സ്‬
‭പ്രിന്റർ (DMP)‬

‭പിന്നുകൾ മഷി പുരണ്ട റിബ്ബണിൽ അടിക്കുന്നതിന്റെ ഫലമായി പേപ്പറിൽ‬
‭ഇമേജ്/ടെക്സ്റ്റ് രൂപപ്പെടുന്നു.‬

‭ഇങ്ക്ജെറ്റ് പ്രിന്റർ‬ ‭പേപ്പറിലേക്കു ലിക്വിഡ് ഇങ്ക് സ്പ്രൈ ചെയ്യുന്നു‬

‭ലേസർ പ്രിന്റർ‬ ‭ലേസർ ബീം ഉപയോഗിച്ച് പ്രിന്റ് ചെയ്യേണ്ടവ ഡ്രമിൽ എത്തിക്കുന്നു.ഡ്രമിൽ ഇങ്ക്‬
‭പൌഡർ സ്പ്രൈ ചെയ്തു ചൂടാക്കി പേപ്പറിൽ പതിപ്പിക്കുന്നു.‬

‭തെർമൽ പ്രിന്റർ‬ ‭ഒരു  തെർമൽ പ്രിന്റ്റിന്റെ ഹെഡ് തെർമൽ പേപ്പറിൽ കൂടി കടന്നുപോയി‬
‭തിരഞ്ഞെടുത്ത ഭാഗങ്ങളിൽ മാത്രം ചൂടാക്കി ഇമേജ് നിർമിക്കുന്നു.‬

‭1.5.3 പ്ലോട്ടർ ( Plotter ) :‬‭ഗ്രാഫുകളുടെയും ഡിസൈനുകളുടെയും ഹാർഡ്‌കോപ്പികൾ നിർമ്മിക്കാൻ‬
‭ഉപയോഗിക്കുന്ന ഉപകരണമാണ്‬

‭ഡ്രം പ്ലോട്ടർ/‬
‭റോളർ പ്ലോട്ടർ‬

‭കറങ്ങുന്ന ഡ്രമ്മിന്റെ ഉപരിതലത്തിൽ പേപ്പർ ഘടിപ്പിച്ചിരിക്കുന്നു. ഡ്രോയിംഗ്‬
‭സിസ്റ്റം ഉപയോഗിച്ച്  ഗ്രാഫുകൾ വരയ്ക്കുന്നു.‬

‭ഫ്ലാറ്റ്ബെഡ് പ്ലോട്ട
‭(ടേബിൾ പ്ലോട്ടർ)‬

‭ഡ്രോയിംഗ് സിസ്റ്റം പേപ്പറിന് മുകളിലൂടെ നീങ്ങുകയും പേപ്പറിൽ ഗ്രാഫ്‬
‭വരയ്ക്കുകയും ചെയ്യുന്നു‬

‭1.5.4. ത്രീ ഡിമെൻഷനൽ (3D) പ്രിൻറർ :‬‭പ്ലാസ്റ്റിക് കളിപ്പാട്ടങ്ങൾ, മെറ്റൽ മെഷീൻ ഭാഗങ്ങൾ തുടങ്ങിയ
‭3D വസ്തുക്കൾ പ്രിന്റ് ചെയ്യാൻ ഉപയോഗിക്കുന്നു.‬

‭1.5.5 ഓഡിയോ ഔട്ട്പുട്ട് ഉപകരണം :‬‭ശബ്ദം പുറപ്പെടുവിക്കുന്ന ഔട്ട്പുട്ട് ഉപകരണമാണ്‬
‭സ്പീക്കറുകൾ‬

‭2. ******ഇ-വേസ്റ്റ് ( e-Waste / ഇ- മാലിന്യം )‬
‭ഉപേക്ഷിക്കപ്പെട്ട ഇലക്ട്രിക്കൽ അല്ലെങ്കിൽ ഇലക്ട്രോണിക് ഉപകരണങ്ങളാണ് ഇ-വേസ്റ്റ്.‬

‭*****‬‭ഇ-വേസ്റ്റ് നിർമാർജന രീതികൾ‬

‭പുനരുപയോഗം  ( Reuse )‬ ‭സെക്കൻഡ് ഹാൻഡ് ഉപയോഗമോ കേടുപാടുകൾ പരിഹരിച്ചുള്ള‬
‭ഉപയോഗമോ ആകുന്നു‬

‭കത്തിച്ചുകളയുക‬
‭( Incineration )‬

‭ഇൻസിനറേറ്ററുകളിൽ ഉയർന്ന താപനിലയിൽ മാലിന്യം കത്തിക്കുന്നു‬

‭റീസൈക്ലിങ് ( Recycling )‬ ‭ഇ-വേസ്റ്റിൽ നിന്ന് പുതിയ ഉൽപ്പന്നങ്ങൾ‬
‭നിർമ്മിക്കുന്നപ്രക്രിയയാണിത്.‬

‭കുഴിച്ചു മൂടുക( Land filling ) ‭മണ്ണ് കുഴിച്ച് അതിൽ ഇ-വേസ്റ്റ് കുഴിച്ചിടുന്നു‬

‭2.1 ഇ-വേസ്റ്റ് നിർമാർജനത്തിൽ വിദ്യാർത്ഥികളുടെ പങ്ക്‬
‭●‬ ‭അനാവശ്യ ഇലക്ട്രോണിക് ഉപകരണങ്ങൾ വാങ്ങുന്നത് ഒഴിവാക്കുക.‬

‭●‬ ‭ഉപകരണങ്ങൾ തകരാറിലാകുമ്പോൾ പുതിയത് വാങ്ങുന്നതിന് പകരം നന്നാക്കാൻ ശ്രമിക്കുക.‬

‭●‬ ‭ഉപകരണങ്ങൾ റീസൈക്കിൾ ചെയ്യാൻ ശ്രമിക്കുക‬

‭●‬ ‭ഡിസ്പോസിബിൾ ബാറ്ററികൾക്ക് പകരം റീചാർജബിൾ ഉപകരണം വാങ്ങുക‬
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‭3. ഗ്രീൻ കമ്പ്യൂട്ടിംഗ് /  ഗ്രീൻ ഐ.ടി‬

‭പ്രകൃതിക്കു കോട്ടം തട്ടാതെയുള്ള സാങ്കേതികവിദ്യയുടെ പഠനവും ഉപയോഗവുമാണിത്.‬

‭3.1. ഗ്രീൻ കമ്പ്യൂട്ടിംഗ് പ്രോത്സാഹിപ്പിക്കുന്നതിന് ഉപയോഗിക്കുന്ന 4 രീതികൾ‬

‭ഗ്രീൻ ഡിസൈൻ,ഗ്രീൻ മാനുഫാക്ച്ചറിങ്, ഗ്രീൻ യൂസ്, ഗ്രീൻ ഡിസ്പോസൽ‬

‭4.സോഫ്റ്റ്‌വെയർ :‬

‭കമ്പ്യൂട്ടറിനെ പ്രവർത്തിക്കുവാനാവശ്യമായ ഒരു കൂട്ടം പ്രോഗ്രാമുകളാണ് സോഫ്റ്റ്‌വെയർ.‬

‭2 തരം സോഫ്റ്റ്‌വെയർ‬‭:‬

‭4.1. സിസ്റ്റം സോഫ്റ്റ്‌വെയർ :‬‭ഒരു കമ്പ്യൂട്ടറിന്റെ പ്രവർത്തനങ്ങൾ നിയന്ത്രിക്കാൻ രൂപകൽപ്പന‬

‭ചെയ്ത പ്രോഗ്രാമുകളുടെ ഒരു കൂട്ടമാണിത്‬‭.‬ ‭3 തരം സിസ്റ്റം സോഫ്റ്റ്വെയറിന്റെ ഘടകങ്ങൾ  :‬

‭4.1.A.  ഓപ്പറേറ്റിംഗ് സിസ്റ്റം  (OS)‬‭:‬‭യൂസറിനും ഹാർഡ് വെയറിനും ഇടയിൽ ഇന്റർഫേസ് ആയി‬

‭പ്രവർത്തിക്കുന്ന സിസ്റ്റം സോഫ്റ്റ് വെയറാണ് ഓപ്പറേറ്റിംഗ് സിസ്റ്റം.‬

‭*****‬‭ഓപ്പറേറ്റിംഗ് സിസ്റ്റത്തിന്റെ 4 പ്രധാന പ്രവർത്തനങ്ങൾ‬

‭4.1.A.‬‭1 പ്രോസസ്സ് മാനേജ്മെന്റ്  :‬‭ഓപ്പറേറ്റിംഗ് സിസ്റ്റത്തിൽ ഒരേസമയം പ്രവർത്തിക്കുന്ന നിരവധി‬

‭പ്രോസസ്സുകൾ കൈകാര്യം ചെയ്യുന്നതിനുള്ള ഒരു നടപടിക്രമമാണിത്.‬

‭4.1.A‬‭.2 മെമ്മറി മാനേജ്മെന്റ് :‬‭ഒരു കമ്പ്യൂട്ടറിന്റെ പ്രധാന മെമ്മറി നിയന്ത്രിക്കുകയും‬

‭ഏകോപിപ്പിക്കുകയും ചെയ്യുന്നു.‬

‭4.1.A‬‭.3 ഫയൽ മാനേജ്മെന്റ്  :‬‭ഫയൽ സ്റ്റോറിങ്,വീണ്ടെടുക്കൽ, ഷെയറിങ്, പ്രൊട്ടക്ഷൻ‬

‭തുടങ്ങിയ ഫയലുമായി ബന്ധപ്പെട്ട പ്രവർത്തനങ്ങൾ ചെയ്യുന്നു.‬

‭4.1.A‬‭.4 ഡിവൈസ്  മാനേജ്മെന്റ് :‬‭കമ്പ്യൂട്ടറിൽ ഘടിപ്പിച്ചിരിക്കുന്ന ഹാർഡ് വെയർ‬

‭ഡിവൈസുകളെ നിയന്ത്രിക്കുന്നു.‬

‭*!‬‭OSന് ഉദാഹരണം‬‭:  DOS, Windows, Unix, Linux, Mac iOS, Ubuntu, Android OS‬

‭*****‬‭4.1.B.  ലാംഗ്വേജ് പ്രോസസ്സറുകൾ‬‭:‬‭കമ്പ്യൂട്ടറിനു മനസിലാകുന്ന മെഷീൻ ഭാഷയിലേക്കു‬

‭ഹൈ-ലെവൽ & അസംബ്ലി ഭാഷകളെ മാറ്റുന്നു.‬

‭****‬‭വ്യത്യസ്ത തരം ലാംഗ്വേജ് പ്രോസസ്സറുകൾ‬

‭4.1.B.1. അസ്സെംബ്ലർ‬ ‭:‬‭അസംബ്ലി ലാംഗ്വേജിലുള്ള കോഡിനെ മെഷീൻ ഭാഷയിലേക്കു മാറ്റുന്നു‬‭.‬

‭4.1.B.2. ഇന്റെർപ്രെറ്റർ :‬‭ഹൈലെവൽ ലാംഗ്വേജിലുള്ള പ്രോഗ്രാമിനെ ഓരോ വരിവരിയായി‬

‭മെഷീൻ ലാംഗ്വേജിലേക്ക് പരിവർത്തനം മാറ്റുന്നു.‬

‭4.1.B.3. കംപൈലർ :‬‭ഹൈലെവൽ ലാംഗ്വേജിലുള്ള പ്രോഗ്രാമിന്റെ മുഴുവൻ ലൈനുകളും ഒരേ‬

‭സമയം മെഷീൻ ലാംഗ്വേജിലേക്ക് മാറ്റുന്നു.‬

‭*****‬‭4.1.C.  യൂട്ടിലിറ്റി സോഫ്റ്റ് വെയർ  :‬‭സിസ്റ്റം മെയിന്റനൻസ് ജോലികളിൽ സഹായിക്കുന്ന‬

‭പ്രോഗ്രാമുകളാണിത്.‬

‭ഉദാഹരണം :‬‭കംപ്രഷൻ ടൂൾസ് , ഡിസ്ക് ഡീഫ്രാഗ്മെന്റർ , ബാക്കപ്പ് സോഫ്റ്റ്‌വെയർ , ആൻറിവൈറസ്‬

‭4.2. അപ്ലിക്കേഷൻ സോഫ്റ്റ്‌വെയർ:‬

‭ഒരു പ്രത്യേക ആവശ്യത്തിനായി നിർമിക്കുന്ന സോഫ്റ്റ്-വേറുകളാണിത്.‬
‭4.2.A‬‭പൊതു ആവശ്യത്തിനുള്ള സോഫ്റ്റ്‌വെയർ പാക്കേജുകൾ :‬‭വേർഡ് പ്രോസസ്സിംഗ് സോഫ്റ്റ്‌വെയർ,‬

‭സ്പ്രെഡ്ഷീറ്റ്, പ്രസന്റേഷൻ സോഫ്റ്റ്‌വെയർ,ഡാറ്റാബേസ് സോഫ്റ്റ്‌വെയർ,മൾട്ടീമീഡിയ സോഫ്റ്റ്‌വെയർ‬

‭4.2.B‬‭പ്രത്യേക ആവശ്യത്തിനുള്ള സോഫ്റ്റ്‌വെയർ :‬

‭ഉദാഹരണം:‬‭പേറോൾ സിസ്റ്റം ,ഇൻവെന്ററി മാനേജ്‌മന്റ്,സിസ്റ്റം ,ഹ്യൂമൻ റിസോഴ്സ് മാനേജ്‌മന്റ് സിസ്റ്റം.‬
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‭5. ഫ്രീ & ഓപ്പൺ സോഴ്സ് സോഫ്റ്റ്‌വെയർ‬‭:‬

‭ഉപയോക്താവിന് സോഫ്റ്റ്‌വെയർ ഉപയോഗിക്കാനും പകർത്താനും,വിതരണം‬

‭ചെയ്യാനും,പരിശോധിക്കുക,‬

‭മാറ്റം വരുത്തുക, മെച്ചപ്പെടുത്തുക എന്നിവയ്ക്ക് സ്വാതന്ത്ര്യം നൽകുന്നു.‬

‭******ഉപയോക്താവിന് നൽകിയിരിക്കുന്ന സ്വാതന്ത്ര്യം ഏതെല്ലാം?‬

‭ഫ്രീഡം 0 : ഏത് ആവശ്യത്തിനും പ്രോഗ്രാം പ്രവർത്തിപ്പിക്കാനുള്ള സ്വാതന്ത്ര്യം‬

‭ഫ്രീഡം 1 :പ്രോഗ്രാം എങ്ങനെ പ്രവർത്തിക്കുന്നുവെന്ന് പഠിക്കാനും, മാറ്റം വരുത്തുവാനുള്ള‬

‭സ്വാതന്ത്ര്യം.‬

‭ഫ്രീഡം 2 : സോഫ്റ്റ്‌വെയറിന്റെ പകർപ്പുകൾ വിതരണം ചെയ്യാനുള്ള സ്വാതന്ത്ര്യം.‬

‭ഫ്രീഡം 3 : പ്രോഗ്രാം മെച്ചപ്പെടുത്താനും ,മെച്ചപ്പെടുത്തലുകൾ പൊതുജനങ്ങൾക്ക്‬

‭നൽകാനുമുള്ള സ്വാതന്ത്ര്യം.‬

‭ഉദാഹരണം : ഗ്നു/ലിനക്സ് ,ജിമ്പ്,മോസില്ല ഫയർഫോക്സ്,ഓപ്പൺഓഫീസ്.org‬

‭******‬‭6. ഫ്രീവെയർ & ഷെയർവെയർ‬‭:‬

‭ഫ്രീവെയർ‬ ‭ഷെയർവെയർ‬

‭ഇന്റർനെറ്റിൽ നിന്ന് ഡൗൺലോഡ് ചെയ്ത്‬
‭സൗജന്യമായി ഉപയോഗിക്കാവുന്നതാണ്‬

‭വിലകൊടുത്തു വാങ്ങുന്നതിന് മുമ്പ്  സോഫ്റ്റ്‌വെയർ‬
‭ഉപയോഗിച്ച നോക്കുവാൻ അവസരം നൽകുന്നു‬

‭സോഫ്ട്‍വെയറിന്റെ എല്ലാ ഫീച്ചറും‬
‭സൗജന്യമായി ലഭിക്കുന്നു‬

‭എല്ലാ ഫീച്ചറും ലഭ്യമല്ല എന്നാൽ വിലകൊടുത്തു വാങ്ങിയാൽ‬
‭എല്ലാ ഫീച്ചറും ലഭ്യമാക്കാം‬

‭സൗജന്യമായി സോഫ്റ്റ്‌വെയർ വിതരണം‬
‭ചെയ്യാം‬

‭സൗജന്യമായോ അല്ലാതെയോ വിതരണം ചെയ്യാൻ പാടില്ല‬

‭7. ഹ്യൂമൻവെയർ/ ലൈവ് വെയർ  :‬‭കമ്പ്യൂട്ടർ ഉപയോഗിക്കുന്ന മനുഷ്യരെ സൂചിപ്പിക്കുന്നു.‬

‭വ്യത്യസ്ത ഹ്യൂമൻ വെയർ :‬‭സിസ്റ്റം അഡ്മിനിസ്ട്രേറ്റർ,സിസ്റ്റം മാനേജർ,സിസ്റ്റം‬

‭അനലിസ്റ്റ്,ഡാറ്റാബേസ് അഡ്മിനിസ്ട്രേറ്റർ, കമ്പ്യൂട്ടർ എഞ്ചിനീയർ,കമ്പ്യൂട്ടർ പ്രോഗ്രാമർ,കമ്പ്യൂട്ടർ‬

‭ഓപ്പറേറ്റർ‬
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‭XI  - CHAPTER - 3‬

‭DATA PROCESSING WITH ELECTRONIC SPREADSHEET‬

‭1. എന്താണ് ഇലക്ട്രോണിക് സ്പ്രെഡ്ഷീറ്റ് ?‬‭:‬‭ഡാറ്റയുടെ കണക്കുകൂട്ടൽ, ഓർഗനൈസേഷൻ,‬

‭വിശകലനം, സംഭരണം എന്നിവയെല്ലാം ടേബിൾ രൂപത്തിൽ അവതരിപ്പിക്കുന്ന ഒരു കമ്പ്യൂട്ടർ അപ്ലിക്കേഷൻ.‬

‭2. ഇലക്ട്രോണിക് സ്പ്രെഡ്ഷീറ്റിന്റെ സവിശേഷതകൾ‬

‭●‬ ‭അനേകം ഡാറ്റ ടേബിൾ രൂപത്തിൽ സംഭരിക്കാം‬

‭●‬ ‭ഫോർമുലകളും ഫംഗ്‌ഷനുകളും ഉപയോഗിച്ച് കണക്കുകൂട്ടലുകൾ, താരതമ്യങ്ങൾ, വിശകലനം‬

‭എന്നിവ നടത്താം.‬

‭●‬ ‭ബന്ധപ്പെട്ട ഡാറ്റയിൽ മാറ്റം വരുത്തിയാൽ, റിസൾട്ടും അപ്ഡേറ്റ് ആകുന്നു.‬

‭●‬ ‭അലൈൻമെന്റ്, ബോർഡറുകൾ, മെർജ് സെൽ, ഫോണ്ട് സെറ്റിങ് തുടങ്ങിയ ടെക്സ്റ്റ് ഫോർമാറ്റിംഗ്‬

‭സവിശേഷതകൾ നൽകുന്നു.‬

‭●‬ ‭സോർട്ടിംഗ്, ഫിൽട്ടറിംഗ് തുടങ്ങിയ സൗകര്യങ്ങൾ ഉണ്ട്.‬

‭●‬ ‭ഗ്രാഫിക്കൽ-ഡാറ്റ വിശകലനത്തിനായി ചാർട്ടുകൾ നിർമിക്കാം.‬

‭3.‬‭സ്പ്രെഡ്ഷീറ്റിന്റെ അടിസ്ഥാനകാര്യങ്ങൾ‬

‭സെൽ :‬‭റോയും കോളവും കൂടിച്ചേരുന്നിടം. വർക്ക് ഷീറ്റിലെ ഏറ്റവും  ചെറിയ യൂണിറ്റ് ആണിത്.‬

‭ആക്റ്റീവ് സെൽ :‬‭ബോൾഡ് ബൗണ്ടറിയുള്ള സെല്ലിൽ മാത്രമേ ഡാറ്റ നൽകാനാകൂ.‬

‭4. വർക്ക്ഷീറ്റ് വിൻഡോയുടെ ഘടകങ്ങൾ‬

‭●‬ ‭ടൈറ്റിൽ ബാർ:‬‭ഫയലിന്റെയും, സോഫ്റ്റ് വെയറിന്റെയും പേര് കാണപ്പെടുന്ന‬

‭വിൻഡോയുടെ മുകളിലെ ഭാഗം.‬

‭●‬ ‭മെനു ബാർ :‬‭ഫയൽ, എഡിറ്റ്, വ്യൂ , ഇൻസേർട്ട് തുടങ്ങിയ മെനു ഓപ്ഷനുകൾ കാണാം.‬

‭●‬ ‭ടൂൾ ബാർ :‬‭പ്രധാനപ്പെട്ട കമാൻഡ്കളുടെ ഷോർട് കട്ട് ബട്ടൺ കാണപ്പെടുന്നു.‬

‭●‬ ‭ഫോർമുല ബാർ:‬ ‭ഫോർമുലകൾ ഉൾപ്പെടുന്ന ഭാഗം‬

‭●‬ ‭ഷീറ്റ് ടാബ് :‬‭വർക്ക് ഷീറ്റിനു താഴെ ഇടതുവശത്ത് ദൃശ്യമാകുന്ന ചതുരാകൃതിയിലുള്ള‬

‭ടാബുകളാണ്. ഡിഫോൾട് ആയി 3  ടാബുകളുണ്ടാകും‬

‭●‬ ‭സ്റ്റാറ്റസ് ബാർ :‬‭വർക്ക്ഷീറ്റിന്റെ നിലവിലെ അവസ്ഥ കാണപ്പെടുന്നു.‬

‭*****5. സെല്ലിൽ നൽകാവുന്ന ഡാറ്റകൾ ( ഡാറ്റ ടൈപ്പുകൾ )‬

‭➤‬‭നമ്പർ‬ ‭➤‬‭ടെക്സ്റ്റ്‬ ‭➤‬‭തീയതിയും സമയവും‬ ‭➤‬‭ഫോർമുല‬

‭6. സ്പ്രെഡ്ഷീറ്റ് ഫോർമാറ്റ് ചെയ്യുന്ന വിധം‬

‭സ്‌പ്രെഡ്‌ഷീറ്റിലുള്ള ഡാറ്റയുടെ രൂപഭംഗിയും, ക്രമീകരണവമാണ് ഫോർമാറ്റിംഗ്.‬

‭അതിലൂടെ വർക്ക് ഷീറ്റിനെ ആകർഷകമാക്കുന്നു.‬

‭6.1. ഫോർമാറ്റിംഗ് സെൽ :‬

‭Step 1 : Format Cells‬

‭Step 2 : Format Cells എന്ന ഡയലോഗ് ബോക്സിലെ വ്യത്യസ്ത tab ഉപയോഗിക്കാം.‬

‭6.2. ഫോർമാറ്റ് കോളം    :‬ ‭Format  ->  Column‬

‭6.3. ഫോർമാറ്റ് റോ          :‬ ‭Format -> Row‬

‭6.4  ഫോർമാറ്റ് ഷീറ്റ്        :‬ ‭Format -> Sheet‬

‭***6.5  മെർജ് സെൽ‬ ‭:‬ ‭ഒന്നിലധികം സെല്ലുകളെ ഒരു സെല്ലിലേക്ക് യോജിപ്പിക്കുന്നതാണിത്.‬

‭Step 1 : യോജിപ്പിക്കേണ്ട സെല്ലുകൾ തിരഞ്ഞെടുക്കുക.‬

‭Step 2 : Format -> Merge Cells‬
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‭7. സെൽ,റോ,കോളം & വർക്ക് ഷീറ്റ്‬‭ഇൻസേർട്‬‭ചെയ്യുന്ന വിധം‬

‭7.1.‬‭സെൽ ഇൻസേർട് :‬‭Step 1 : പുതിയ സെൽ ചേർക്കേണ്ട ഭാഗത്തെ സെൽ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Insert -> Cells‬

‭7.2.‬‭റോ ഇൻസേർട് :‬

‭Step 1 : പുതിയ റോ ഇൻസേർട് ചെയ്യേണ്ട ഭാഗത്തെ സെൽ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Insert -> Row‬

‭7.3.‬‭കോളം ഇൻസേർട് :‬‭Step 1 : പുതിയ കോളം ചേർക്കേണ്ട ഭാഗത്തെ സെൽ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Insert -> Column‬

‭7.4.‬‭ഷീറ്റ് ഇൻസേർട് :‬ ‭Step 1 : Sheet -> Insert -> Sheet‬

‭8. സെൽ,റോ,കോളം & വർക്ക് ഷീറ്റ്‬‭ഡിലീറ്റ്‬ ‭ചെയ്യുന്ന വിധം‬

‭8.1.‬‭സെൽ ഡിലീറ്റ്  :‬ ‭Step 1 : ഡിലീറ്റ് ചെയ്യേണ്ട സെൽ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Delete Cells‬

‭Step 3 :‬‭വരുന്ന ഡയലോഗ് ബോക്സിൽ ആവശ്യമായ ഓപ്ഷൻ സെലക്ട് ചെയ്യുക‬

‭Step 4 : OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬

‭8.2.‬‭റോ ഡിലീറ്റ്  :‬ ‭Step 1 : ഡിലീറ്റ് ചെയ്യേണ്ട റോ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Delete Row‬

‭8.3.‬‭കോളം ഡിലീറ്റ്  :‬ ‭Step 1 : ഡിലീറ്റ് ചെയ്യേണ്ട കോളം സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Delete Column‬

‭8.4.‬‭ഷീറ്റ് ഡിലീറ്റ്  :‬ ‭Step 1 : ഡിലീറ്റ് ചെയ്യേണ്ട Sheet സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Delete Sheet‬

‭Step 3 : വരുന്ന ഡയലോഗ് ബോക്സിൽ Yes/No ക്ലിക്ക് ചെയ്യുക.‬

‭9. സ്‌പ്രെഡ്‌ഷീറ്റുകളിലെ‬‭എഡിറ്റിംഗ് ഫീച്ചറുകൾ‬

‭9.1.‬‭സെൽ റേഞ്ച് ഫിൽ ചെയ്യുന്ന വിധം :‬

‭****‬‭കോളത്തിൽ 1 മുതൽ 100 ​​വരെയുള്ള തുടർച്ചയായ സംഖ്യകൾ എങ്ങനെ നൽകും‬

‭Step 1 : ആദ്യത്തെ സെല്ലിൽ വാല്യൂ 1 മുതൽ 100 വരെ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Sheet -> Fill Cells -> Series‬

‭Step 3 : Fill Series ഡയലോഗ് ബോക്സിൽ Start value: 1 & Increment: 1 എന്റർ ചെയ്യുക -> OK‬

‭അല്ലെങ്കിൽ‬

‭സെല്ലിൽ ആദ്യനമ്പർ 1 ടൈപ്പ് ചെയ്യുക. മൗസ് ഉപയോഗിച്ചു സെല്ലിന്റെ മൂലയിൽ ക്ലിക്ക്‬

‭ചെയ്തു കൊണ്ട് 100 മത്തെ സെൽ വരെ ഡ്രാഗ് ചെയ്യുക.‬

‭9.1.1.‬‭സെല്ലുകൾ കോപ്പി ചെയ്യുന്നതിനുമുള്ള മാർഗങ്ങൾ‬

‭Step 1 : കോപ്പി ചെയ്യേണ്ട സെൽ സെലക്ട് ചെയ്യുക‬

‭Step 2 : Edit -> Copy or‬‭Ctrl+C‬

‭Step 3 : പേസ്റ്റ് ചെയ്യേണ്ട സെൽ സെലക്ട് ചെയ്യുക‬

‭Step 4 : Edit -> Paste or‬‭Ctrl+V‬

‭9.1.2.‬‭മൂവ് ചെയ്യുന്നതിനുമുള്ള മാർഗങ്ങൾ‬

‭Step 1 :‬‭മൂവ്‬‭ചെയ്യേണ്ട സെൽ സെലക്ട് ചെയ്യുക‬

‭Step 2 : Edit -> Cut or‬‭Ctrl+X‬

‭Step 3 : പേസ്റ്റ് ചെയ്യേണ്ട സെൽ സെലക്ട് ചെയ്യുക‬

‭Step 4 : Edit -> Paste or‬‭Ctrl+V‬
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‭*****‬‭10. റോ & കോളം ഫ്രീസ് ചെയ്യുന്ന വിധം‬

‭വർക്ക്ഷീറ്റ് സ്ക്രോൾ ചെയ്യുമ്പോൾ തിരഞ്ഞെടുത്ത റോ & കോളം സ്ഥാന ചലനം‬

‭സംഭവിക്കാതെ ലോക്ക് ചെയ്യുന്നു.‬

‭Step 1 : ഫ്രീസ് ചെയ്യേണ്ട റോ / കോളം സെലക്ട് ചെയ്യുക‬

‭Step 2 : View -> Freeze Cells -> Freeze First Columns അല്ലെങ്കിൽ Freeze First Row ക്ലിക്ക്‬

‭ചെയ്യുക.‬

‭10.1 ഫ്രീസിങ്ങിന്റെ ഗുണം‬
‭ഹെഡിങ് ഉൾപ്പെടുന്ന ആദ്യ റോയോ കോളമോ ഫ്രീസ് ( ലോക്ക് ) ചെയ്യുന്നതിലൂടെ വർക്ക്ഷീറ്റിന്റെ‬

‭ഏതൊരു ഏരിയയിലേക്കും സ്ക്രോൾ ചെയ്യുമ്പോൾ, ഹെഡിങ് നിശ്ചലമായിരിക്കുകയും‬

‭കൃത്യമായി ഡാറ്റ ഐഡന്റിഫൈ ചെയ്യാനും സാധ്യമാക്കുന്നു.‬

‭******‬‭11. സെൽ റഫറൻസിങ് :‬‭സെൽ റഫറൻസ് സെല്ലിന്റെ അഡ്രസ് ആയി പ്രവർത്തിക്കുന്നു.‬

‭ഉദാ :‬‭B2 എന്നത് കോളം B-യിലെ രണ്ടാമത്തെ സെല്ലിനെ സൂചിപ്പിക്കുന്നു.‬

‭റിലേറ്റീവ് സെൽ റഫറൻസ്‬‭:‬

‭ഒരു സെല്ലിൽ നിന്ന് മറ്റൊരു സെല്ലിലേക്ക് ഫോർമുലയും മറ്റും കോപ്പി ചെയ്യപെടുമ്പോഴും,‬

‭autofill ഉപയോഗിക്കുമ്പോഴും സെല്ലിനനുസരിച് അഡ്രസ് മാറുന്നു.‬

‭അബ്സല്യൂട് സെൽ റഫറൻസ്‬‭:‬‭ഒരേ ഫോർമുല ഒരു സെല്ലിൽ നിന്ന് മറ്റു സെല്ലിലേക്ക്‬

‭കോപ്പി ചെയ്യുമ്പോൾ, അതിന്റെ സെൽ അഡ്രസ് മാറേണ്ട ആവശ്യമില്ല. ഇവിടെ Absolute‬

‭സെൽ റഫറൻസ് ഉപയോഗിക്കുന്നു.Eg:Relative - A3 & Absolute - $A$3‬

‭12. പേജ് ഫോർമാറ്റിംഗ് & വർക്ക്ഷീറ്റ് പ്രിന്റ്‬

‭12.1 പ്രിന്റ് റേഞ്ച്   :‬‭സ്പ്രെഡ്ഷീറ്റിലെ ഡാറ്റയുടെ ഒരു പ്രത്യേക ഭാഗമോ കോളമോ റോയോ  മാത്രം‬

‭പ്രിന്റ് ചെയ്യാൻ അനുവദിക്കുന്നു.‬

‭Step 1 : Format -> Print Ranges -> Edit‬

‭Step 2 : ആവശ്യമായ വാല്യൂ എന്റർ ചെയ്തു OK ക്ലിക്ക് ചെയ്യുക.‬

‭12.2. ഹെയ്ഡർ & ഫൂട്ടർ : പേജിന്റെ മുകളിലെ ടെക്സ്റ്റ്, ഹെഡ്‍റും താഴെ ഫൂട്ടറും കാണപ്പെടുന്നു.‬

‭Step 1 : Insert -> Headers and Footers‬

‭Step 2 : ആവശ്യമായ വാല്യൂ എന്റർ ചെയ്തു OK ക്ലിക്ക് ചെയ്യുക.‬

‭12.3. പേജ് ബ്രേക്കുകൾ : വർക്ക്ഷീറ്റിന്റെ ഉള്ളടക്കം ദൈർഘ്യമേറിയതാണെങ്കിൽ,  പ്രിന്റ്‬

‭ചെയ്യുമ്പോൾ പേപ്പറിന്റെ വലിപ്പം അനുസരിച്ച് പേജ് ബ്രേക്കുകൾ ചേർക്കുന്നു.‬

‭12.4. പേജ് സ്റ്റൈൽ സെറ്റിങ് : പേപ്പർ വലുപ്പം / ഫോർമാറ്റ്, ഓറിയന്റേഷനും മാർജിനുകളും‬

‭സജ്ജമാക്കാൻ.‬

‭Step 1 : Format -> Page Style -> Page‬

‭Step 2 : ആവശ്യമായ വാല്യൂ എന്റർ ചെയ്തു OK ക്ലിക്ക് ചെയ്യുക. ലാൻഡ്‌സ്‌കേപ്പ്‬

‭ഓറിയെന്റഷൻ ഹൊറിസോണ്ടൽ ലേഔട്ട് ആണ്. പോർട്രൈറ്റ് ലേഔട്ട് വെർട്ടിക്കലുമാണ്.‬
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‭X1  - CHAPTER - 4‬

‭DATA ANALYSIS USING SPREADSHEET‬

‭1.      ഫോർമുല :‬‭സെല്ലിൽ വാല്യൂ കാണുന്നതിന് ഉപയോഗിക്കുന്ന സ്പ്രെഷനാണിത്.‬

‭ഫംഗ്‌ഷനുകൾ :‬‭സ്‌പ്രെഡ്‌ഷീറ്റുകളിൽ മുൻകൂട്ടി നിശ്ചയിച്ചിരിക്കുന്ന ഫോർമുലകളാണിത്.‬

‭മാത്തമാറ്റിക്കൽ‬
‭ഫംഗ്‌ഷനുകൾ‬

‭ഫംഗ്‌ഷനുകൾ ‭ഉപയോഗം‬

‭SUM ( )‬ ‭ഒരു കൂട്ടം സംഖ്യകളുടെയും,റേഞ്ചിലെ സംഖ്യകളുടെയും തുക‬
‭കാണുന്നതിന്.‬ ‭Syntax :    = SUM ( Number1,Number2,Number3,........)‬

‭ROUND( )‬ ‭സംഖ്യയെ നിശ്ചിത ദശാംശ സ്ഥാനങ്ങളിലേക്ക് റൗണ്ട് ചെയ്യുന്നു‬
‭Syntax:      =ROUND ( Number ,Count)‬

‭ROUND‬
‭UP( )‬

‭സംഖ്യയെ അതിന്റെ ഏറ്റവും അടുത്തുള്ള പൂർണ്ണസംഖ്യയിലേക്ക്‬
‭റൗണ്ട് ചെയ്യുന്നു.‬ ‭Syntax :     = ROUNDUP( Number ,Count)‬

‭ROUND‬
‭DOWN( )‬

‭ദശാംശ സ്ഥാനത്തുള്ള അക്കത്തിന്റെ വലതു വശത്തുള്ള അക്കങ്ങൾ‬
‭നീക്കം ചെയ്യുവാൻ.‬ ‭Syntax :    = ROUNDDOWN ( Number ,Count)‬

‭COUNTIF( )‬ ‭ഒരു റേഞ്ചിൽ തന്നിരിക്കുന്ന കണ്ടീഷന് വിധേയമായി വരുന്ന വിലകളുടെ‬
‭എണ്ണം കാണുന്നു.‬ ‭Syntax :‬ ‭= COUNTIF (Range, Criteria)‬

‭സ്റ്റാറ്റിസ്റ്റിക്കൽ‬
‭ഫംഗ്‌ഷനുകൾ‬

‭AVERAGE( )‬ ‭ഒരു കൂട്ടം (റേഞ്ചിൽ) സംഖ്യകളുടെ ആവറേജ് കാണുന്നതിന്‬
‭Syntax: AVERAGE ( Number1, Number2,Number3..)‬

‭MAX( )‬ ‭ഒരു കൂട്ടം (റേഞ്ചിൽ)സംഖ്യകളിൽ നിന്ന് ഏറ്റവും വലിയ കാണുന്നതിന്.‬
‭Syntax:‬‭MAX ( Number1, Number2,Number3..)‬

‭MIN( )‬ ‭ഒരു കൂട്ടം (റേഞ്ചിൽ) സംഖ്യകളിൽ നിന്ന് ഏറ്റവും ചെറിയ കാണുന്നതിന്.‬
‭Syntax: MIN ( Number1, Number2,Number3..)‬

‭COUNT( )‬ ‭ആർഗ്യുമെന്റിൽ (റേഞ്ചിൽ) കൊടുത്തിരിക്കുന്ന സംഖ്യകളുടെ എണ്ണം‬
‭കാണുന്നതിന്.‬ ‭Syntax: COUNT ( Number1, Number2,Number3..)‬

‭ലോജിക്കൽ‬
‭ഫംഗ്‌ഷനുകൾ‬

‭IF()‬ ‭നൽകുന്ന കണ്ടീഷൻ ശരിയോ,തെറ്റോ അനുസരിച്ച വാല്യൂ നൽകുന്നു.‬
‭Syntax:  =IF(Condition,Truevalue,Falsevalue)‬

‭AND()‬ ‭ആർഗ്യുമെന്റിലെ എല്ലാ കണ്ടിഷനും ശരിയാണെങ്കിൽ മാത്രം TRUE വാല്യൂ‬
‭നൽകുന്നു,അല്ലാതെ വന്നാൽ FALSE വാല്യൂ നൽകുന്നു.‬
‭Syntax: AND(Logical value1, Logical value2,........)‬

‭OR()‬ ‭ആർഗ്യുമെന്റിലെ ഏതെങ്കിലും ഒരു കണ്ടീഷൻ TRUE ആണെങ്കിൽ TRUE‬
‭നൽകുന്നു, ഏതെങ്കിലും FALSE ആയാൽ മാത്രം false നൽകുന്നു.‬
‭Syntax : OR(Logical value1, Logical value2,........)‬

‭NOT()‬ ‭NOT ഫംഗ്‌ഷൻ TRUE എന്നത് FALSE ആയും FALSE എന്നത് TRUE ആയും‬
‭മാറ്റുന്നു.‬ ‭Syntax : NOT ( Logical value)‬

‭ടെക്സ്റ്റ്‬
‭ഫംഗ്‌ഷനുകൾ‬

‭UPPER( )‬ ‭വാചകം വലിയക്ഷരത്തിലേക്ക് (Capital /Uppercase letter )മാറ്റുന്നു.‬
‭Syntax :‬ ‭UPPER(Text)‬

‭LOWER()‬ ‭വാചകം ചെറിയ അക്ഷരത്തിലേക്ക് മാറ്റുന്നു.(Small /lowercase )‬
‭Syntax : LOWER(Text)‬

‭LEN()‬ ‭ടെക്സ്റ്റിലെ അക്ഷരങ്ങളുടെ എണ്ണം കാണുന്നു.‬ ‭Syntax : LEN(Text)‬
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‭2. നെസ്‌റ്റഡ്‌ ഫംഗ്‌ഷനുകൾ :‬‭ഫംഗ്‌ഷന്റെ ഉള്ളിൽ മറ്റൊരു ഫംഗ്‌ഷൻ ഉൾപ്പെടുത്തുന്നു.‬

‭3. ഡാറ്റ മാനിപുലേഷൻ :‬‭സ്പ്രെഡ്ഷീറ്റിൽ ഒരു പ്രത്യേക ഡാറ്റ കണ്ടെത്താൻ ഉപയോഗിക്കുന്നു.‬

‭3.1 സോർട്ടിങ് :‬‭ഒന്നോ അതിലധികമോ കോളങ്ങളിൽ ഡാറ്റയെ ആരോഹണ അല്ലെങ്കിൽ‬

‭അവരോഹണ ക്രമത്തിലാക്കുന്നു.‬

‭Step 1 : ടേബിളിനെ സെലക്ട് ചെയ്യുക‬

‭Step 2 : MenuBar–>‬‭Data‬‭--> Sort‬

‭Step 3 : Sort by ലിസ്റ്റിൽ നിന്നും ആവശ്യമായ കോളം സെലക്ട് ചെയ്യുക‬

‭Step 4 : ആരോഹണമോ അവരോഹണമോ എന്ന് സെലക്ട് ചെയ്യുക.‬

‭Step 5 : OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬

‭3.2  ഫിൽറ്ററിങ് :‬‭കണ്ടീഷന് അടിസ്ഥാനമാക്കി ഡാറ്റകൾ ഡിസ്‌പ്ലൈ ചെയ്യുന്നു.മറ്റുള്ളവ‬

‭മറച്ചു വെക്കുന്നു.നമുക്ക് വേണ്ട വിവരങ്ങൾ മാത്രം വേഗത്തിൽ നൽകുന്നു.‬

‭3.2.A.‬‭Auto filter :‬‭ഓരോ കോളത്തിലും കാണുന്ന ഡ്രോപ്പ് ഡൌൺ ലിസ്റ്റിലെ‬

‭വിലകളെ അടിസ്ഥാനമാക്കി പ്രത്യേക റോകളെ മാത്രം ഡിസ്‌പ്ലൈ ചെയ്യുന്നു.‬

‭Step 1 : ടേബിളിനെ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Data→Filter→AutoFilter‬

‭3.2.A.‬‭സ്റ്റാൻഡേർഡ് ഫിൽറ്റർ :‬‭ഒന്നോ അതിലധികമോ ലോജിക്കൽ കണ്ടിഷൻ‬

‭ഉപയോഗിച്ച് ഡാറ്റയെ ഫിൽറ്റർ ചെയ്യുന്നു.‬

‭Step 1 : ടേബിളിനെ സെലക്ട് ചെയ്യുക.‬

‭Step 2 : Data→Filter→Standard Filter‬

‭4. ചാർട്ട്‬ ‭:‬ ‭കൂടുതൽ മനസ്സിലാക്കാവുന്ന രീതിയിൽ ഡാറ്റയെ ചിത്രരൂപത്തിൽ അവതരിപ്പിക്കുന്നു.‬

‭അതിലൂടെ വളരെ എളുപ്പത്തിൽ താരതമ്യം സാധ്യമാക്കുന്നു.‬

‭Steps 1 : ഡാറ്റ റേഞ്ച് സെലക്ട് ചെയ്യുക‬

‭Step 2 : Insert →Chart‬

‭Step 3 :‬‭Chart Type‬‭സെലക്ട് ചെയ്യുക.‬

‭Step 4 : Chart Elementsൽ ക്ലിക്ക് ചെയ്യുക.‬

‭Step 5 : Finishൽ ക്ലിക്ക് ചെയ്യുക.‬

‭4.1 വിവിധ തരാം ചാർട്ടുകൾ‬

‭4.1.A.‬‭ബാർ ചാർട്ട് :‬‭തിരശ്ചീനമായി ചതുരാകൃതിയിലുള്ള ബാറുകളിൽ ഡാറ്റ പ്രദർശിപ്പിക്കുന്നു.‬

‭4.1.B‬‭. കോളം ചാർട്ട്‬ ‭: ഡാറ്റകൾ ലംബമായ കോളങ്ങളായി അവതരിപ്പിക്കുന്നു.‬

‭4.1.C.‬‭ലൈൻ ചാർട്ട് :‬‭നേർരേഖകളാൽ ബന്ധിപ്പിച്ചിട്ടുള്ള ഡാറ്റാ പോയിന്റുകൾ പ്രദർശിപ്പിക്കുന്നു.‬

‭4.1.D.‬‭പൈ ചാർട്ട് :‬‭സംഖ്യാ അനുപാതങ്ങൾ വൃത്താകൃതിയിൽ കാണിക്കുന്നു.‬

‭4.2 ചാർട്ട് ഘടകങ്ങൾ ( ചാർട്ട് എലെമെന്റ്സ് )‬
‭●‬ ‭ചാർട്ട് ഏരിയ :‬‭ചാർട്ട് ഉൾകൊള്ളുന്ന ഭാഗം‬

‭●‬ ‭ചാർട്ട് ടൈറ്റിൽ :‬‭ചാർട്ടിന്റെ ടൈറ്റിൽ‬

‭●‬ ‭X ആക്സിസ് ടൈറ്റിൽ : X-Axis‬‭ലെ ഡാറ്റ റേഞ്ചിന്റെ ടൈറ്റിൽ‬

‭●‬ ‭Y ആക്സിസ് ടൈറ്റിൽ :  Y-Axis‬‭ലെ ഡാറ്റ റേഞ്ചിന്റെ ടൈറ്റിൽ‬

‭●‬ ‭X ആക്സിസ്  കാറ്റഗറി :‬‭ഗ്രാഫ് നിർമ്മിക്കാനുപയോഗിക്കുന്ന ഡാറ്റയുടെ വിഭാഗം‬

‭●‬ ‭Y ആക്സിസ് വാല്യൂ :‬‭ഡാറ്റ ശ്രേണി പ്ലോട്ട് ചെയ്യാൻ അടയാളപ്പെടുത്തിയ ഡാറ്റ റേഞ്ച്‬

‭●‬ ‭ഡാറ്റ ലേബെൽസ് :‬‭ഗ്രാഫ് നിർമ്മിക്കാനുപയോഗിക്കുന്ന ഡാറ്റ ശ്രേണിയുടെ വിലകൾ‬

‭●‬ ‭ലെജന്റ്സ് :‬‭ഡാറ്റ ശ്രേണിയെ പ്രതിനിധാനം ചെയ്യുന്ന നിറമോ,ചിഹ്നമോ,പാറ്റെണോ കാണിക്കുന്ന‬

‭ചതുരം‬
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‭CHAPTER - 5‬

‭PRESENTATION SOFTWARE‬

‭1 പ്രസന്റേഷൻ സോഫ്റ്റ്‌വെയർ‬‭:‬‭ചിത്രങ്ങൾ,ഗ്രാഫുകൾ,ശബ്ദം,വിഡിയോകൾ, എന്നിവ ഉപയോഗിച്ച‬

‭സ്ലൈഡ് നിർമിച്ച ഇൻഫർമേഷൻ ഡിസ്‌പ്ലൈ ചെയ്യുന്നു.‬

‭ഉദാഹരണം‬‭:  ലിബ്രെ ഓഫീസ് ഇമ്പ്രെസ്സ് , മൈക്രോസോഫ്ട് പവർ പോയിന്റ്‬

‭2. പ്രസന്റേഷൻ സോഫ്റ്റ്‌വെയർ ന്റെ IDE ഭാഗങ്ങൾ‬‭**IDE - ഇന്റഗ്രേറ്റഡ് ഡെവലപ്മെന്റ് എൻവിറോണ്മെന്റ്‬

‭➣‬‭ടൈറ്റിൽബാർ‬‭➣‬‭മെനുബാർ‬‭➣‬‭ടൂൾബാർ‬ ‭➣‬‭സ്ലൈഡ്പാൻ‬‭➣‬‭ടാസ്ക്പാൻ‬‭➣‬‭വർക്കിംഗ് ഏരിയ‬

‭➣‬‭സ്റ്റാറ്റസ് ബാർ‬

‭3. സ്ലൈഡിലേക്ക് ടെക്സ്റ്റ് ആഡ് ചെയ്യുന്നതിനുള്ള മാർഗ്ഗങ്ങൾ‬

‭i) ഒരു സ്ലൈഡിലെ ടെക്സ്റ്റ് എലമെന്റിൽ ടെക്സ്റ്റ് നേരിട്ട് ടൈപ്പ് ചെയ്യാം.‬

‭ii) ഡ്രോയിംഗ് ടൂൾബാറിലെ ടെക്സ്റ്റ് ടൂൾ ഉപയോഗിക്കുന്നു.‬

‭4. സ്ലൈഡ് ഫോർമാറ്റിങ് :‬‭സ്ലൈഡിലെ ഉള്ളടക്കങ്ങൾ ക്രമീകരിക്കുകയും,അവതരിപ്പിക്കുകയും‬

‭ചെയ്യുന്നമാർഗമാണ്.‬

‭4.1 ടെക്സ്റ്റ് ഫോർമാറ്റിങ് :‬‭സ്ലൈഡിലെ ടെക്സ്റ്റുകൾക്ക് നൽകുന്ന എഫക്ട്‬

‭4.1.A‬‭കാരക്ടർ ഫോർമാറ്റിങ് :‬‭അക്ഷരങ്ങളുടെ ഫോണ്ട്ഫ് ഫേസ്, വലിപ്പം, നിറം, മറ്റ് ഇഫക്റ്റുകൾ‬

‭എന്നിവ  സജ്ജീകരിക്കുന്നു.‬

‭Step 1 : ടെക്സ്റ്റ് തിരഞ്ഞെടുക്കുക‬

‭Step 2 : Format -> Character‬

‭4.1.B‬‭പാരഗ്രാഫ് ഫോർമാറ്റിങ് :‬‭സ്‌പെയ്‌സിംഗ്, ഇൻഡന്റേഷനുകൾ, അലൈൻമെന്റ്, ടാബ്‬

‭ക്രമീകരണം  എന്നിവ ഉൾപ്പെടുന്നു.‬

‭Step1 :പാരഗ്രാഫിനെ തിരഞ്ഞെടുക്കുക‬

‭Step2: Format->Paragraph‬

‭4.1.C‬‭ലിസ്റ്റ് ഫോർമാറ്റിങ് (ബുള്ളറ്റ്‌സ് & നമ്പറിങ് ) :‬ ‭Step 1: Format->Bullets and Numbering‬

‭4.2. സ്ലൈഡിന്റെ ബാക്ക്ഗ്രൗണ്ട് ക്രമീകരിക്കുന്നു‬

‭Step 1 : Slide -> Slide Properties‬

‭Step 2 : തുറന്നു വരുന്ന ഡയലോഗ് ബോക്സിൽ താഴെ കൊടുത്ത ടാബ് ഉപയോഗിക്കാം‬

‭കളർ  :‬‭സ്ലൈഡിന്റെ ബാക്ഗ്രൗണ്ടായി ഏകീകൃത നിറം‬

‭ഗ്രേഡിയൻറ് ഫിൽ :‬‭ഒരു നിറത്തിൽ നിന്ന് മറ്റൊരു നിറത്തിലേക്ക് മാറ്റം നൽകുന്ന എഫക്ട്‬

‭ഹാച്ചിങ് :‬‭ഷേഡിംഗ് കാണിക്കാൻ ഫൈൻ ലൈനുകൾ ഉപയോഗിച്ചു ബാക്ക്ഗ്രൗണ്ട് സെറ്റ് ചെയ്യുന്നു.‬

‭ഇമേജ് /‬‭ബിറ്റ്മാപ് :‬‭ബാക്ക്ഗ്രൗണ്ടിൽ ഇമേജ് സെറ്റ് ചെയ്യുന്നു‬

‭5. സ്ലൈഡ് മാസ്റ്റേഴ്സ് ( ടെംപ്ലേറ്റ് ):‬ ‭എല്ലാ സ്ലൈഡുകളുടെയും അടിസ്ഥാന ഫോർമാറ്റിംഗ്‬

‭നിയന്ത്രിക്കുന്നു.‬

‭Step 1 : Slide -> New Slide ( Ctrl+M)‬

‭Step 2 : View ->Master slide‬

‭Step 3 : ലഭ്യമായ ലിസ്റ്റിൽ നിന്ന് വേണ്ട സ്ലൈഡ് മാസ്റ്റർ സെലക്ട് ചെയ്യുക.‬
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‭6. വിവിധ ഫയൽ ഉൾപ്പെടുത്തുന്ന വിധം‬

‭Image‬ ‭Insert -> Image‬

‭Audio & video‬ ‭Insert -> Audio or Video‬

‭Table‬ ‭Insert -> Table‬

‭Chart‬ ‭Insert -> Chart‬

‭Hyperlink‬
‭ഉൾപെടുത്താൻ‬

‭*ഹൈപ്പർലിങ്ക് :‬‭ഒരു സ്ലൈഡിൽ നിന്ന്‬‭‘i) ഇന്റർനെറ്റ്  ii) മെയിൽ & ന്യൂസ്  iii)‬
‭ഡോക്യുമെന്റ്  iv) ന്യൂ ഡോക്യുമെന്റ്’‬ ‭തുടങ്ങിയവയിലേക്ക്‬
‭ബന്ധിപ്പിക്കുന്നതിനു ഉപയോഗിക്കുന്ന ടെക്സ്റ്റോ ഒബ്ജെക്ടോ ആകാം.‬

‭Insert -> Hyperlink‬

‭ആഡിങ്‬
‭ആക്ഷൻ‬
‭ഒബ്ജെക്ട്സ്‬

‭ആക്ഷൻ ഒബ്ജെക്ട്സ്‬ ‭: സ്ലൈഡിൽ ടെക്സറ് ബോക്സ്,ഇമേജ് എന്നിവയെ‬
‭ഒബ്ജക്റ്റുകളാക്കുകയും ചില പ്രത്യേക ആക്ഷനുകൾ (സ്ലൈഡിലേക്ക്‬
‭പോകുക, വീഡിയോ/ഓഡിയോ ക്ലിപ്പ് പ്ലേ ചെയ്യുക) നൽകുകയും ചെയ്യാം‬
‭Step 1 : Slide-> New Slide‬
‭Step 2 : റെക്റ്റാംഗിൾ ടൂളുപയോഗിച്ച ബോക്സ് വരക്കാം‬
‭Step 3 :‬‭ബോക്സിൽ റൈറ്റ് ക്ലിക്ക് ചെയ്തു Interaction ഓപ്ഷൻ സെലക്ട് ചെയ്യുക‬
‭Step 4 :  Action at mouse click എന്നതിന്റെ ഡ്രോപ്പ് ഡൗൺ ബോക്സിൽ നിന്ന്‬
‭അനുയോജ്യമായ ഇനം തിരഞ്ഞെടുക്കുക‬

‭***7. സ്ലൈഡ് വ്യൂകൾ :‬

‭വ്യൂസ്‬ ‭വിവരണം‬

‭നോർമൽ വ്യൂ (സ്ലൈഡ് വ്യൂ )‬ ‭പ്രസന്റേഷൻ ന്റെ ഡീഫോൾട് വ്യൂ ആണിത്.‬

‭ഔട്ട് ലൈൻ  വ്യൂ‬ ‭എല്ലാ സ്ലൈഡുകളെയും ക്രമത്തിൽ കാണുവാനും,‬
‭സ്ലൈഡിലെ ടെക്സ്റ്റുകൾ മാത്രം കാണുവാനും‬
‭ഉപയോഗിക്കുന്നു.മറ്റു ഇമേജുകളും ടേബിളുകളും hide ചെയ്യുന്നു.‬

‭നോട്ട്സ് വ്യൂ‬ ‭ഓരോ സ്ലൈഡിലും നോട്ട്സ് രേഖപ്പെടുത്തുന്നതിന്‬
‭ഉപയോഗിക്കുന്നു.‬

‭ഹാൻഡ് ഔട്ട്  വ്യൂ‬ ‭പ്രസന്റേഷന്റെ പ്രിന്റൗട്ട് എടുക്കുമ്പോൾ ലേഔട് സെറ്റ് ചെയ്യുവാൻ‬

‭സ്ലൈഡ്  സോർട്ടർ  വ്യൂ‬ ‭ഓരോ സ്ലൈഡിന്റെയും തമ്പ്നെയിൽ ( ചെറു ചിത്രങ്ങൾ )‬
‭കാണുവാൻ സാധിക്കും. സ്ലൈഡുകളുടെ സ്ഥാനം‬
‭പുനഃക്രമീകരിക്കുവാനും സ്ലൈഡ് മാനേജ് ചെയ്യുവാനും‬
‭ഇതിൽ സാധിക്കും.‬

‭8. സ്ലൈഡ് ട്രാൻസിഷൻസ് :‬ ‭സ്ലൈഡ്ഷോ ചെയ്യുമ്പോൾ  സ്ലൈഡുകൾക്ക് ആകർഷകമായ‬

‭ഇഫക്റ്റുകൾ സൃഷ്ടിക്കുന്നു.‬

‭രണ്ട് സ്ലൈഡ് ട്രാൻസിഷൻ ക്രമീകരണങ്ങൾ‬

‭8.1‬ ‭ഓട്ടോമാറ്റിക് സ്ലൈഡ് ട്രാൻസിഷൻ‬‭: യൂസർ നിർദ്ദേശമില്ലാതെ തന്നെ സ്ലൈഡ് ഷോയിൽ‬

‭സ്ലൈഡുകൾ താനേ മാറുന്നു.‬

‭Step 1: Slide Transition pane -> Advance slide -> Automatically after‬

‭Step 2 : സമയം സെറ്റ് ചെയ്യുക. Apply to All Slides എന്ന ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬

‭8.2‬‭റിഹേർസ് ടൈമിംഗ്‬‭:ഓരോ സ്ലൈഡുകൾ കാണിക്കുന്നതിന് വ്യത്യസ്‌ത സമയം‬

‭ക്രമീകരിക്കുന്നതാണിത്.‬

‭Step : Slide Show -> Rehearse Timing‬
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‭XI  -   CHAPTER - 6‬

‭GETTING STARTED WITH GIMP‬

‭1. ഇമേജ് എഡിറ്റിംഗ് :‬‭ഇമേജ് എഡിറ്റിംഗ് എന്നത് ഒരു ഇമേജിന്റെയോ ഗ്രാഫിക്സിന്റെയോ എഡിറ്റിംഗ്‬

‭അല്ലെങ്കിൽ തിരുത്തലുകളാണ്.ഇതിനായി ഉപയോഗിക്കുന്ന സോഫ്റ്റ് വെയറുകളാണ് ഇമേജ് എഡിറ്റർ.‬

‭3 തരം എഡിറ്ററുകളുണ്ട്.‬

‭●‬ ‭റാസ്റ്റർ ഗ്രാഫിക്സ് എഡിറ്റർ:    ഉദാ: ജിമ്പ്,അഡോബ് ഫോട്ടോഷോപ്പ്,ജി-തമ്പ് ഇമേജ് വ്യൂവർ‬

‭●‬ ‭വെക്റ്റർ ഗ്രാഫിക്സ് എഡിറ്റർ:   ഉദാ:  അഡോബ് ഇല്ലുസ്ട്രേറ്റർ,കോറൽ ഡ്രോ,ഇങ്ക്സ്‌കേപ്പ്‬

‭●‬ ‭3D മോഡുലാർ :   ഉദാ:കെ-3D‬

‭1.1 ഇമേജ് എഡിറ്റിംഗ് സോഫ്റ്റ്വെയറിന്റെ ഉപയോഗം‬‭: വലുപ്പം മാറ്റൽ, ക്രോപ്പിംഗ്,‬

‭കളറിംഗ്,ഇമേജുകൾ സംയോജിപ്പിക്കുകയും മാറ്റുകയും ചെയ്യുന്നു, പോറലുകൾ, ചുളിവുകൾ‬

‭എന്നിവ നീക്കം ചെയ്യാനും ഉപയോഗിക്കുന്നു.‬

‭2. രണ്ടുതരം ഇമേജ് എഡിറ്റിംഗ് സോഫ്റ്റ് വെയർ‬‭:‬

‭റാസ്റ്റർ ഗ്രാഫിക് എഡിറ്റർ & വെക്റ്റർ ഗ്രാഫിക് എഡിറ്റർ‬

‭റാസ്റ്റർ ഗ്രാഫിക് എഡിറ്റർ‬ ‭വെക്റ്റർ ഗ്രാഫിക് എഡിറ്റർ‬

‭റാസ്റ്റർ ചിത്രം പിക്സലുകൾ കൊണ്ട്‬
‭നിർമിച്ചിരിക്കുന്നു‬

‭ഗണിതശാസ്ത്രപരമായ സൂത്രവാക്യങ്ങൾ‬
‭കൊണ്ട് നിർമിച്ചിരിക്കുന്നു.‬

‭ചിത്രങ്ങളുടെ വലിപ്പം കൂട്ടുംതോറും‬
‭ഗുണനിലവാരം കുറയുന്നു‬

‭വലിപ്പം കൂട്ടുംതോറും ഗുണനിലവാരത്തിൽ‬
‭നഷ്ടപ്പെടുന്നില്ല.‬

‭പലപ്പോഴും വലിയ ഫയൽ സൈസ്‬
‭ഉള്ളവയാണ്‬

‭പലപ്പോഴും ഫയൽ സൈസ് കുറവുള്ളവയാണ്‬

‭3. GIMP‬‭( ഗ്നു-ഇമേജ് മാനിപുലേഷൻ പ്രോഗ്രാം )‬‭സവിശേഷതകൾ‬

‭➤ പെയിന്റിംഗ് ടൂളുകൾ  ➤ഒന്നിലധികം ആണ്ടു / റീഡു ➤സെലെക്ഷൻ  ടൂളുകൾ‬

‭➤ട്രാൻസ്ഫോർമേഷൻ ടൂളുകൾ‬

‭➤ ഒന്നിലധികം ലെയർ സൗകര്യം - എന്നിവയെല്ലാം ലഭ്യമാണ്.‬

‭കൂടതെ GIF, JPEG, PNG, TIFF, BMP പോലുള്ള ഫയൽ ഫോർമാറ്റുകൾ പിന്തുണയ്ക്കുന്നു.‬

‭GIMP ഇമേജ് ഫയലിന്റെ ഡിഫോൾട്ട് എക്സ്റ്റൻഷൻ‬‭.xcf‬‭ആണ്.‬

‭4. GIMP-ൽ ക്യാൻവാസ് സൃഷ്ടിക്കുന്നതിനുള്ള ഘട്ടങ്ങൾ :‬

‭Step 1: File -> New‬

‭Step 2 : Create a New Image ഡയലോഗ് ബോക്സ് ഉപയോഗിച്ച് അനുയോജ്യമായ വലുപ്പം‬

‭ക്രമീകരിക്കുക.‬

‭Step 3 : OK ബട്ടണിൽ ക്ലിക്ക് ചെയ്യുക.‬
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‭5. GIMP-ലെ ലേയറുകൾ‬‭: ലേയറുകളുടെ സഹായത്താൽ ഒരു ഇമേജിന്റെ മുകളിൽ അനേകം‬

‭ഇമേജിന്റെ ഭാഗങ്ങൾ കൂട്ടിച്ചേർത്തു ഒറ്റ ഇമേജാക്കിമാറ്റാം.‬

‭ലെയറുകളിലെ പ്രവർത്തനങ്ങൾ :‬‭ക്രിയേറ്റ് ന്യൂ ലെയർ, മൂവ് ലെയർ അപ്പ്, മൂവ് ലെയർ ഡൌൺ,‬

‭ക്രിയേറ്റ് ഡ്യൂപ്ലിക്കേറ്റ് കോപ്പി ഓഫ് ലെയർ,ഡിലീറ്റ് ലെയർ ,‬‭ആങ്കർ ദി ഫ്ലോട്ടിങ് ലെയർ‬‭.‬

‭ആങ്കറിങ് ലെയർ :‬‭ഫ്ലോട്ടിംഗ് ലെയറിനെ നോർമൽ ലെയറിലേക്ക് യോജിപ്പിക്കുന്നതാണ്‬

‭ആങ്കറിങ്ങിനായി:- ലെയർ ഡയലോഗ് ബോക്സിൽ ആങ്കർ ബട്ടൺ തിരഞ്ഞെടുക്കുക.‬

‭6. സെലെക്ഷൻ ടൂൾ‬‭:ആക്റ്റീവ് ലെയറിൽ നിന്ന് ആവശ്യമുള്ള ഭാഗങ്ങൾ തിരഞ്ഞെടുത്തു വിവിധ‬

‭പ്രവൃത്തി  ചെയ്യാനാകും.‬

‭6.1.‬‭റെക്‌റ്റാംഗിൾ സെലക്ട്‬‭:‬‭ഇമേജിൽ ചതുരാകൃതിയിൽ ഒരു ഭാഗം സെലക്ട് ചെയ്യുവാൻ.‬

‭Tools -> Selection Tools–> Rectangle Select‬

‭6.2.‬‭എലിപ്സ്  സെലക്ട്‬‭:‬‭ഇമേജിൽ വൃത്താകൃതിയിലോ എലിപ്റ്റിക്കലോ ഒരു ഭാഗം സെലക്ട്  ചെയ്യുവാൻ.‬

‭Tools -> Selection Tools–> Ellipse Select‬

‭6.3.‬‭ഫ്രീ സെലക്ട് (ലാസ്സോ ടൂൾ)‬‭:‬‭ഇമേജിൽ സ്വതന്ത്രമായി ഏതു ഭാഗവും തിരഞ്ഞെടുക്കൽ വരയ്ക്കാൻ‬

‭Tools -> Selection Tools–> Free Select‬

‭6.4.‬‭ഫസി സെലക്ട് (മാജിക് വാൻഡ് )‬‭:‬‭ഇമേജിൽ ഒരേ കളറിൽ തുടർച്ചയായി കാണപ്പെടുന്ന ഭാഗം‬

‭സെലക്ട്  ചെയ്യുന്നു.     Tools -> Selection Tools–> Fuzzy Select‬

‭6.5.‬‭ബൈ കളർ സെലക്ട്‬‭:‬‭ഇമേജിൽ ഒരേ കളറിൽ തുടർച്ചയല്ലാതെ കാണപ്പെടുന്ന ഭാഗം സെലക്ട് ചെയ്യുന്നു.‬

‭Tools -> Selection Tools–> By Colour Select‬

‭6.6.‬‭ഇന്റലിജന്റ് സിസെർസ്‬‭:‬‭കടുത്ത നിറങ്ങളെ സെലക്ട് ചെയ്യുന്നു.‬

‭Tools -> Selection Tools–> Intelligent Scissors‬

‭6.7.‬‭ഫോർഗ്രൗണ്ട് സെലക്ട്‬‭:‬‭ഇമേജിൽ നേർത്ത പിക്സലുകളെ തിരഞ്ഞെടുക്കുന്നു.‬

‭Tools -> Selection Tools–> Foreground Select‬

‭7. ട്രാൻസ്‌ഫോം ടൂൾ‬‭:ഇമേജിന്റെ വലിപ്പം,സ്ഥാനം,ആംഗിൾ തുടങ്ങിയ രൂപഭാവം മാറ്റുന്നതിന്‬

‭ഉപയോഗിക്കുന്നു.‬

‭7.1.‬‭അലൈൻ‬‭:‬‭ഇമേജിലെ ലെയറുകളുടെ സ്ഥാനം നിർണയിക്കുന്നു.‬

‭Tools ->  Transform Tools→  Align‬

‭7.2.‬‭മൂവ്‬‭:‬‭ലെയറുകളോ സെലെക്ഷനോ ഒരു സ്ഥാനത്തിൽ നിന്ന് മറ്റൊരു സ്ഥാനത്തേക്ക് മാറ്റുവാൻ.‬

‭Tools -> Transform Tools→  Move‬

‭7.3.‬‭ക്രോപ്‬‭:‬‭ഇമേജിനെ മുറിക്കുന്നതിന് ഉപയോഗിക്കുന്നു.‬

‭Tools -> Transform Tools→ Crop‬

‭7.4.‬‭റൊട്ടേറ്റ്‬‭:‬‭ഇമേജിനെ പല ദിശയിൽ തിരിക്കുന്നതിന് (റൊട്ടേറ്റ് ) ഉപയോഗിക്കുന്നു.‬

‭Tools -> Transform Tools→ Rotate‬

‭7.5.‬‭സ്കെയിൽ‬‭:‬‭ഇമേജിന്റെ വലിപ്പം വ്യതിചലിപ്പിക്കുവാൻ ഉപയോഗിക്കുന്നു.‬

‭Tools -> Transform Tools→ Scale‬

‭7.6.‬‭ഷിയർ‬‭:‬‭ഇമേജിന്റെ എതിർ വശങ്ങളെ എതിർ ദിശയിലേക്ക് മാറ്റുന്നതിന് ഉപയോഗിക്കുന്നു.‬

‭Tools -> Transform Tools→ Shear‬

‭7.7.‬‭ഫ്ലിപ്‬‭:‬‭മിറർ ഇമേജ് നിർമിക്കുവാൻ ഉപയോഗിക്കുന്നു.‬

‭Tools -> Transform Tools→ Flip‬

‭8.ഇമേജ് എക്സ്പോർട്ട് ചെയ്യുന്ന വിധം‬

‭1.‬ ‭File → Save As       or         2. File → Export To‬
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‭XI  -  CHAPTER - 7‬

‭ADVANCED TOOLS FOR IMAGE EDITING‬

‭1. പാത്ത് ടൂളും ഗുണങ്ങളും‬‭:‬

‭●‬ ‭GIMP-ൽ, നേർരേഖയും വളഞ്ഞതുമായ പാതകൾ നിർമിക്കാൻ പാത്ത് ഉപയോഗിക്കുന്നു.‬

‭●‬ ‭വ്യത്യസ്ത തരം പാറ്റേണുകൾ നിർമിക്കാൻ ഉപയോഗിക്കുന്നു.‬

‭●‬ ‭ചിത്രത്തിൽ നിന്ന് വ്യത്യസ്ത ആകൃതിയിലുള്ള ഒരു ഭാഗം തിരഞ്ഞെടുക്കാൻ സാധിക്കുന്നു.‬

‭●‬ ‭ടെക്സ്റ്റുകളെ പല രീതിയിൽ അലൈൻ ചെയ്യാം.    Steps : Tools → Paths‬

‭ആങ്കർ പോയിന്റ്‬‭: പാത്ത് ലെ ഓരോ പോയിന്റും ആങ്കർ പോയിന്റ് എന്ന് വിളിക്കുന്നു‬‭.‬

‭➤ പാത്തിൽ നിന്ന് ആങ്കർ പോയിന്റുകൾ ചേർക്കുന്ന വിധം : Ctrl + Mouse click‬

‭➤ പാത്തിൽ നിന്ന് ആങ്കർ പോയിന്റുകൾ നീക്കം ചെയ്യുന്ന വിധം : Ctrl + Shift + Mouse Click‬

‭ടെക്സ്റ്റിനെ പാത്തിലേക്ക് അലൈൻ ചെയ്യുന്ന വിധം‬

‭Step 1 : ടൂൾബോക്സിൽ നിന്ന് ടെക്സ്റ്റ് ടൂൾ തിരഞ്ഞെടുത്ത് ക്യാൻവാസിൽ ഒരു ടെക്സ്റ്റ്‬

‭ടൈപ്പ് ചെയ്യുക‬

‭Step 2 : പാത്ത് ടൂൾ ഉപയോഗിച്ച് ക്യാൻവാസിൽ ഒരു പാത്ത് വരയ്ക്കുക‬

‭Step 3 : ടൈപ്പ് ചെയ്ത വാചകം തിരഞ്ഞെടുത്ത് താഴെ കൊടുത്ത മെനു ഓപ്ഷൻ‬

‭ഉപയോഗിക്കുക.‬ ‭Layer → Text Along Path‬

‭2.‬‭GIMP-ൽ കളർ പ്രദര്ശിപ്പിക്കുന്നതിനുള്ള  കളർ ഡയലോഗ് ബോക്‌സിലെ വിവിധ കളർ പാറ്റേൺ‬

‭➤ ജിമ്പ്       ➤ CMYK      ➤വാട്ടർ കളർ     ➤ വീൽ    ➤ പാലറ്റ്‬

‭3. ജിമ്പിലെ കളർ സ്കീമുകൾ‬

‭സബ്‌ട്രാക്റ്റീവ് കളർ സ്‌കീം‬ ‭അഡിറ്റീവ്‬‭കളർ സ്‌കീം‬

‭കളർ പ്രിന്റിംഗിൽ ഉപയോഗിക്കുന്നു‬ ‭കമ്പ്യൂട്ടർ, ടെലിവിഷൻ സ്ക്രീനുകളിൽ‬
‭ഉപയോഗിക്കുന്നു‬

‭സിയാൻ, മജന്ത,യെല്ലോ നിറങ്ങൾ‬
‭ഉപയോഗിച്ചു‬
‭മറ്റു നിറങ്ങൾ നിർമിക്കുന്നു. (CMYK)‬

‭റെഡ്, ഗ്രീൻ, ബ്ലൂ നിറങ്ങൾ ഉപയോഗിച്ചു മറ്റു‬
‭നിറങ്ങൾ നിർമിക്കുന്നു ( RGB)‬

‭എല്ലാ നിറങ്ങളുടെയും സാന്നിധ്യം കറുപ്പാണ്
‭!C+M+Y=blac‬‭K‬

‭എല്ലാ നിറങ്ങളുടെയും സാന്നിധ്യം വെളുപ്പാണ്.‬
‭!R+G+B=‬‭W‬‭hite‬

‭നിറങ്ങളുടെ അഭാവം വെളുപ്പാണ്.‬ ‭നിറങ്ങളുടെ അഭാവം കറുപ്പാണ്.‬

‭4. ഒരു ചിത്രത്തിന്റെ‬‭ബ്രൈറ്റ്നെസ്സ് & കോൺട്രാസ്റ്‬‭ക്രമീകരിക്കുന്നു വിധം‬

‭Step : : Tools → Colour Tools → Brightness - Contrast‬

‭5.‬‭കളർ ബാലൻസിങ്‬‭: നിറം ബാലൻസ് ചെയ്തുകൊണ്ട് ചിത്രം ശരിയാക്കാൻ ഇത് ഉപയോഗിക്കുന്നു.‬

‭Step 1 : Colours → Colour Balance‬

‭Step 2 :  വരുന്ന ഡയലോഗ് ബോക്സിൽ Shadows,Midtones ,Highlights എന്നീ ഐറ്റം ഉപയോഗിക്കാം.‬
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‭6. ജിമ്പിലെ വ്യത്യസ്ത ഫിൽറ്ററുകൾ‬

‭⏩‬‭ബ്ലർ‬‭-‬

‭ഗോസിയൻ-‬‭ഇമേജിന് ഔട്ട് ഓഫ് ഫോക്കസ് ഇഫക്റ്റ്. Step : Filters->Blur-> Gaussian Blur‬

‭സിമ്പിൾ   -‬‭ഇമേജുകൾ ചെറിയ രീതിയിൽ ബ്ലർ ചെയ്യുന്നു.‬

‭മോഷൻ   -‬‭ഇമേജുകൾ ചലിച്ച ബ്ലർ എഫക്ട്.‬

‭പിക്സെലൈസ് -‬‭ചിത്രത്തെ വലിയ ചതുരങ്ങളുടെ ഒരു കൂട്ടമായി ബ്ലർ ചെയ്യും.‬

‭സെലെക്ടിവ് ഗോസിയൻ -‬‭ഒരേപോലുള്ള പിക്സിലുകൾ ബ്ലർ ചെയ്യുന്നു.‬

‭⏩‬‭ഡിസ്റ്റോർട്സ്‬ ‭-‬‭ഇമേജിന്റെ ആകൃതി മാറ്റുന്നു.‬

‭എംബോസ് -‬‭ഇമേജിലെ പ്രകാശം/ഇരുണ്ട ഏരിയ ഹൈലൈറ്റ് /ഷാഡോ ഉപയോഗിച്ച്‬

‭മാറ്റിസ്ഥാപിക്കുന്നു.‬

‭മൊസൈക് -‬‭ഇമേജിനെ ചിപ്പുകളോ ടൈലുകളോ കൊണ്ട് നിർമ്മിച്ചത് പോലെയാക്കുന്നു.‬

‭റിപ്പിൾ -‬‭ഇമേജിനെ തരംഗ രൂപത്തിലാക്കുന്നു.‬

‭ഷിഫ്റ്റ് -‬‭ഇമേജിൽ പിക്സലുകളെ തിരശ്ചീനമായോ ലംബമായോ മാറ്റുന്നു.‬

‭വേവ്സ് -‬‭വെള്ളത്തിലേക്ക് കല്ല് എറിയുമ്പോൾ ഉണ്ടാകുന്ന തതരംഗംപോലാക്കുന്നു.‬

‭വിൻഡ് -‬‭നേർത്ത കറുപ്പും വെളുപ്പും വരകൾ ഉപയോഗിച്ച windy എഫ്ഫക്റ്റ് നൽകുന്നു.‬

‭⏩‬‭ലൈറ്റ് & ഷാഡോ‬ ‭-‬‭പ്രകാശത്തിന്റെയും നിഴലിന്റെയും എഫെക്ട് നൽകുന്നു.‬

‭ലെൻസ് ഫ്ലെയർ -‬‭പ്രകാശ സ്രോതസ്സ് നേരിട്ട് ലെൻസിലേക്ക് പതിക്കുന്ന എഫക്ട്.‬

‭ലൈറ്റനിംഗ് ഇഫക്റ്റ് -‬‭പ്രകാശം ഇമേജിൽ വീഴുന്ന എഫക്ട്.‬

‭സൂപ്പർനോവ -‬‭സൂപ്പർനോവ എഫക്ട് നൽകുന്നു.‬

‭⏩‬‭ആർട്ടിസ്റ്റിക്‬‭-‬‭കലാപരമായ എഫക്ട് നൽകുന്നു.‬

‭ക്ലോത്തിഫൈ -‬‭ഇമേജ് തുണിയിൽ വരച്ചപോലുള്ള എഫക്ട്.‬

‭ക്യൂബിസം -‬‭ഇമേജ് അനേകം ക്യൂബുകളാൽ നിർമിച്ചപോലെ എഫക്ട്.‬

‭ഓയിലിഫൈ -‬‭ഇമേജിനെ ഓയിൽ പെയിന്റിന്റെ എഫക്ട്.‬

‭സോഫ്റ്റ് ഗ്ലോ -‬‭ചെറിയ തിളക്കത്തോടെ ഇമേജിനെ കാണുന്നു.‬

‭വീവ്‬ ‭- റിബൺ കൊണ്ട് നെയ്ത പോലെ ഇമേജിനെ ആക്കുന്നു.‬

‭⏩ ഷാർപെൻ -‬‭ഇമേജിന്റെ വക്കുകൾ കൂടുതൽ വ്യക്തത നൽകുന്നു.‬

‭Step : Filters->Enhance-> Sharpen‬
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‭XI  - CHAPTER - 8‬

‭COMPUTER NETWORKS‬

‭1 കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്ക് :‬‭കമ്പ്യൂട്ടറുകളും ഹാർഡ് വേറുകളും ഒരു കമ്മ്യൂണിക്കേഷൻ മീഡിയത്തിന്റെ‬

‭സഹായത്താൽ പരസ്പരം ബന്ധിപ്പിക്കുന്നതാണ് നെറ്റ്‌വർക്ക്.   ഉദാ: ഇന്റർനെറ്റ്‬

‭ഗുണങ്ങൾ : ➤‬‭റിസോഴ്സ് ഷെയറിങ്‬ ‭➤‬‭പ്രൈസ്-പെർഫോമൻസ് റേഷ്യോ‬

‭➤‬‭കമ്മ്യൂണിക്കേഷൻ‬ ‭➤‬‭റിലയബിലിറ്റി‬ ‭➤‬ ‭സ്കേലബിളിറ്റി‬

‭2. നെറ്റ് വർക്കുമായി ബന്ധപ്പെട്ട കീ ടെം:‬

‭2.1.‬‭ബാൻഡ് വിഡ്ത് :‬‭ഒരു നിശ്ചിത സമയത്തിനുള്ളിൽ നെറ്റ്‌വർക്കിലെ കംപ്യൂട്ടറുകൾ‬

‭തമ്മിലുള്ള പരമാവധി ഡാറ്റ -കൈമാറ്റ നിരക്ക്.  (‬‭bps‬‭: ബിറ്റ്‌സ് പെർ സെക്കന്റ് )‬

‭2.2.‬‭നോയ്‌സ് (Noise):‬‭ഡാറ്റാ സിഗ്നലുകളുടെ ഗുണനിലവാരം കുറയ്ക്കുന്ന അനാവശ്യ‬

‭വൈദ്യുത അല്ലെങ്കിൽ വൈദ്യുതകാന്തിക ഊർജ്ജമാണ്.‬

‭2.3.‬‭നോഡ് :‬ ‭കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്കിലേക്ക് നേരിട്ട് ബന്ധിപ്പിച്ചിരിക്കുന്ന ഏതൊരു‬

‭ഉപകരണത്തെയും നോഡ് എന്ന് വിളിക്കുന്നു‬

‭3. ഡാറ്റ കമ്മ്യൂണിക്കേഷൻ സിസ്റ്റം :‬‭രണ്ട് ഉപകരണങ്ങൾ തമ്മിലുള്ള ഡിജിറ്റൽ ഡാറ്റ കൈമാറ്റം.‬

‭3.1‬‭മെസ്സേജ് :‬‭നെറ്റ് വർക്കിൽ കൈമാറ്റം‬

‭ചെയ്യപ്പെടേണ്ട ഇൻഫർമേഷൻ.‬

‭3.2.‬‭സെൻഡർ :‬‭ഡാറ്റ അയക്കുന്ന ഉപകരണം.‬

‭3.3‬‭റിസീവർ :‬‭ഡാറ്റ സ്വീകരിക്കുന്ന ഉപകരണം.‬

‭3.4.‬‭പ്രോട്ടോകോൾ :‬‭ഡാറ്റ കൈമാറുന്നതിനുള്ള നിയമങ്ങളും നിയന്ത്രണങ്ങളും‬

‭www.teachbook.in‬ ‭|‬ ‭20‬

‭3.5 കമ്മ്യൂണിക്കേഷൻ മീഡിയം:‬‭നെറ്റ്‌വർക്കിലെ നോഡുകൾ പരസ്പരം ബന്ധിപ്പിക്കുന്നതിന്
‭ഉപയോഗിക്കുന്ന ആശയവിനിമയ ചാനലുകൾ.‬

‭3.5.1‬
‭ഗൈഡഡ്‬
‭മീഡിയം‬
‭( Guided‬
‭Medium )‬

‭കേബിളുകളും വയറുകളും ഉപയോഗിച്ച ഡാറ്റ ട്രാൻസ്മിഷൻ നടത്തുന്നു.‬

‭ട്വിസ്റ്റഡ് പെയർ‬
‭കേബിൾ‬

‭രണ്ട് ഇൻസുലേറ്റഡ് കോപ്പർ വയറുകൾ പിരിച്ചുവെച്ചിരിക്കുന്നു.
‭(ഇതെർനെറ്റ് കേബിൾ )‬

‭കോആക്സിൽ‬
‭കേബിൾ‬

‭ഏറ്റവും ഉള്ളിൽ കോപ്പർ വയർ, അതിനെ പൊതിഞ്ഞു‬
‭ഇൻസുലേറ്റർ, ഇൻസുലേറ്ററിനെ പൊതിഞ്ഞു കോപ്പർ‬
‭മെഷ്,ഏറ്റവും പുറത്തായി ഒരു ഇൻസുലേഷനും ഉണ്ട്. ചിലവും‬
‭ബാൻഡ് വിഡ്ത്തും കൂടുതലാണ്‬

‭ഒപ്റ്റിക്കൽ‬
‭ഫൈബർ‬
‭കേബിൾ‬

‭പ്രകാശ സിഗ്നലുകളായി ഡാറ്റ കൈമാറ്റം ചെയ്യപ്പെടുന്ന നീളമുള്ള
‭ഗ്ലാസ് നാരുകളാണ് ഒപ്റ്റിക്കൽ ഫൈബർ.കോർ, ക്ലാഡിംഗ്,‬
‭കോട്ടിംഗ്,നാരുകൾ, പുറം ജാക്കറ്റ് എന്നിവയാണ് ഭാഗങ്ങൾ.‬
‭ഉയർന്ന വേഗത & ബാൻഡ്‌വിഡ്ത്ത് & ചെലവ്,  വളരെ‬
‭ദൂരെയുള്ള ഒരു ദൂരത്തിൽ ഡാറ്റ കൊണ്ടുപോകുന്നു,‬
‭ഇൻസ്റ്റാളേഷനും പരിപാലനവും ബുദ്ധിമുട്ടാണ്‬

‭3.5.2 അൺ‬
‭ഗൈഡഡ്‬
‭മീഡിയം‬‭(‬
‭Un-Guided‬
‭Medium )‬

‭റേഡിയോ തരംഗങ്ങൾ, മൈക്രോവേവ് അല്ലെങ്കിൽ ഇൻഫ്രാറെഡ് സിഗ്നലുകൾ‬
‭എന്നിവ ഡാറ്റാ ട്രാൻസ്മിഷനായി ഉപയോഗിക്കുന്നു.‬

‭റേഡിയോ വേവ്സ് ഉപയോഗിച്ചുള്ള വയർലെസ്സ് ട്രാൻസ്മിഷൻ:‬
‭ബ്ലൂടൂത്ത്,വൈ-ഫൈ, വൈ-മാക്സ്, സാറ്റ്ലൈറ്റ് ലിങ്ക്.‬
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‭4. നെറ്റ്‌വർക്ക് ടോപ്പോളജികൾ ;-‬ ‭ഒരു നെറ്റ്‌വർക്ക് രൂപീകരിക്കുന്നതിന് നോഡുകൾ‬

‭ഭൗതികമായി പരസ്പരം ബന്ധിപ്പിച്ചിരിക്കുന്ന  രീതിയെ ടോപ്പോളജി എന്ന് വിളിക്കുന്നു.‬

‭ബസ് ടോപ്പോളജി‬ ‭നോഡുകളെ ഒരൊറ്റ കേബിളുമായി നേരിട്ട് ലിങ്ക് ചെയ്‌തിരിക്കുന്ന‬
‭ഒരു നെറ്റ്‌വർക്കിന്റെ സജ്ജീകരണമാണിത്.‬

‭റിംഗ്  ടോപ്പോളജി‬ ‭ഓരോ നോഡും മറ്റ് രണ്ട് നോഡുകളുമായി ബന്ധിപ്പിച്ച് ഒരു റിംഗ്‬
‭രൂപത്തിൽ ക്രമീകരിക്കുന്നു. ഡാറ്റകൾ റിങ്ങിൽ കൂടി ഒരേ ദിശയിൽ‬
‭സഞ്ചരിച്ചു ലക്ഷ്യസ്ഥാനത്ത് എത്തുന്നതിന് മുമ്പ് ഓരോ‬
‭നോഡിലൂടെയും കടന്നുപോകുന്നു.‬

‭സ്റ്റാർ  ടോപ്പോളജി‬ ‭നെറ്റ്‌വർക്ക് ലെ എല്ലാ നോഡുകളും ഹബ്/സ്വിച്ചിമായി‬
‭ബന്ധിപ്പിച്ചിരിക്കുന്നു. ഓരോ നോഡും മറ്റൊരു നോഡിലേക്ക്‬
‭അയക്കുന്ന ഡാറ്റ ആദ്യം ഹബ്/സ്വിച്ച്ൽ എത്തിച്ചേരുകയും തുടർന്ന്‬
‭ലക്ഷ്യത്തിലേക്കുള്ള നോഡിലേക്ക് എത്തിക്കുകയും ചെയ്യുന്നു.‬

‭മെഷ്  ടോപ്പോളജി‬ ‭ഓരോ നോഡും മറ്റൊരു നോഡുമായി ബന്ധിപ്പിച്ചിരിക്കുന്നു.‬
‭അതിനാൽ രണ്ട് നോഡുകൾക്കിടയിൽ ഒന്നിലധികം പാതകൾ‬
‭ഉണ്ടാകും. ഒരു പാത പരാജയപ്പെടുകയാണെങ്കിൽ, ഡാറ്റ മറ്റൊരു‬
‭പാതയിലൂടെ സഞ്ചരിച്ച് ലക്ഷ്യസ്ഥാനത്ത് എത്തും.‬

‭5. ഡാറ്റ കമ്മ്യൂണിക്കേഷൻ ഡിവൈസ്‬ ‭:‬‭നെറ്റ്‌വർക്കിൽ കമ്പ്യൂട്ടറിനെയും കമ്മ്യൂണിക്കേഷൻ‬

‭മീഡിയത്തിനെയും ബന്ധിപ്പിക്കുന്ന ഉപകരണങ്ങൾ.‬

‭നെറ്റ്‌വർക്ക്‬
‭-ഇന്റർഫേസ്‬
‭കാർഡ്‬‭(NIC)‬

‭നെറ്റ്‌വർക്കിലേക്ക് കണക്റ്റുചെയ്യാൻ കമ്പ്യൂട്ടറിൽ ഇൻസ്റ്റാൾ ചെയ്തിരിക്കുന്ന സർക്യൂട്ട്‬
‭ബോർഡ്‬

‭ഹബ്‬ ‭നെറ്റ്‌വർക്കിലെ എല്ലാ കംപ്യൂട്ടറിലേക്കും ഹബ് ഡാറ്റ അയക്കുന്നു. അതാതു കമ്പ്യൂട്ടർ‬
‭ഡാറ്റ പാക്കറ്റ്സ് പരിശോധിക്കുകയും അർഹത പെട്ടവ സ്വീകരിക്കുകയും അല്ലാത്തവ‬
‭തിരസ്ക്കരിക്കുകയും ചെയ്യുന്നു. ആയതിന്റെ ഫലമായി ട്രാഫിക് ജാം ഉണ്ടാകുകയും ഡാറ്റ
‭ട്രാൻസ്മിഷൻ വേഗത കുറയുകയും ചെയ്യുന്നു.‬

‭സ്വിച്ച്‬ ‭ഡാറ്റ എത്തിച്ചേരേണ്ട കംപ്യൂട്ടറിലേക്കു മാത്രം സ്വിച്ച് ഡാറ്റയെ അയക്കുന്നു. ആയതിന്റെ‬
‭ഫലമായി ട്രാഫിക് ജാം കുറയുകയും ഡാറ്റ ട്രാൻസ്മിഷൻ വേഗത കൂടുകയും ചെയ്യുന്നു.‬

‭റിപ്പീറ്റർ‬ ‭നെറ്റ്‌വർക്കിലൂടെ കടന്നുപോകുന്ന സിഗ്നലുകൾ വർദ്ധിപ്പിക്കുകയും‬
‭പുനരുജ്ജീവിപ്പിക്കുകയും ചെയ്യുന്ന ഉപകരണം.‬

‭ബ്രിഡ്ജ്‬ ‭ഒരു നെറ്റ്‌വർക്കിനെ ഒരേ പ്രോട്ടോകോൾ ഉള്ള രണ്ടു ഭാഗങ്ങളായി വിഭജിക്കുവാൻ‬
‭ഉപയോഗിക്കുന്നു.‬

‭റൂട്ടർ‬ ‭ഒരേ പ്രോട്ടോക്കോളുള്ള ഒരേ തരത്തിലുള്ള രണ്ട് നെറ്റ്‌വർക്കുകളെ പരസ്പരം‬
‭ബന്ധിപ്പിക്കുന്നു.ഇത് ബ്രിഡ്ജിനെക്കാൾ ഇന്റെലിജന്റാണ്.‬

‭ഗേറ്റ്‌വേ‬ ‭വ്യത്യസ്ത പ്രോട്ടോക്കോളുകളുള്ള വ്യത്യസ്ത നെറ്റ്‌വർക്കുകൾ ബന്ധിപ്പിക്കുന്നു.‬
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‭6. ഡാറ്റ ടെർമിനൽ ഉപകരണങ്ങൾ : കമ്പ്യൂട്ടറുകൾ തമ്മിൽ ഡാറ്റ അയക്കുന്നത് നിയന്ത്രിക്കുന്നു.‬

‭6.1 മോഡം ( Modulator-demodulator ) :‬‭ഡിജിറ്റൽ വിവരങ്ങൾ അനലോഗ് സിഗ്നലുകളിലേക്ക്‬

‭പരിവർത്തനം ചെയ്യുകയും(മോഡുലേഷൻ), അനലോഗ് സിഗ്നലുകൾ ഉപയോഗപ്രദമായ‬

‭ഡിജിറ്റൽ വിവരങ്ങളാക്കി മാറ്റുകയും  (ഡീമോഡുലേഷൻ) ചെയ്യുന്നു.‬

‭6.2. മൾട്ടിപ്ലക്‌സിംഗ് :‬‭ഒന്നിലധികം ഡാറ്റ  സിഗ്നലുകൾ സംയോജിപ്പിച്ച് ഒരൊറ്റ മാധ്യമത്തിലൂടെ‬

‭അയയ്‌ക്കാൻ ഉപയോഗിക്കുന്ന ഒരു സാങ്കേതികതയാണ്.‬

‭7. വിവിധ തരം നെറ്റ്‌വർക്ക്കൾ‬

‭7.1 PAN ( പേർസണൽ ഏരിയ‬
‭നെറ്റ്‌വർക്ക്)‬

‭ഒരു വ്യക്തിയുടെ സമീപത്തു ഏതാനും മീറ്ററുകൾക്കുള്ളിൽ‬
‭ഇലക്ട്രോണിക് ഉപകരണങ്ങളെ ബന്ധിപ്പിക്കുന്ന ഒരു കമ്പ്യൂട്ടർ‬
‭ശൃംഖലയാണിത്. വേഗത കൂടുതലും ചെലവ് കുറവുമാണ്.‬

‭7.2 LAN ( ലോക്കൽ ഏരിയ‬
‭നെറ്റ്‌വർക്ക് )‬

‭ഒരു കെട്ടിടം, ഓഫീസ് അല്ലെങ്കിൽ വീട് പോലെയുള്ള ഒരു ഫിസിക്കൽ‬
‭ലൊക്കേഷനിൽ ഒരുമിച്ച് ബന്ധിപ്പിച്ചിരിക്കുന്ന ഉപകരണങ്ങളുടെ ഒരു‬
‭ശേഖരമാണ് ലാൻ.ഇതിന്റെ ദൂര പരിധി ഏതാനും മീറ്ററുകൾ മുതൽ‬
‭പരിമിതമായ കിലോമീറ്ററുകൾ വരെയാണ്.‬

‭7.3MAN(മെട്രോപൊളിറ്റൻ‬
‭ഏരിയ നെറ്റ്‌വർക്ക് )‬

‭ഒരു മെട്രോപൊളിറ്റൻ ഏരിയയ്ക്കുള്ളിൽ ഒന്നിലധികം ലോക്കൽ ഏരിയ
‭നെറ്റ്‌വർക്കുകളെ ബന്ധിപ്പിക്കുന്ന ഒരു കമ്പ്യൂട്ടർ ശൃംഖലയാണിത്.‬
‭ഉദാ : നഗരത്തിൽ വ്യാപിച്ചുകിടക്കുന്ന കേബിൾ ടിവി നെറ്റ്‌വർക്ക്.‬

‭7.4 WAN( വൈഡ് ഏരിയ‬
‭നെറ്റ്‌വർക്ക് )‬

‭ഒരു വലിയ ഭൂമിശാസ്ത്രപരമായ പ്രദേശത്ത് ഒന്നിലധികം സ്ഥലങ്ങളെ‬
‭ബന്ധിപ്പിക്കുന്ന ഒരു കമ്പ്യൂട്ടർ ശൃംഖലയാണ്. ഒരു പ്രദേശം, രാജ്യം, ലോകം
‭മുഴുവൻ ഉൾക്കൊള്ളാൻ കഴിയും.‬

‭8. ഒരു നെറ്റ്‌വർക്കിലെ കമ്പ്യൂട്ടറുകളുടെ തിരിച്ചറിയൽ രീതി‬

‭8.1 MAC അഡ്രസ് :‬‭മീഡിയ ആക്‌സസ് കൺട്രോൾ അഡ്രസ് ഒരു നെറ്റ്‌വർക്കിലേക്ക്  കണക്റ്റു‬

‭ചെയ്തിരിക്കുന്ന ഒരു ഉപകരണത്തെ തിരിച്ചറിയുന്ന 12-അക്ക ഹെക്‌സാഡെസിമൽ  നമ്പറാണ്. വിലാസം‬

‭സാധാരണയായി ഉപകരണത്തിന്റെ നെറ്റ്‌വർക്ക് ഇന്റർഫേസ് കാർഡിൽ (NIC)  കാണപ്പെടുന്നു.‬

‭8.2 IP(ഇന്റർനെറ്റ് പ്രോട്ടോക്കോൾ ) അഡ്രസ്:‬‭ഇൻറർനെറ്റുമായി ബന്ധിപ്പിച്ചിരിക്കുന്ന ഒരു‬

‭ഉപകരണത്തെയോ  നെറ്റ്‌വർക്കിനെയോ തിരിച്ചറിയുന്ന സംഖ്യയാണ്. IP വിലാസങ്ങൾ സാധാരണയായി ഒരു‬

‭ഇന്റർനെറ്റ് സർവീസ് പ്രൊവൈഡർ (ISP) ആണ് അസൈൻ ചെയ്യുന്നത്.‬

‭9. വ്യത്യസ്ത നെറ്റ്‌വർക്ക് പ്രോട്ടോക്കോളുകൾ :‬

‭9.1 TCP/IP‬‭(ട്രാൻസ്മിഷൻ കൺട്രോൾ പ്രോട്ടോക്കോൾ/ ഇന്റർനെറ്റ് പ്രോട്ടോക്കോൾ):‬ ‭ഇന്റർനെറ്റ് പോലുള്ള‬

‭നെറ്റ്‌വർക്കിൽ ആശയവിനിമയം നടത്താൻ കമ്പ്യൂട്ടറുകളെ അനുവദിക്കുന്ന സ്റ്റാൻഡേർഡ് നിയമങ്ങളുടെ കൂട്ടമാണിത്.‬

‭9.2. HTTP‬‭( ഹൈപ്പർടെക്സ്റ്റ് ട്രാൻസ്ഫർ പ്രോട്ടോക്കോൾ): ഇത് വേൾഡ് വൈഡ് വെബിന്റെ അടിത്തറയാണ്,‬

‭വെബ്‌പേജുകൾ ലോഡുചെയ്യാൻ ഇത് ഉപയോഗിക്കുന്ന ഒരു കൂട്ടം നിയമങ്ങളാണിവ.‬

‭9.3. FTP‬‭( ഫയൽ ട്രാൻസ്ഫർ പ്രോട്ടോക്കോൾ : ഒരു ഹോസ്റ്റിൽ നിന്ന് മറ്റൊന്നിലേക്ക് ഫയലുകൾ‬

‭കൈമാറുന്നതിന് ഉപയോഗിക്കുന്ന ഒരു സാധാരണ നെറ്റ്‌വർക്ക് പ്രോട്ടോക്കോൾ.‬

‭9.4. DNS‬‭(ഡൊമെയ്ൻ നെയിം സിസ്റ്റം) പ്രോട്ടോക്കോൾ‬‭: നമ്പർ ശ്രേണിയിലുള്ള ഐപി അഡ്രസ്സിനു പകരം‬

‭മനുഷ്യർക്ക് വായിക്കാവുന്ന വെബ്സൈറ്റ് അഡ്രസ് ഉപയോഗിച്ച് വെബ്‌സൈറ്റുകൾ കണ്ടെത്താൻ‬

‭പ്രോട്ടോക്കോൾ സഹായിക്കുന്നു.‬

‭10. URL (യൂണിഫോം റിസോഴ്സ് ലൊക്കേറ്റർ) :‬

‭ഇന്റർനെറ്റിൽ ഒരു റിസോഴ്സ് കണ്ടെത്തുന്നതിന്‬

‭ഉപയോഗിക്കുന്ന ഒരു  ഐഡന്റിഫയറാണ്.‬

‭ഇതിനെ ഒരു വെബ് അഡ്രസ് എന്നും വിളിക്കുന്നു.‬

‭ഇതിനു 3 ഭാഗങ്ങളുണ്ട്.‬

‭1. Protocol    2. Domain Name    3. File Name‬
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‭XI  - CHAPTER - 9‬

‭INTERNET‬
‭●‬ ‭ഇന്റർനെറ്റ്  :‬‭നെറ്റ്‌വർക്കുകളുടെ നെറ്റ്‌വർക്കാണിത്.‬

‭●‬ ‭ഇൻട്രാനെറ്റ്  :‬‭ഒരു സ്ഥാപനത്തിനുള്ളിലെ സ്വകാര്യ നെറ്റ്‌വർക്കാണിത്.‬

‭●‬ ‭എക്സ്ട്രാനെറ്റ്  :‬‭ഒരു കമ്പനിയുടെ റിസോഴ്സ് (ഇൻട്രാനെറ്റ്) ബിസിനസ്സ് പങ്കാളികൾക്കും‬

‭ആക്സസ് ചെയ്യുന്നു.‬

‭➤‬‭ഇന്റർനെറ്റിലേക്ക് കമ്പ്യൂട്ടർ ബന്ധിപ്പിക്കുന്ന വിധം‬

‭1. NIC ഉള്ള ഒരു കമ്പ്യൂട്ടർ  2.TCP/ IP പിന്തുണയ്ക്കുന്ന ഒരു ഓപ്പറേറ്റിംഗ് സിസ്റ്റം‬

‭3.മോഡം  4. ടെലിഫോൺ കണക്ഷൻ   5. ISP തരുന്ന ഇന്റർനെറ്റ് അക്കൗണ്ട്‬

‭6.ബ്രൗസിംഗ് പോലുള്ള സോഫ്റ്റ്‌വെയർ‬

‭➤‬‭ഇന്റർനെറ്റ് കണക്ഷനുകൾ പങ്കിടാൻ കഴിയുന്ന വ്യത്യസ്ത‬‭മാർഗ്ഗങ്ങൾ : ലാൻ, വൈ-ഫൈ,ലൈ-ഫൈ‬

‭1.ഇന്റർനെറ്റിലെ സേവനങ്ങൾ‬‭:‬

‭1.1  Www ( വേൾഡ് വൈഡ് വെബ് )‬‭: ഇന്റർനെറ്റ് വഴി ആക്സസ്‬‭ചെയ്യാവുന്ന പരസ്പരബന്ധിതമായ‬

‭പൊതു വെബ്പേജുകളുടെ ഒരു സംവിധാനമാണ്. അവതരിപ്പിച്ച വ്യക്തി : ടിം ബെർണേഴ്‌സ് ലീ.‬

‭1.2 ബ്രൗസർ‬‭: WWW-ൽ വെബ് പേജുകൾ ആക്സസ് ചെയ്യുന്നതിനുള്ള ഒരു ആപ്ലിക്കേഷൻ‬

‭സോഫ്റ്റ് വെയറാണ്.‬

‭ഉദാ : ഗൂഗിൾ ക്രോം,ഇന്റർനെറ്റ് എസ്പ്ലൊറെർ,മോസില്ല ഫയർഫോക്സ്,ഒപേറാ,സഫാരി‬

‭വെബ് ബ്രൗസിംഗ്‬‭: വെബ് പേജുകൾക്കായി ഇന്റർനെറ്റിൽ തിരയുന്നതാണിത്.‬

‭1.3.‬‭സെർച്ച് എഞ്ചിനുകൾ‬‭: WWW-ലെ വിവരങ്ങൾ തിരയാൻ ഉപയോക്താക്കളെ‬‭അനുവദിക്കുന്ന‬

‭ഒരു വെബ്‌സൈറ്റാണിത്. ഉദാ: ഗൂഗിൾ,ബിങ്,യാഹൂ സെർച്ച്,ആസ്ക്‬

‭ക്രൗലേഴ്‌സ്‬ ‭വിവിധ വെബ്സൈറ്റുകൾ പരതി ആവശ്യമായ വിവരങ്ങൾ‬‭ശേഖരിക്കാനുപയോഗിക്കുന്ന ഒരു പ്രോഗ്രാം.‬

‭1.4 ഇ-മെയിൽ‬‭(ഇലക്‌ട്രോണിക് മെയിൽ) : ഇന്റർനെറ്റിലൂടെ‬‭കമ്പ്യൂട്ടറുകൾക്കിടയിൽ ഡിജിറ്റൽ‬

‭സന്ദേശങ്ങൾ കൈമാറുന്നതിനുള്ള ഒരു രീതിയാണിത്.‬

‭ഇ-മെയിൽ വിലാസങ്ങളുടെ ഘടന:‬‭യൂസർനെയിം@ഡൊമൈൻനെയിം  ,‬‭ഉദാ:‬‭Iza@gmail.com‬

‭ഒരു ഇ-മെയിലിന്റെ ഭാഗങ്ങൾ :‬

‭TO : സ്വീകർത്താവിന്റെ വിലാസം‬

‭CC : മെസ്സേജിന്റെ കോപ്പി അയക്കുന്ന രണ്ടാമത്തെ ആളുടെ അഡ്രസ്.‬

‭Bcc : മെസ്സേജിന്റെ കോപ്പി അയക്കുന്ന മൂന്നാമത്തെ ആളുടെ അഡ്രസ്.‬

‭Subject : അയക്കുന്ന മെസ്സേജിന്റെ ഉള്ളടക്കം.‬

‭Content : മെസ്സേജ് ടൈപ്പ് ചെയ്യുന്നിടം.‬

‭ഗുണങ്ങൾ :‬ ‭ഉയർന്ന വേഗത, ഉപയോഗിക്കാൻ എളുപ്പമാണ്, ഇത്‬‭വിലകുറഞ്ഞതാണ്,‬

‭എപ്പോൾ വേണമെങ്കിലും എവിടെയും ലഭ്യമാണ്, പരിസ്ഥിതി സൗഹൃദം.‬

‭ദോഷങ്ങൾ :‬‭ഇ-മെയിലിൽ വൈറസുകൾ, ജങ്ക് മെയിലുകൾ എന്നിവ‬‭ഉണ്ടായിരിക്കാം.‬

‭ഈ-മെയിലുമായി ബന്ധപ്പെട്ട പ്രോട്ടോകോൾസ്‬

‭➤ POP‬‭(പോസ്റ്റ് ഓഫീസ് പ്രോട്ടോക്കോൾ) or IMAP(ഇന്റർനെറ്റ്‬‭മെസ്സേജ് ആക്സസ്‬

‭പ്രോട്ടോക്കോൾ)‬‭ഇ-മെയിൽ ക്ലയന്റ് ആപ്ലിക്കേഷനുകൾ സാധാരണയായി‬‭സന്ദേശങ്ങൾ‬

‭സ്വീകരിക്കുന്നതിന് ഉപയോഗിക്കുന്ന പ്രോട്ടോകോളുകളാണിവ.‬

‭1.5 സോഷ്യൽ മീഡിയ‬‭:‬‭ആശയവിനിമയം നടത്താനും കമ്മ്യൂണിറ്റികൾ‬‭സൃഷ്ടിക്കാനും ഉള്ളടക്കം‬

‭പങ്കിടാനും ആശയങ്ങൾ കൈമാറാനും ആളുകളെ അനുവദിക്കുന്ന വെബ്സൈറ്റ് / ആപ്പ്.‬
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‭വ്യത്യസ്ത തരം സോഷ്യൽ മീഡിയകൾ‬‭:‬

‭ഇന്റർനെറ്റ് ഫോറങ്ങൾ‬‭: ആളുകൾക്ക് താൽപ്പര്യമുള്ള വിഷയങ്ങളിൽ‬‭ആശയങ്ങൾ‬

‭കൈമാറാവുന്ന വെബ്‌സൈറ്റ്.‬

‭സോഷ്യൽ ബ്ലോഗുകൾ‬‭:‬‭ഡയറി ശൈലിയിലുള്ള പോസ്റ്റുകൾ അടങ്ങുന്ന‬‭വിവരദായക വെബ്‌സൈറ്റ്.‬

‭മൈക്രോബ്ലോഗുകൾ‬‭:‬‭ഹ്രസ്വവും ടെക്‌സ്‌റ്റ് അടിസ്ഥാനമാക്കിയുള്ളതുമായ‬‭പോസ്റ്റുകൾ പങ്കിടുന്ന‬

‭പ്രവർത്തനം.‬

‭വിക്കികൾ‬‭: ഒന്നിലധികം ഉപയോക്താക്കളെ ഉള്ളടക്കം എഡിറ്റുചെയ്യാനും‬‭ആക്‌സസ് ചെയ്യാനും‬

‭അനുവദിക്കുന്ന വെബ്‌സൈറ്റ്‬

‭സോഷ്യൽ നെറ്റ്‌വർക്കുകൾ‬‭:‬‭ആളുകളെ പരസ്പരം ബന്ധിപ്പിക്കാൻ‬‭അനുവദിക്കുന്ന ഒരു വെബ്‌സൈറ്റ് /ആപ്പ്.‬

‭കോൺടെന്റ് കമ്മ്യൂണിറ്റികൾ‬‭: ഓൺലൈൻ മൾട്ടിമീഡിയ മെറ്റീരിയലുകൾ‬‭പങ്കിടാൻ‬

‭കോൺടെന്റ് കമ്മ്യൂണിറ്റികൾ അനുവദിക്കുന്നു.‬

‭ഗുണം:‬‭ആളുകളെ ഒരുമിച്ച് ചേർക്കുന്നു, ഇവന്റുകൾ ആസൂത്രണം‬‭ചെയ്യുകയും‬

‭സംഘടിപ്പിക്കുകയും ചെയ്യുക, ബിസിനസ് പ്രമോഷൻ, സാമൂഹിക നൈപുണ്യം.‬

‭ദോഷം:‬‭സ്വകാര്യതയിലേക്കുള്ള കടന്നുകയറ്റം, സൈറ്റുകൾക്ക്‬‭അടിമകളാകുന്നു,‬

‭അപവാദം പ്രചരിപ്പിക്കൽ.‬

‭2.‬‭Cyber security (സൈബർ സുരക്ഷ )‬‭:‬

‭സൈബർ ആക്രമണങ്ങളിൽ നിന്ന് ഇന്റർനെറ്റ് ബന്ധിപ്പിച്ച ഉപകരണങ്ങളും സേവനങ്ങളും‬

‭സംരക്ഷിക്കുന്ന രീതിയാണിത്.‬

‭കമ്പ്യൂട്ടർ വൈറസ്‬‭:‬‭കമ്പ്യൂട്ടറുകൾക്കിടയിൽ വ്യാപിക്കുകയും‬‭ഡാറ്റയ്ക്കും സോഫ്റ്റ്‌വെയറിനും‬

‭കേടുപാടുകൾ വരുത്തുകയും ചെയ്യുന്ന ഒരു തരം സോഫ്റ്റ് വെയർ പ്രോഗ്രാമുകളിത്.‬

‭കമ്പ്യൂട്ടർ വേം‬‭:‬‭സ്വയം പകർത്താനും മറ്റ് കമ്പ്യൂട്ടറുകളിലേക്ക്‬‭വ്യാപിക്കാനും കഴിയുന്ന പ്രോഗ്രാം.‬

‭ട്രോജൻ ഹോഴ്സ്‬‭:‬‭ഒരു ഉപകാരപ്രദമായ സോഫ്ട്‍വെയറാണെന്നു‬‭ഉപയോക്താക്കളെ തെറ്റിദ്ധരിപ്പിക്കുകയും‬

‭ഇൻസ്റ്റാൾ ചെയ്താൽ കമ്പ്യൂട്ടർ പ്രവർത്തനങ്ങൾ താറുമാക്കുകയും ചെയ്യുന്ന സോഫ്റ്റ്‌വെയർ.‬

‭സ്പാം‬‭:‬‭ഇന്റർനെറ്റിലൂടെ ധാരാളം ആളുകൾക്ക് അയയ്‌ക്കുന്ന‬‭ആവശ്യപ്പെടാത്ത സന്ദേശങ്ങളാണിത്.‬

‭ഹാക്കിങ്‬‭:‬‭കമ്പ്യൂട്ടർ നെറ്റ് വർക്കിലേക്കോ കമ്പ്യൂട്ടറിലോ‬‭ഉള്ള ഡാറ്റയിലേക്ക് അനധികൃത ആക്സസ്‬

‭നേടുന്ന പ്രക്രിയയാണ് ഹാക്കിംഗ്. ഹാക്ക് ചെയ്യുന്ന വ്യക്തിയെ ഹാക്കർ എന്ന് വിളിക്കുന്നു.‬

‭ഹാക്കർമാർ 3 തരമുണ്ട്.‬

‭വൈറ്റ്ഹാറ്റ് ഹാക്കർ‬‭:‬‭കമ്പ്യൂട്ടർ നെറ്റ് വർക്കിന്റെ‬‭സുരക്ഷ പരിശോധിക്കുന്ന എത്തിക്കൽ ഹാക്കറാണിവർ‬

‭ബ്ലാക്ക്ഹാറ്റ് ഹാക്കർ‬‭:‬‭ദുരുദ്ദേശ്യത്തോടെ കമ്പ്യൂട്ടർ‬‭ശൃംഖലകളിൽ കടന്നുകയറുന്ന ഹാക്കറാണിവർ.‬

‭ഗ്രേഹാറ്റ് ഹാക്കർ‬‭:‬‭എത്തിക്കൽ നിയമങ്ങൾ ലംഗിച്ചു‬‭കമ്പ്യൂട്ടർ നെറ്റ് വർക്കിൽ നുഴഞ്ഞു‬

‭കയറുകയും,  എന്നാൽ ദുരുദ്ദേശ്യങ്ങളില്ലാത്ത കമ്പ്യൂട്ടർ സുരക്ഷാ വിദഗ്ധരാണിവർ.‬

‭ഫിഷിംഗ് :‬‭വ്യാജ വെബ്സൈറ്റ് സൃഷ്ടിച്ചു യൂസർ നെയിം,പാസ്‌വേഡുകൾ,‬‭ക്രെഡിറ്റ് കാർഡ് തുടങ്ങിയ‬

‭വിവരങ്ങൾ നേടാനുള്ള ശ്രമമാണിത് . ഇത്തരം വ്യാജ വെബ്സൈറ്റ് നിർമിക്കുന്നതാണ്‬‭സ്പൂഫിംഗ്‬‭.‬

‭ഡിനൈൽ ഓഫ് സർവീസ്(DoS) അറ്റാക്ക്‬‭: വെബ് സെർവറിനെ ഷട്ട്‬‭ഡൗൺ ആക്കുന്നു.‬

‭3. നെറ്റ്‌വർക് അറ്റാക്കിനെ തടയാനുള്ള മാർഗ്ഗങ്ങൾ‬

‭ആന്റിവൈറസ് സ്കാനറുകൾ‬‭:‬‭കമ്പ്യൂട്ടർ സിസ്റ്റത്തിലെ ഫയലുകളിൽ‬‭കാണപ്പെടുന്ന വൈറസ്,വോം,‬

‭ട്രോജൻ ഹോഴ്സ്,മാൽവെയർ എന്നിവയെല്ലാം സ്‌കാൻ ചെയ്യുകയും അവ നീക്കം ചെയ്യുകയും ചെയ്യുന്നു.‬

‭ഫയർവാൾ‬‭:‬‭കമ്പ്യൂട്ടർ നെറ്റ് വർക്കിന്‌ സുരക്ഷ നൽകുന്ന ഹാർഡ്‌വെയറിന്റെയും സോഫ്റ്റ് വെയറിന്റെയും‬

‭ഒരു സമ്മിശ്ര രൂപമാണിത്.‬

‭കുക്കീസ്‌‬‭:‬ ‭നിയമ വിധേയമല്ലാത്ത ഉപയോഗത്തിനും, സ്വകാര്യ വിവരങ്ങൾ ഉപയോഗിക്കുന്നത് തടയുവാനും‬

‭കുക്കികളുടെ അടിക്കടിയുള്ള നശീകരണത്തിലൂടെ സാധിക്കുന്നു.‬
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‭XI  - CHAPTER - 10‬

‭IT APPLICATIONS‬

‭ICT( ഇൻഫർമേഷൻ ആൻഡ് കമ്മ്യൂണിക്കേഷൻ ടെക്നോളജി ) അപ്ലിക്കേഷൻ‬

‭1. e-Governance( ഇ-ഗവേണൻസ് ) :‬

‭പൗരന്മാർക്ക് സൗകര്യപ്രദവും കാര്യക്ഷമവും സുതാര്യവുമായ രീതിയിൽ സർക്കാർ സേവനങ്ങൾ‬

‭എത്തിക്കുന്നതിനുള്ള ICTയുടെ ആപ്ലിക്കേഷനാണ്.‬

‭1.1. ഇ-ഗവേണൻസിലെ വ്യത്യസ്ത ഇടപെടലുകൾ‬

‭➤‬‭G2C ( ഗവണ്മെന്റ് ടു സിറ്റിസൺസ് ) :‬‭ഗവണ്മെന്റും‬‭പൗരന്മാരും തമ്മിൽ ആശയവിനിമയം‬

‭➤‬‭G2B ( ഗവണ്മെന്റ് ടു സിറ്റിസൺസ് ) :‬‭ഗവണ്മെന്റും‬‭ബിസിനസ്സുകാരും തമ്മിൽ ആശയവിനിമയം‬

‭➤‬‭G2E ( ഗവണ്മെന്റ് ടു എംപ്ലോയീസ് ) :‬‭ഗവണ്മെന്റും ജീവനക്കാരും‬‭തമ്മിൽ ആശയവിനിമയം‬

‭➤‬‭G2G ( ഗവണ്മെന്റ് ടു ഗവണ്മെന്റ് ) :‬‭ഗവണ്മെന്റും‬‭ഗവണ്മെന്റും തമ്മിൽ ആശയവിനിമയം‬

‭1.2 ഇ-ഗവേണൻസ് ഇൻഫ്രാസ്ട്രക്ചർ‬

‭➤‬‭SDC ( സ്റ്റേറ്റ് ഡാറ്റ സെന്റർ )‬‭:‬‭സംസ്ഥാന തലത്തിലുള്ള‬‭ഇ-ഗവൺമെന്റ് ആപ്ലിക്കേഷനുകൾ‬

‭ഹോസ്റ്റുചെയ്യുന്നതിനുള്ള ഭൗതിക സൗകര്യം ഒരുക്കുന്നു.‬

‭➤‬‭KSWAN ( കേരളം സ്റ്റേറ്റ് വൈഡ് ഏരിയ   നെറ്റ്‌വർക്ക്‬‭):‬‭സംസ്ഥാനത്തെ പൊതുമേഖലയ്ക്ക്‬

‭വൈഡ് ഏരിയ നെറ്റ്‌വർക്ക് കണക്റ്റിവിറ്റിയും അനുബന്ധ സേവനങ്ങളും ലഭ്യമാക്കാൻ‬

‭അനുവദിക്കുന്ന അത്യാധുനിക സംവിധാനം.‬

‭➤‬‭CSC ( കോമൺ സർവീസ് സെന്റർ  )‬‭:‬‭സർക്കാർ, സ്വകാര്യ,‬‭സാമൂഹിക മേഖലയിലെ സേവനങ്ങളുടെ‬

‭ഫ്രണ്ട് എൻഡ് ഡെലിവറി പോയിന്റുകളാണ് CSC. ഉദാ: അക്ഷയ സെന്റർ,ജനസേവ കേന്ദ്രം‬

‭⏩‬ ‭ഇ-ഗവേണൻസിന്റെ ഗുണങ്ങൾ:‬‭വേഗത,സമയവും പണവും ലാഭിക്കുന്നു,‬

‭സുതാര്യത,അഴിമതി കുറയ്ക്കുന്നു.‬

‭⏩‬ ‭ഇ-ഗവേണൻസിന്റെ വെല്ലുവിളികൾ:‬‭ഇ-സാക്ഷരത കുറവ്,സൈബർ‬‭ആക്രമണം,വ്യക്തിഗത‬

‭വിവരങ്ങളുടെ ലീക്ക്,കമ്പ്യൂട്ടറും അനുബന്ധ ഉപകരണങ്ങളും ക്രമീകരിക്കുന്നതിന്റെ ചെലവ്.‬

‭2. ഇ-ബിസിനസ്സ്:‬

‭ICTയുടെസഹായത്താൽ ബിസിനസ് സംബന്ധമായ വിവിധ പ്രവർത്തനങ്ങൾ ചെയ്യുന്നതാണിത്.‬

‭2.1 ഇ-കൊമേഴ്‌സ് :‬

‭സാധനങ്ങളും സേവനങ്ങളും ഓൺലൈൻ പണമിടപാടിലൂടെ വാങ്ങുന്നതിനും‬

‭വിൽക്കുന്നതിനുമുള്ള ഒരു രീതി. ഉദാ:ആമസോൺ,ഫ്ലിപ്കാർട്.‬

‭2.2. ഇ-ബാങ്കിംഗ് :‬
‭ഓൺലൈൻ സംവിധാനത്തിലൂടെ ഏതു സമയത്തും ബാങ്ക് ഇടപാടുകൾ നടത്താൻ അനുവദിക്കുന്നു.‬

‭2.3. ഇലക്ട്രോണിക് പേയ്മെന്റ് സിസ്റ്റം (EPS):‬

‭പണമോ ചെക്കുകളോ ഇല്ലാതെ ഓൺലൈൻ ഇടപാടുകൾ നടത്താൻ  ആളുകളെയും‬

‭ബിസിനസുകളെയും അനുവദിക്കുന്നു. ഉദാ: G-പേ, ഫോൺ-പേ,പേടിഎം‬
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‭⏩‬‭ഇ-ബിസിനസ്ന്റെ ഗുണങ്ങൾ:‬

‭വേഗത,പ്രവർത്തന ചെലവ് കുറയ്ക്കുന്നു,സമയവും പണവും ലാഭിക്കുന്നു, എല്ലാ സമയത്തും‬

‭തുറന്നിരിക്കുന്നു, ഭൂമിശാസ്ത്രപരമായ പരിമിതികൾ മറികടക്കുന്നു, വലിയ സെലെക്ഷൻ ലഭ്യമാണ്‬

‭⏩‬‭ഇ-ബിസിനസ്ന്റെ വെല്ലുവിളികൾ:‬

‭സാധനങ്ങൾ തൊട്ടുനോക്കി വാങ്ങുവാൻ സാധിക്കില്ല, ഡെലിവറിക്ക്‬

‭കാലതാമസം, സൈബർ ആക്രമണം, ഇ-സാക്ഷരത ആവശ്യമുണ്ട്.‬

‭3. ഇ-ലേർണിംഗ് :‬‭ഇലക്‌ട്രോണിക് മീഡിയയും ICTയും ഉപയോഗിച്ചു‬‭നടത്തുന്ന പഠന രീതിയാണിത്.‬

‭3.1 ഇ-ലേണിംഗ് ടൂളുകൾ‬

‭3.1.A‬‭ഇലക്ട്രോണിക് ബുക്ക് റീഡർ (ഇ-ബുക്കുകൾ):‬‭ഇ-ബുക്കുകളെ‬‭സ്റ്റോർ ചെയ്യുവാനും,റീഡ്‬

‭ചെയ്യുവാനുമുള്ള ഇലക്ട്രോണിക് ഉപകരണം.‬

‭ഉദാ: ആമസോൺ കിൻഡിൽ,iPad‬

‭3.1.B‬‭ഇ-ടെക്‌സ്റ്റ്‬‭: ഇലക്ട്രോണിക് രൂപത്തിലുള്ള ടെക്സ്റ്റ്‬‭ബുക്കുകളാണിവ.‬

‭3.1.C‬‭ഓൺലൈൻ ചാറ്റ്‬‭:‬‭പഠിതാക്കൾക്കു ആശയങ്ങൾ ഓൺലൈനിലൂടെ‬‭പങ്കിടാൻ സാധിക്കുന്നു.‬

‭3.1.D‬‭ഇ-കണ്ടെന്റ്‬‭:‬‭ഇ-ലേർണിംഗിനായുള്ള വീഡിയോകൾ, അവതരണങ്ങൾ,‬‭ഗ്രാഫിക്സ്, ആനിമേഷൻ‬

‭3.1.E‬‭വിദ്യാഭ്യാസ ടിവി ചാനലുകൾ :‬ ‭ഉദാ:  വ്യാസ്,‬‭വിക്ടർസ്‬

‭⏩‬ ‭ഇ-ലേണിംഗ് ഗുണങ്ങൾ:‬‭പാഠപുസ്തകത്തിന്റെ ആവശ്യമില്ല,‬‭ഓൺലൈൻ പഠനത്തിന് അധ്യാപക‬

‭ദൗർലഭ്യം പരിഹരിക്കാൻ കഴിയും,സമയവും സ്ഥലവും ഒരു തടസ്സമല്ല.‬

‭4. ICT അധിഷ്ഠിത സേവനങ്ങൾ:‬

‭4.1 BPO (ബിസിനസ് പ്രോസസ് ഔട്ട്‌സോഴ്‌സിംഗ്) :‬‭ICTയുടെ‬‭വിവിധ ബിസിനസ്സുമായി ബന്ധപ്പെട്ട‬

‭പ്രവർത്തനങ്ങൾ മറ്റൊരു കമ്പനിക്ക് ഉപകരാർ നൽകുന്ന ഒരു രീതിയാണിത്. ICTഅപ്ലിക്കേഷന്റെ‬

‭സഹായത്തോടെ പേറോൾ, അക്കൗണ്ടിംഗ്, ടെലിമാർക്കറ്റിംഗ്, ഡാറ്റ റെക്കോർഡിംഗ്, സോഷ്യൽ‬

‭മീഡിയ, കസ്റ്റമർ സപ്പോർട്ട്, ഹ്യൂമൻ റിസോഴ്‌സ്, മാർക്കറ്റിംഗ്, സപ്ലൈ ചെയിൻ മാനേജ്‌മെന്റ്.‬

‭4.2 KPO ( നോളജ് പ്രോസസ് ഔട്ട്സോഴ്സിംഗ് ):‬‭BPOയുടെ‬‭ഉപവിഭാഗമായ KPO പ്രധാന‬

‭ബിസിനസ്സ് പ്രവർത്തനങ്ങളായ ഡാറ്റ അനലിറ്റിക്‌സ്, ഇൻഫർമേഷൻ ടെക്‌നോളജി എന്നിവ‬

‭പോലുള്ള വിജ്ഞാനാധിഷ്‌ഠിത സേവനങ്ങൾ പിന്തുണയ്ക്കുന്നു. ഒരു പ്രത്യേക മേഖലയിൽ‬

‭പ്രത്യേക അറിവുള്ള ഫ്രീലാൻസ് വ്യക്തികളാണ് ഇവ ചെയ്യുന്നത്.‬

‭4.3 കോൾ സെന്റർ :‬‭ഒരു സ്ഥാപനത്തിലെ കോളുകൾ കൈകാര്യം‬‭ചെയ്യുന്ന സേവന സൗകര്യം.‬

‭4.4. ടെലികോൺഫറൻസിങ്,    4.5. വീഡിയോ കോൺഫെറെൻസിങ്‬
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