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‭CHAPTER - 1‬

‭INTRODUCTION TO PUBLISHING‬

‭⏩ എന്താണ്‬‭പബ്ലിഷിംഗ് :‬‭വിവരങ്ങൾ പൊതുജനങ്ങൾക്ക് ലഭ്യമാക്കുന്നതിനുള്ള‬‭പ്രവർത്തനം.‬
‭പബ്ലിഷിംഗ് രണ്ടുതരം :‬‭പബ്ലിഷിംഗ് ത്രൂ  പ്രിന്റ് മീഡിയ,‬‭പബ്ലിഷിംഗ് ത്രൂ  ഇലക്ട്രോണിക് മീഡിയ‬

‭1. പബ്ലിഷിംഗ് ത്രൂ  പ്രിന്റ് മീഡിയ‬
‭പബ്ലിഷിംഗ് ത്രൂ  പ്രിന്റ് മീഡിയയിലെ 3 പ്രവർത്തനങ്ങൾ :‬‭1.1 പ്രീപ്രെസ്സ്, 1.2. പ്രിന്റിങ്, 1.3. പോസ്റ്റ്പ്രസ്‬

‭1.1  പ്രീപ്രെസ്സ് :‬‭ഡോക്യുമെന്റ് പ്രിന്റ് ചെയ്യുന്നതിന്‬‭മുന്നേ ഉള്ള പ്രവർത്തനം.‬
‭ഉദാ: ലേഔട്ട് സെറ്റിങ്,ബുക്ക് സൈസ് തീരുമാനിക്കുക‬
‭DTP‬‭(DeskTop Publishing) : സോഫ്റ്റ്‌വെയർ‬‭ഉപയോഗിച്ചു ഡോക്യൂമെന്റിന്റെ ലേഔട്ട് സെറ്റ്‬
‭ചെയ്യുന്നു.‬‭ഉദാഹരണം:‬‭സ്ക്രൈബസ്, അഡോബ് ഇൻഡിസൈൻ,‬‭ക്വാർക് എക്സ്പ്രസ്സ്‬

‭പ്രീപ്രെസ്സ് ആക്ടിവിറ്റികൾ‬
‭A.ഡിസൈനിങ്       B.പ്രീ-ഫ്ലൈറ്റിങ്      C.ക്രിയേറ്റിങ് പ്രൂഫ്         D.പ്രിന്റിങ് പ്ലേറ്റ്സ്‬
‭1.1.A. ഡിസൈനിങ് :‬
‭1.1.A.1.  ഡിസൈൻ ഘടകങ്ങൾ ( എലെമെന്റ്സ് ഓഫ് ഡിസൈൻ )‬
‭1.ലൈൻ  :‬‭സ്പെയ്സ് വിഭജിക്കാനും ഒരു പ്രത്യേക സ്ഥലത്തേക്ക്‬‭ശ്രദ്ധ കേന്ദ്രീകരിക്കാൻ .‬
‭2. ഷെയ്പ്പ് :‬‭പേജുകളെ ആകർഷകമാക്കാൻ ഷെയ്പ്പ് (സമചതുരം,വൃത്തം)‬‭ഉപയോഗിക്കുന്നു.‬
‭3. കളർ :‬‭വായിക്കുന്ന ആളുകളുടെ മൂഡിനെ കളർ സ്വാധീനിക്കുന്നു.‬
‭4. സ്പേസ് :‬‭ചിത്രങ്ങളുടെ ആഴം സൃഷ്ടിക്കുന്നു.‬
‭5. ടൈപ്പോഗ്രഫി :‬‭ഡോക്യുമെന്റ് വായിക്കാവുന്നതും മനോഹരവുമാക്കുന്നതിനും‬

‭അക്ഷരങ്ങൾ ക്രമീകരിക്കുന്നതിനുള്ള സാങ്കേതികതയാണിത്‬‭.‬
‭**ഫോണ്ടുകൾ രണ്ടു തരത്തിലുണ്ട് :‬
‭സാൻസ് സെരിഫ് :‬‭പാദങ്ങളില്ലാത്ത ഫോണ്ടുകൾ‬
‭സെരിഫ് :‬‭പാദങ്ങളുള്ള  ഫോണ്ടുകൾ.‬
‭1.1.A.2. ഡിസൈൻ തത്വങ്ങൾ ( പ്രിൻസിപ്പിൾസ് ഓഫ് ഡിസൈൻ‬‭)‬
‭1. ബാലൻസ്‬‭:‬‭ഒബ്ജക്റ്റ്,കളർ,ടെസ്റ്റുകൾ എന്നിവയെ വിദഗ്ധമായി‬‭പേജിൽ ക്രമീകരിക്കുന്നു.‬
‭2. റീപെറ്റീഷൻ :‬‭പേജിൽ പാറ്റേണുകൾ ആവർത്തിച്ച് ആർട്‬‭വർക്കുകളെ ആകർഷണമാക്കുക.‬
‭3. കോൺട്രാസ്റ് :‬‭കളർ,ദിശകൾ മറ്റൊന്നിൽ നിന്ന് വ്യത്യസ്തമാക്കാൻ‬‭ഉപയോഗിക്കുന്നു.‬
‭4. ഹാർമണി :‬‭കാഴ്ച്ചയിൽ ഒരേപോലുള്ള ഭാഗങ്ങൾ ഭംഗിയാക്കാൻ.‬
‭5. യൂണിറ്റി :‬‭ഡിസൈൻ വർക്കിന്റെ വ്യത്യസ്‌ത ഘടകങ്ങളെ‬‭ഒന്നിച്ച് ക്രമീകരിക്കുന്നു.‬
‭6. ഡൊമിനൻസ്:‬‭നിറമോ,വലിപ്പമോ നൽകി പേജിലെ ഘടകങ്ങൾക്ക്‬‭പ്രത്യേക ശ്രദ്ധ കൊടുക്കുന്നു.‬

‭1.1.B പ്രീ-ഫ്ലൈറ്റിങ് :‬‭പ്രിന്റിങ്ങിനു മുമ്പ് പേജുകൾ‬‭എല്ലാം കൃത്യമായിട്ട് ഉണ്ടോ എന്ന് ഈ ഘട്ടത്തിൽ‬
‭പരിശോധിക്കും.‬‭പ്രസിദ്ധീകരണത്തിനായി ഒരു രേഖ തയ്യാറാക്കുന്ന‬‭പ്രക്രിയയാണ് : പ്രീ പ്രസ് / പ്രീ-ഫ്ലൈറ്റിംഗ് /‬
‭ഡിസൈനിംഗ്‬

‭1.1.C. ക്രിയേറ്റിങ് പ്രൂഫ്  :‬‭പൂർത്തീകരിച്ച ഡിസൈൻ‬‭പ്രിൻറ് ചെയ്യുമ്പോൾ എപ്രകാരമാണ്‬
‭കാണപ്പെടുന്നത്  എന്ന് മനസ്സിലാക്കാൻ സഹായിക്കുന്നു.‬
‭PDF ന്റെ പൂർണ രൂപം :‬ ‭പോർട്ടബിൾ ഡോക്യുമെന്റ് ഫോർമാറ്റ്‬
‭1.1.D. പ്രിന്റിങ് പ്ലേറ്റ്സ്  :‬‭പേജുകളിൽ പ്രിൻറ് ചെയ്യേണ്ട‬‭വസ്തുക്കൾ പ്രിൻറിംഗ് പ്ലേറ്റിൽ ഇമേജുകൾ‬
‭ആയി പതിപ്പിക്കും.ഓഫ്-സെറ്റ് പ്രെസ്സുകളിൽ ഉപയോഗിക്കുന്നു.‬
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‭1.2 പ്രിന്റിങ്‬
‭1.2.1. ലിത്തോഗ്രാഫിക് പ്രിന്റിങ്  :‬‭ഓഫ്-സെറ്റ് പ്രിന്റിങ്‬‭ടെക്‌നിക്കാണ്. പ്രിന്റിങ് പ്ലേറ്റുകളുടെ‬
‭സഹായത്താൽ വ്യാവസായികമായി പ്രിന്റ് ചെയ്യുന്നു.‬
‭1.2.2. ഡിജിറ്റൽ പ്രിന്റിങ്  :‬‭പ്രിന്റിങ്  പ്ലേറ്റുകളല്ലാത്തതിനാൽ ഇമേജ് എഡിറ്റിംഗ് സാധ്യമാണ്.‬
‭ലിത്തോഗ്രാഫിക്  പ്രിന്റിനെ അപേക്ഷിച്ചു കോസ്റ്റ്, ക്വാളിറ്റി  കൂടുതലാണ്.‬

‭*CMYK‬‭- സിയാൻ, മജെന്ത,യെല്ലോ,ബ്ലാക്ക്‬
‭1.2.3. ഗ്രേവിയർ പ്രിന്റിങ്:‬‭പേപ്പർ,പ്ലാസ്റ്റിക്,ലോഹം,പാക്കേജിംഗ്,മെറ്റീരിയലുകൾ,അലുമിനിയം,‬
‭ഫോയിൽപേപ്പർ എന്നിങ്ങനെയുള്ള വസ്തുക്കളിൽ ഉയർന്ന ക്വാളിറ്റിയിൽ പ്രിന്റ് ചെയ്യാൻ‬
‭സാധിക്കുന്നു. ഉദാ: ലെയ്സ് കവർ.‬
‭1.2.4. ഫ്ലെക്സോഗ്രാഫി:‬‭ലേബലുകൾ,കാർഡ്ബോർഡ് ബോക്സുകൾ,ബാഗുകൾ,ഫ്ലെക്സിബിൾ‬
‭പാക്കേജിംഗ് ഫിലിമുകൾ തുടങ്ങിയ പാക്കേജിംഗ് മെറ്റീരിയലുകളിൽ അച്ചടിക്കാൻ വ്യാപകമായി‬
‭ഉപയോഗിക്കുന്ന രീതിയാണിത്.‬
‭1.2.5. സ്ക്രീൻ പ്രിന്റിങ്  :‬‭ഫാബ്രിക്, പേപ്പർ, ടി-ഷർട്ടുകൾ,‬‭പോസ്റ്ററുകൾ, ബാനറുകൾ എന്നിവയിൽ‬

‭കലാപരമായ ചിത്രങ്ങൾ, ചിഹ്നങ്ങൾ മെഷും മഷിയും ഉപയോഗിച്ച് സൃഷ്ടിക്കുന്നു.‬
‭1.3 പോസ്റ്റ് പ്രെസ്സ്‬

‭1.3.1. ഫോൾഡിങ്   :‬‭പ്രിന്റ് ചെയ്തു വന്ന പേജുകളെ മടക്കുന്ന‬‭രീതിയാണിത്.‬
‭1.3.2. അസ്സംബ്ലിങ്    :‬‭പ്രിന്റ് ചെയ്ത എല്ലാ പേജുകളും‬‭ക്രമത്തിൽ കൂട്ടിച്ചേർക്കുന്നതാണിത്.‬
‭1.3.3. ബൈൻഡിങ്  :‬‭ഹാൻഡ് കവർ,സ്പൈറൽ,തെർമൽ ,സ്റ്റിച്ചേഡ്‬‭എന്നിവ‬
‭1.3.4. കട്ടിങ് :‬‭പേജുകളിലെ ക്രോപ് മാർക്കിനെ അടിസ്ഥാനമാക്കി‬‭മെഷീൻ മുഖേനയോ,കൈകൾ‬
‭കൊണ്ടോ പേജുകൾ മുറിച്ചുമാറ്റുന്നു.‬

‭2.പബ്ലിഷിംഗ് ത്രൂ  ഇലക്ട്രോണിക്  മീഡിയ‬
‭ഇ-ബുക്കുകൾ, ഡിജിറ്റൽ മാസികകൾ എന്നിവയുടെ ഡിജിറ്റൽ പ്രസിദ്ധീകരണമാണിത്.‬

‭2.1‬‭രണ്ടുതരം ഇലക്ട്രോണിക് പബ്ലിഷിംഗ്‬‭ഏതെല്ലാം ?‬
‭2.1.1‬‭വെബ് ബേസ്ഡ് പബ്ലിഷിംഗ്:‬‭ഇന്റർനെറ്റിൽ ഉള്ളടക്കങ്ങൾ‬‭പ്രസിദ്ധീകരിക്കുന്ന പ്രക്രിയയാണ്‬
‭വെബ് പബ്ലിഷിംഗ് അല്ലെങ്കിൽ ഓൺലൈൻ പ്രസിദ്ധീകരണം.‬
‭ഉദാ: വിക്കിപീഡിയ,ഓൺലൈൻ പത്രങ്ങൾ, ബ്ലോഗുകൾ‬
‭2.1.2.‬‭ഡിജിറ്റൽ ഡിസ്ട്രിബൂഷൻ / ഡിജിറ്റൽ പബ്ലിഷിംഗ്‬ ‭:‬‭ഇ-ബുക്കുകൾ, ഇ-ടെസ്റ്റുകൾ,‬
‭ഇ-ജേണലുകൾ തുടങ്ങിയ ഇലക്‌ട്രോണിക് രീതിയിൽ പ്രസിദ്ധീകരിച്ച മെറ്റീരിയലുകൾ.‬

‭2.2.ഇ-ബുക്ക് റീഡർ :‬‭ഡിജിറ്റൽ പുസ്തകങ്ങൾ ( ഇ-ബുക്കുകൾ‬‭) വായിക്കുന്നതിനുള്ള ഒരു‬
‭പോർട്ടബിൾ ഇലക്ട്രോണിക് ഉപകരണമാണ്.‬‭ഉദാ :‬‭ആമസോൺ കിൻഡിൽ,‬‭ആപ്പിൾ ഐപാഡ്‬

‭2.3. PDF ഡോക്യൂമെന്റുകൾ വായിക്കാൻ ഉപയോഗിക്കുന്ന സോഫ്റ്റ്‌വെയർ ഏതെല്ലാം ?‬
‭ഉത്തരം: അഡോബി റീഡർ, ഫോക്സിറ്റ്‌ , google ക്രോം ,Open Office.org , Nitro PDF‬

‭***‬‭PDF : പോർട്ടബിൾ ഡോക്യുമെന്റ് ഫോർമാറ്റ്‬
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‭XII  -  CHAPTER - 2‬
‭INTRODUCTION TO WORD PROCESSORS‬

‭1. വേഡ് പ്രോസസർ സോഫ്റ്റ്‌വെയർ :‬‭ഒരു ഡോക്യുമെന്റ് സൃഷ്ടിക്കാൻ ഉപയോഗിക്കുന്ന ഒരു‬
‭ആപ്ലിക്കേഷൻ സോഫ്റ്റ്‌വെയറാണ് വേഡ് പ്രോസസർ.‬
‭ഉദാ:ലിബ്രെഓഫീസ് റൈറ്റർ,മൈക്രോസോഫ്ട് വേർഡ്‬
‭2. എന്താണ് ഡോക്യുമെന്റ് :‬‭ടെക്‌സ്‌റ്റോ ചിത്രങ്ങളോ‬‭അടങ്ങുന്ന ഒരു ഫയലാണ് ഡോക്യുമെന്റ്.‬
‭3.വേഡ് പ്രോസസറുകളുടെ സവിശേഷതകൾ‬‭ചുരുക്കി വിശദീകരിക്കുക‬

‭3.1.‬‭സ്പീഡ് :‬‭പുതിയ ഡോക്യുമെന്റ് വേഗത്തിലും എളുപ്പത്തിലും‬‭സൃഷ്ടിക്കുന്നതിനും,കൈകാര്യം‬
‭ചെയ്യുന്നതിനും സംരക്ഷിക്കാനും വീണ്ടെടുക്കാനും പ്രിന്റ് ചെയ്യാനും സാധിക്കും.‬

‭3.2‬ ‭വേർഡ് റാപ്പിംഗ്‬‭:‬‭ഒരു വരിയുടെ അവസാനം വരുന്ന‬‭ഒരു വാക്ക് മാർജിനുകൾക്കുള്ളിൽ വാചകം‬
‭നിലനിർത്തുന്നതിനായി, ഒരു പുതിയ വരിയിലേക്ക് സ്വയമേ നീക്കുന്ന ഒരു പ്രക്രിയയാണിത്.‬

‭3.3‬‭എഡിറ്റിംഗ് :‬‭വാചകം ചേർക്കൽ,ഇല്ലാതാക്കൽ, പകർത്തൽ‬‭തുടങ്ങിയ തിരുത്തൽ ക്രിയയാണിത്.‬
‭3.4.‬‭ഡ്രോയിങ് & ഗ്രാഫിക്സ് :‬‭ചിത്രങ്ങളും,ഷെയ്പ്പുകളും,‬‭ചെയ്യാനുള്ള ടൂൾ ലഭ്യമാണ്.‬
‭3.5.‬‭ടേബിൾ :‬‭ഡാറ്റകളെ വരിയും നിരയുമുള്ള ടേബിളുകൾ‬‭ആയി അവതരിപ്പിക്കാം.‬
‭3.6.‬‭ഫോർമാറ്റിംഗ് :‬‭വേർഡ്, പാരഗ്രാഫ്, പേജ് പോലുള്ള‬‭വിവിധ തരം ഫോർമാറ്റിംഗ് വേഡ്‬

‭പ്രോസസറിൽ ഉണ്ട് . ഇത് ഡോക്യൂമെന്റിനെ കൂടുതൽ മനോഹരമാക്കുന്നു.‬
‭3.7.‬‭ഹെയ്ഡർ :‬‭എല്ലാ പേജുകളുടെയും മുകളിൽ ദൃശ്യമാകുന്ന‬‭വാചകമാണ് ഹെഡ്ഡർ.‬

‭ഫൂട്ടർ :‬‭എല്ലാ പേജുകളുടെയും ചുവടെ ദൃശ്യമാകുന്നത്‬‭ഫൂട്ടർ.‬
‭പേജ് നമ്പർ :‬ ‭ഓരോ പേജിനും നൽകിയിരിക്കുന്ന‬‭തുടർച്ചയായ സംഖ്യകളാണ് പേജ് നമ്പറുകൾ.‬

‭3.8.‬‭സ്പെൽ&ഗ്രാമർ ചെക്ക് :‬‭ഡോക്യൂമെന്റിലെ അക്ഷര‬‭തെറ്റുകളും,വ്യാകരണ തെറ്റുകളും‬
‭കണ്ടെത്താനുള്ള മാർഗം.‬

‭3.9.‬‭മെയിൽ മെർജിങ് :‬‭ഒരു പ്രധാന ഡോക്യൂമെന്റിനെ ഒരു‬‭കൂട്ടം ഡാറ്റയുമായോ ഡാറ്റാ സ്രോതസ്സുകളുമായോ‬
‭ലിങ്ക് ചെയ്‌ത് അക്ഷരങ്ങളും മെയിലിംഗ് ലേബലുകളും എൻവലപ്പുകളും സൃഷ്‌ടിക്കാൻ.‬

‭3.10.‬‭ഇൻഡക്സ് :‬ ‭പ്രധാന പദങ്ങളോ വാക്കുകളോ ഉൾപ്പെടുന്ന‬‭ഡോക്യുമെന്റ്. പ്രോജക്റ്റ് റിപ്പോർട്ട്,  സർവേ പോലുള്ള‬
‭പ്രൊഫഷണൽ ഡോക്യുമെന്റുകളുടെ അവസാനത്തിലാണ് ഇൻഡക്സ് സാധാരണയായി സൃഷ്ടിക്കുന്നത്.‬

‭ടേബിൾ ഓഫ് കോൺടെന്റ്സ് (TOC ) :‬‭പാഠപുസ്തകത്തിനായുള്ള‬ ‭ഡോക്യുമെന്റിന്റെ തുടക്കത്തിൽ കാണപ്പെടുന്ന‬
‭ഉള്ളടക്ക പട്ടിക. പ്രധാന തലക്കെട്ടുകളും ഡോക്യുമെന്റിൽ ദൃശ്യമാകുന്ന ഉപതലക്കെട്ടുകളും, പേജ് നമ്പർ ഉൾപ്പെടുന്നു.‬

‭3.11.‬‭ടെംപ്ലേറ്റ്സ്:‬‭മുൻകൂട്ടി തയ്യാറാക്കി വെച്ചിരിക്കുന്ന‬‭ഡോക്യുമെന്റ് ഫോർമാറ്റ്.‬
‭3.12.‬‭ഒബ്ജക്റ്റ് ലിങ്കിംഗ് & എംബെഡ്‌ഡിങ് (OLE) :‬‭മറ്റു‬‭ആപ്ലിക്കേഷനുകൾ സൃഷ്‌ടിച്ച ഒബ്ജക്റ്റുകൾ‬

‭അടങ്ങിയ ഡോക്യൂമെന്റുകൾ സൃഷ്‌ടിക്കാനും എഡിറ്റുചെയ്യാനും ഉപയോക്താക്കളെ അനുവദിക്കുന്ന ഒരു‬
‭സംവിധാനമാണ് OLE. ഉദാഹരണം : Word ഡോക്യുമെന്റുകളിലേക്ക് Excel സ്‌പ്രെഡ്‌ഷീറ്റുകൾ ചേർക്കുന്നതാണ്.‬

‭4. റൈറ്റർ IDE യിലെ 4 ഘടകങ്ങൾ‬
‭4.1.‬‭ടൈറ്റിൽ ബാർ:‬‭IDE വിൻഡോയുടെ ഏറ്റവും മുകളിലുള്ള‬‭ഭാഗമാണിത്. ഡോക്യൂമെന്റിന്റെ പേരും,‬

‭സോഫ്റ്റ്‌വെയർന്റെ പേരും കാണിക്കുന്നു.വലതുവശത്ത് നിയന്ത്രണ ബട്ടണുകൾ കാണിക്കുന്നു.‬
‭4.2.‬‭മെനു ബാർ :‬‭ഫയൽ,എഡിറ്റ്,വ്യൂ,ഫോർമാറ്റ് തുടങ്ങിയ‬‭പ്രധാനപ്പെട്ട മെനു ഇനങ്ങൾ അടങ്ങിയിരിക്കുന്നു.‬

‭4.3.‬‭ടൂൾ ബാർ :‬‭കമാൻഡ് ഷോർട് കട്ട്കളുടെ ഐക്കൺ അഥവാ‬‭ബട്ടണുകൾ കാണുന്നു.‬
‭*ടൂൾട്ടിപ് ( Tooltip ) :‬‭ബട്ടണിൽ മൗസ് പോയിന്റർ‬‭വെച്ചാൽ ടെക്സ്റ്റ് ദൃശ്യമാകും. ടൂളിനെ കുറിച്ച് വിവരം നൽകുന്നു.‬

‭4.4.‬‭സ്ക്രോൾ ബാർ :‬‭വിൻഡോയിലൂടെ മുകളിലേക്കും,താഴേക്കും,ഇടത്തോട്ടും,വലത്തോട്ടും‬‭നീങ്ങുന്ന പ്രക്രിയ.‬

‭4.5.‬‭റൂളർ :‬‭ഡോക്യുമെന്റിന്റെ ഇടത് വലത് മാർജിനുകൾ മാറ്റാൻ‬‭ഇത് അനുവദിക്കുന്നു.‬
‭4.6.‬‭സ്റ്റാറ്റസ് ബാർ :‬‭ഇത് IDE വിൻഡോയുടെ ചുവടെ ദൃശ്യമാണ്.ഇത്‬‭പേജ് നമ്പറുകൾ,കോളം,‬

‭കഴ്‌സർ സ്ഥിതിചെയ്യുന്ന ലൈൻ നമ്പർ, തിരഞ്ഞെടുത്ത ഭാഷ തുടങ്ങിയ വിവരങ്ങൾ പ്രദർശിപ്പിക്കുന്നു.‬

‭4.7.‬‭ടെക്സ്റ്റ് ഏരിയ:‬‭ഡോക്യുമെന്റിന്റെ ടെക്സ്റ്റ്‬‭മാറ്റർ ടൈപ്പ് ചെയ്യുന്ന സ്ഥലമാണിത്.‬
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‭5. Short cut കീയും അതിന്റെ ഉപയോഗവും‬
‭Function‬ ‭Short-cut key ‭Function‬ ‭Short-cut key‬

‭Create a new document / File‬ ‭Ctrl+N‬ ‭Print‬ ‭Ctrl+P‬

‭Open a document‬ ‭Ctrl+O‬ ‭Creating a table‬ ‭Ctrl+F12‬

‭Function‬ ‭Short-Cut Key‬ ‭Function‬ ‭Short-Cut Key‬

‭Save Document‬ ‭Ctrl+S‬ ‭Print Preview‬ ‭Ctrl + Shift + O‬

‭Select All‬ ‭Ctrl+A‬ ‭Closing a document‬ ‭File-> Close / Ctrl+W‬

‭Cut‬ ‭Ctrl+X‬ ‭Undo‬ ‭Ctrl+Z‬

‭Paste‬ ‭Ctrl+V‬ ‭Redo‬ ‭Ctrl+Y‬

‭Copy‬ ‭Ctrl+C‬ ‭SaveAs‬ ‭Ctrl+Shift+S‬

‭6.എഡിറ്റിംഗിനുള്ള മുന്നൊരുക്കങ്ങൾ :‬
‭6.A. നാവിഗേഷൻ :‬‭നാവിഗേഷൻ ഡോക്യുമെന്റിൽ കഴ്‌സറിനെ ഒരു‬‭പോയിന്റിൽ നിന്ന് മറ്റൊന്നിലേക്ക് മാറ്റുന്നു.‬

‭ചോദ്യം : നാവിഗേഷനായി ഉപയോഗിക്കുന്ന കീകൾ എന്തൊക്കെയാണ്.‬
‭●‬ ‭ആരോ കീകൾ :‬‭അടുത്ത പൊസിഷനിലേക്ക് കഴ്‌സർ നീക്കാൻ.‬
‭●‬ ‭ഹോം കീ :‬‭ഇപ്പോൾ നിൽക്കുന്ന ലൈനിന്റെ ആരംഭത്തിലേക്കു‬‭കഴ്സർ നീക്കാൻ.‬
‭●‬ ‭എൻഡ് കീ:‬‭ഇപ്പോൾ നിൽക്കുന്ന ലൈനിന്റെ അവസാന ഭാഗത്തേക്ക്‬‭കഴ്സർ നീക്കാൻ.‬
‭●‬ ‭പേജ് അപ്പ് :‬‭ഇപ്പോൾ നിൽക്കുന്ന സ്ഥാനത്തു നിന്നും ഒരു‬‭പേജ് മുകളിലേക്ക് മാറി കേഴ്‌സറിനെ നിർത്തുന്നു.‬

‭●‬ ‭പേജ് ഡൌൺ :‬‭ഇപ്പോൾ നിൽക്കുന്ന സ്ഥാനത്തു നിന്നും ഒരു‬‭പേജ് താഴേക്ക് മാറി കേഴ്‌സറിനെ നിർത്തുന്നു.‬

‭●‬ ‭Ctrl+ → :‬‭അടുത്ത വാക്കിന്റെ ആരംഭത്തിലേക്ക് കേഴ്‌സറിനെ‬‭എത്തിക്കുന്നു.‬
‭●‬ ‭Ctrl+ ← :‬‭തൊട്ട് മുന്നത്തെ വാക്കിന്റെ ആരംഭത്തിലേക്ക്‬‭കേഴ്‌സറിനെ എത്തിക്കുന്നു.‬
‭●‬ ‭Ctrl + Home :‬‭ഡോക്യൂമെന്റിന്റെ ആരംഭത്തിലേക്ക് കേഴ്‌സറിനെ‬‭എത്തിക്കുന്നു.‬
‭●‬ ‭Ctrl+End :‬‭ഡോക്യൂമെന്റിന്റെ ഏറ്റവും അവസാന ഭാഗത്തേക്ക്‬‭കേഴ്‌സറിനെ എത്തിക്കുന്നു.‬

‭6.B.ഇൻസേർട്/ഓവർറൈറ്റ് മോഡ്‬‭സെറ്റിങ് :‬‭പുതിയ കാരക്ടർ‬‭നിലവിലുള്ളതിനു പകരമായി വരുന്നു.‬
‭6.C.അൺഡു ( Ctrl+Z) & റീഡു (Ctrl+Y) ആക്ഷൻസ് :‬

‭Undo‬‭: അവസാനം ചെയ്ത പ്രവർത്തനം റദ്ദാക്കാനോ‬‭റിവേഴ്സ് ചെയ്യാനോ അനുവദിക്കുന്നു.‬
‭Redo‬‭: ഒഴിവാക്കിയ പ്രവർത്തനത്തെ വീണ്ടും പുനഃസ്ഥാപിക്കാൻ.‬

‭6.D. ടെക്സ്റ്റ് സെലെക്ഷൻ:‬‭ഡോക്യൂമെന്റിലെ വാക്കിനെയോ,‬‭പൂർണമായോ സെലക്ട് ചെയ്യാൻ‬
‭ഉപയോഗിക്കുന്നു. ( Select All -> Ctrl+A )‬
‭7. കട്ട്,കോപ്പി ,പേസ്റ്റ്  ( Cut,Copy,Paste ) ഫംഗ്‌ഷനുകൾ താരതമ്യം ചെയ്യുക‬

‭കട്ട്-പേസ്റ്റ് ( Cut-Paste )‬ ‭കോപ്പി-പേസ്റ്റ് ( Copy Paste )‬

‭ടെക്‌സ്‌റ്റ് ഡ്യൂപ്ലിക്കേറ്റ് ചെയ്യുന്നില്ല‬ ‭ടെക്‌സ്‌റ്റ് ഡ്യൂപ്ലിക്കേറ്റ് ചെയ്യുന്നു.‬

‭ടെക്‌സ്‌റ്റ് ഡെസ്റ്റിനേഷനിൽ മാത്രം കാണുന്നു.‬ ‭ടെക്‌സ്‌റ്റ് സോഴ്സിലും ഡെസ്റ്റിനേഷനിലും കാണുന്നു.‬

‭ടെക്സ്റ്റിനെ ഒരു സ്ഥലത്തുനിന്നും മറ്റൊരു‬
‭സ്ഥലത്തേക്ക് നീക്കുന്നു.‬

‭ടെക്സ്റ്റിന്റെ കോപ്പി മറ്റൊരു സ്ഥലത്തു എത്തിക്കുന്നു.‬

‭8.ഫൈൻഡിങ് & റീപ്ലേസിങ് ടെക്സ്റ്റ്‬
‭ചോദ്യം :‬‭രാജു തന്റെ ഡോക്യൂമെന്റിൽ ടൈപ്പ് ചെയ്തിട്ടുള്ള‬‭‘മലയാളം’ എന്ന വാക്കിന്റെ എല്ലാ ആവർത്തനങ്ങളും‬
‭അക്ഷരങ്ങളുടെ ടൈപ്പ് പരിഗണിക്കാതെ ‘ഹിന്ദി’ എന്ന് ലിബ്രെ ഓഫീസ് ഉപയോഗിച്ച് മാറ്റുന്നതെങ്ങനെ?‬

‭ഉത്തരം :‬ ‭Step1  :   Edit -> Find & Replace or Ctrl‬‭+ h ൽ ക്ലിക്ക് ചെയ്യുക‬
‭Step 2 :‬‭തുറന്നു വരുന്ന വിൻഡോയുടെ Find എന്നതിന് നേരെ‬‭മാറ്റേണ്ട വാക്ക് ('മലയാളം') ടൈപ്പ് ചെയ്യുക.  ഈ വിൻഡോയിൽ‬
‭തന്നെയുള്ള Replace എന്നിടത്തു പകരം വെക്കേണ്ട വാക്ക് ('ഹിന്ദി') ടൈപ്പ്  ചെയ്തു ReplaceAll എന്ന ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
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‭9.ഡോക്യുമെന്റ് ഫോർമാറ്റ് ചെയ്യുന്ന വിധം :‬‭ടെക്സ്റ്റിന്റെ പൊതുവായ ക്രമീകരണം ഫോർമാറ്റിംഗ്‬
‭എന്നറിയപ്പെടുന്നു. ഒരു ഡോക്യുമെന്റ് ആകർഷകമാക്കാൻ ചില ഫോർമാറ്റിംഗ് സവിശേഷതകൾ പ്രയോഗിക്കുന്നു.‬

‭9.1 കാരക്ടർ ഫോർമാറ്റിങ് :‬‭ഡോക്യൂമെന്റിലെ അക്ഷരങ്ങൾ എപ്രകാരം കാണണമെന്ന് ഇത്‬
‭തീരുമാനിക്കുന്നു.‬ ‭Format -> Character.‬
‭റൈറ്ററിലെ ക്യാരക്ടർ ഫോർമാറ്റിംഗ് സവിശേഷതകൾ‬
‭ബോൾഡ്,ഇറ്റാലിക്‌,അണ്ടർലൈനിങ്,ഓവർലൈനിങ്,സബ്സ്ക്രിപ്റ്റ്(2‬‭5‬‭),സൂപ്പർസ്ക്രിപ്ട്(2‬‭5‬‭)ഫോണ്ട്,‬
‭ഫോണ്ട് എഫക്ട്,പൊസിഷൻ, ഹൈപ്പർലിങ്ക് ,ബാക്ക്ഗ്രൗണ്ട്,ബോർഡേഴ്സ്‬

‭9.2. പാരഗ്രാഫ് ഫോർമാറ്റിങ്:‬ ‭പാരഗ്രാഫിലെ മുഴുവൻ എഴുത്തുകളും‬‭മനോഹരമാക്കുന്നതിനു‬
‭ഉപയോഗിക്കുന്നു.‬ ‭Format -> Paragraph......‬

‭9.2.1.  പാരഗ്രാഫ് അലൈൻമെന്റ് :‬
‭ഹൊറിസോണ്ടൽ അലൈൻമെന്റ് : അലൈൻ -ലെഫ്റ് ,റൈറ്റ്, സെന്റർ, ജസ്റ്റിഫൈ‬
‭വെർട്ടിക്കൽ അലൈൻമെന്റ്  : ടോപ്,ബോട്ടം, മിഡിൽ .‬

‭9.2.2. പാരഗ്രാഫ് ഇൻഡെന്റെഷൻ & ലൈൻ സ്പേസിങ് :‬
‭പേജ് അതിരുകളും ടെക്സ്റ്റ് മാർജിനും തമ്മിലുള്ള അകലം ആണ് ഇത്.‬

‭പാരഗ്രാഫ് ഇൻഡെന്റെഷൻ 4 തരം :‬
‭പോസിറ്റീവ് ഇൻഡന്റ് :‬‭മാർജിനിൽ നിന്ന് അല്പം അകത്തേക്ക്‬‭മാറി ടെക്സ്റ്റിനെ ക്രമീകരിക്കുന്നു.‬
‭നെഗറ്റീവ് ഇൻഡന്റ്  :‬‭മാർജിനിൽ നിന്ന് പുറത്തേക്ക്‬‭തള്ളി നിൽക്കുന്ന രീതിയിൽ ടെക്സ്റ്റിനെ ക്രമീകരിക്കുന്നു.‬

‭ഫസ്റ്റ് ലൈൻ ഇൻഡന്റ് :‬‭സെലക്ട് ചെയ്ത പാരഗ്രാഫിന്റെ‬‭ആദ്യ ലൈൻ മറ്റു ലൈനുകളെക്കാൾ‬
‭അല്പം  അകത്തേക്ക് മാറ്റി ക്രമീകരിക്കുന്നു.‬

‭ഹാങ്ങിങ് ഇൻഡന്റ് :‬‭സെലക്ട് ചെയ്ത പാരഗ്രാഫിലെ,‬‭ആദ്യ ലൈനിൽ നിന്ന് വ്യത്യസ്തമായി  മറ്റു‬
‭ലൈനുകൾ ഇടതു മാർജിനിൽ നിന്ന് അല്പം വലത്തേക്ക് മാറി ക്രമീകരിക്കുന്നതിന് ഉപയോഗിക്കുന്നു.‬
‭ലൈൻ സ്പേസിങ് :‬‭ഒരു പാരഗ്രാഫിലെ ലൈനുകൾ തമ്മിലുള്ള‬‭അകലമാണിത്.‬
‭*****9.2.3. ഡ്രോപ്പ് ക്യാപ്സ് ഫീച്ചർ ( Drop Caps feature )‬
‭ആദ്യ പാരഗ്രാഫിലെ ആദ്യ അക്ഷരം, രണ്ടോ അതിലധികമോ വരികളുടെ ഉയരം എടുത്തേക്കാം.‬
‭Step 1 : പാരഗ്രാഫിൽ കഴ്സർ സ്ഥാപിക്കുക‬
‭Step 2 :പാരഗ്രാഫ്  ഡയലോഗ് ബോക്സ് തുറന്ന് ഡ്രോപ്പ് ക്യാപ്സ് ടാബ് തിരഞ്ഞെടുക്കുക.‬
‭Step 3 :‬‭ഡ്രോപ്പ് ക്യാപ്സ് ചെയ്യേണ്ട അക്ഷരങ്ങളുടെ എണ്ണവും,സ്പാൻ‬‭ചെയ്യേണ്ട വരികളുടെ എണ്ണവും വ്യക്തമാക്കുക.‬

‭Step 4 :Ok ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
‭9.2.4.ബുള്ളറ്റ്‌സ് & നമ്പറിങ്‬
‭Steps 1: Formats Bullets and Numbering.....ൽ Click ചെയ്യുക.‬
‭Step 2: വരുന്ന ഡയലോഗ് ബോക്സിൽ ഇന്നും ആവശ്യമുള്ള ബുള്ളറ്റ്/നമ്പറിങ് സെലക്ട് ചെയ്യുക.‬
‭Step 3: Ok Click ചെയ്യുക.‬
‭Step 4: ഇനി ഡോക്യൂമെന്റൽ ടൈപ്പ് ചെയ്തു എന്റർ ചെയ്യുമ്പോൾ ബുള്ളറ്റ്/നമ്പർ പ്രത്യക്ഷപ്പെടും.‬

‭9.3 പേജ് ഫോർമാറ്റിംഗ്‌ :‬‭പേജ് ലേഔട്ട്, ഡിസൈൻ എന്നിവയാണ്‬‭ഉൾപ്പെടുത്തിയിരിക്കുന്നത്.‬
‭Format ->Page .   A3,A4,ലെറ്റർ,ലീഗൽ, തുടങ്ങിയ വലിപ്പമുള്ള പേജുകൾ സെറ്റ് ചെയ്യാം.‬

‭*ഹെഡർ,ഫൂട്ടർ ഉൾപെടുത്തുവാനുള്ള പ്രവർത്തനം :‬
‭Header:    Insert -> Header, Format-> Page->Header->Apply->OK‬
‭Footer:    Insert -> Footer, Format-> Page->Header->Apply->OK‬
‭**ഒരു ഡോക്യൂമെന്റിന്റെ ഫൂട്ടറിൽ പേജ് നമ്പർ ആഡ് ചെയ്യുന്ന വിധം : Insert ->Field ->Page Number‬

‭10. ഡോക്യുമെന്റ് പ്രിന്റിങ് :‬‭തയ്യാറാക്കിയ ഡോക്യൂമെന്റിനെ‬‭പേപ്പറിലേക്ക് പകർത്തുന്നതാണ് പ്രിന്റിങ്.‬
‭File->Print അല്ലെങ്കിൽ Ctrl+P ഉപയോഗിക്കുന്നു.‬
‭പ്രിന്റ് പ്രിവ്യു :‬‭ഡോക്യുമെന്റ് പ്രിന്റ് ചെയ്യുന്നതിന്‬‭മുന്നേ പേജുകൾ എങ്ങനെയിരിമെന്ന്കാണുവാൻ‬
‭സാധിക്കും.        File -> Print Preview  അല്ലെങ്കിൽ Ctrl+Shift+O‬
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‭XII  - CHAPTER - 3‬

‭Creating Professional Documents‬

‭1.ടേബിളുകൾ‬‭:വരികളുടെയും നിരകളുടെയും രൂപത്തിലുള്ള ഡാറ്റയുടെ ക്രമീകരണമാണ് ടേബിൾ.‬
‭1.1 ടേബിൾ സൃഷ്ടിക്കാൻ 3 വഴികളുണ്ട്    Inserting tables‬

‭Step 1:  Menu bar -> Insert -> Table or സ്റ്റാൻഡേർഡ് ടൂൾബാറിലെ ടേബിൾ ഐക്കണിൽ ക്ലിക്ക്‬
‭ചെയ്യുക.  അല്ലെങ്കിൽ‬ ‭Ctrl+F12‬‭പ്രെസ്സ്‬‭ചെയ്യുക.‬

‭Step 2:  അപ്പോൾ ദൃശ്യമാകുന്ന ഡയലോഗ് ബോക്സിൽ ടേബിളിന്റെ പേരും,വരിയുടെയും‬
‭നിരയുടെയും  എണ്ണം  കൊടുക്കുക. OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬

‭1.1.1. ടേബിളിലേക്ക് ബോർഡർ പ്രയോഗിക്കുന്ന വിധം‬‭Applying borders to tables‬
‭Step 1:   ടേബിൾ -> ടേബിൾ പ്രോപ്പർട്ടീസ് -> ടേബിൾ ഫോർമാറ്റ് ഡയലോഗ് ബോക്സ്‬
‭Step 2 :  സെറ്റ്  - ബോർഡർ, ലൈൻ ശൈലി, വീതി, നിറം‬

‭1.2മാനേജിങ് ടേബിൾ  Managing Tables‬
‭1.2.1 നിരയുടെയും വരിയുടെയും വീതി മാറ്റാൻ( Changing‬‭column width or row height ):‬

‭വരിയുടെയും നിരയുടെയും വശങ്ങളിൽ മൗസ് ഉപയോഗിച്ച് ക്ലിക്ക് ചെയ്ത് വലിച്ചിടുക.‬
‭1.2.2 പുതിയ നിരയും വരിയും ഉൾപെടുത്താൻ ( Inserting‬‭new rows /columns ) :‬

‭പുതിയ വരി‬‭-‬‭Table-> Insert -> Rows  |||||‬ ‭പുതിയ‬‭നിര‬‭-‬‭Table -> Insert -> Columns‬
‭1..2.3. വരിയും നിരയും ഒഴിവാക്കാൻ ( Deleting ) :‬‭Table -> Delete -> Rows/Columns‬
‭1.2.4. വരിയും നിരയും ഒരുമിപ്പിക്കാൻ ( Merging‬‭):‬‭തിരഞ്ഞെടുത്ത സെല്ലുകളെ  സംയോജിപ്പിക്കുന്നതിനെ‬

‭മെർജിങ് വിളിക്കുന്നു.‬ ‭Table -> Merge‬‭cells or (Right click on the cell, Cell -> Merge)‬
‭1.2.5. വരികൾ/നിരകൾ വിഭജിക്കുന്നു(Splitting) :‬‭Table‬‭-> Split Cells or (right click in the cell, Cell -> Split)‬

‭സ്പ്ലിറ്റ് സെൽ ഡയലോഗ് ബോക്സിൽ vertical or Horizontal തിരഞ്ഞെടുക്കുക‬
‭2.ഗ്രാഫിക്സ് ഉൾപ്പെടുത്തുന്ന 3 വിധം‬

‭2.1 ഒരു ചിത്രം ചേർക്കുന്നു :‬‭Step  : Insert -> Image‬‭-> From file. / OR   Use  standard ToolBar ലെ Image icon‬

‭2.2. ഡ്രോയിംഗ് ടൂളുകൾ ചേർക്കുന്നു‬
‭ലൈൻ ടൂൾ‬‭:‬‭നേർരേഖകൾ വരയ്ക്കാൻ‬
‭Rectangle and Ellipse‬ ‭:‬‭ദീർഘചതുരങ്ങൾ , Ellipse വരയ്ക്കാൻ‬
‭ഫ്രീ ഫോം ടൂൾ ( ഫ്രീഹാൻഡ്‌ ടൂൾ  ):‬‭നമ്മുടെ ഇഷ്ടത്തിനനുസരിച്ചു‬‭സ്വതന്ത്രമായി ഏത് രൂപവും‬

‭വരയ്ക്കുന്നതിനു ഉപയോഗിക്കുന്നു.‬
‭ടെക്സ്റ്റ് ടൂൾ‬‭:‬ ‭ടെക്സ്റ്റ്ബോക്സ് ചേർക്കാൻ‬
‭ഫോണ്ട് വർക്ക് ഗാലറി ടൂൾ‬‭:‬ ‭ടെസ്റ്റുകൾ കലാപരമായി‬‭അവതരിപ്പിക്കുന്നു.‬
‭എക്‌സ്‌ട്രൂഷൻ ഓൺ/ഓഫ്‬‭:‬ ‭തിരഞ്ഞെടുത്ത ഒബ്‌ജക്റ്റിന്‬‭3D ഇഫക്റ്റ് നൽകാൻ‬
‭2.3. ചാർട്ടുകൾ ചേർക്കുന്നു :‬
‭Step 1 :ചാർട്ട് തയ്യാറാക്കേണ്ട ടേബിൾ തിരഞ്ഞെടുക്കുക‬
‭Step 2 : Insert -> Object -> Chart -> Chart Wizard.‬
‭Step 3 : chart type, Data range, Data series and Chart elements‬

‭എന്നിവ തിരഞ്ഞെടുക്കുക.ഫിനിഷ് ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
‭3.പേജ് ബോർഡറുകൾ ഉൾപ്പെടുത്തുന്ന വിധം‬

‭Step 1 : Format -> Page എന്ന് സെലക്ട് ചെയ്യുക.‬
‭Step 2 : അപ്പോൾ കാണുന്ന ഡയലോഗ് ബോക്സിൽ ബോർഡേഴ്സ് ടാബ് സെലക്ട് ചെയ്ത്,‬

‭അതിൽ വരുന്ന Line Arrangement എന്നതിൽ ഇഷ്ടമുള്ള ബോർഡർ സെലക്ട് ചെയ്യാം.‬
‭Step 3 : ലൈനിന്റെ സ്റ്റൈൽ, കളർ, വിഡ്ത് എന്നിവ മാറ്റുവാനും സാധിക്കും.‬
‭Step 4 : OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
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‭***4.വാട്ടർമാർക്  ഉൾപ്പെടുത്തുന്ന വിധം‬‭:‬‭ഡോക്യൂമെന്റിന്റെ ബാക്ക്ഗ്രൗണ്ടിൽ കാണുന്ന വാചകത്തെ‬
‭വാട്ടർമാർക്ക് എന്ന് വിളിക്കുന്നു.ഡോക്യൂമെന്റിനെ pdf ആയി എക്സ്പോർട്ട് ചെയ്യുന്ന സമയത്തു മാത്രമേ‬
‭വാട്ടർമാർക് ഉൾപെടുത്താൻ സാധിക്കു.‬
‭Step 1 : pdf ആയി മാറ്റേണ്ട ഡോക്യുമെന്റ് ഫയൽ ഓപ്പൺ ചെയ്യുക.‬
‭Step 2: File - > Export as PDF സെലക്ട് ചെയ്യുക.‬
‭Step 3: ആവശ്യമുള്ള വാട്ടർമാർക് ടൈപ്പ് ചെയ്യുക.‬
‭Step4 : Export എന്ന ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
‭Step 5 : വരുന്ന ഡയലോഗ് ബോക്സിൽ ഫയലിന്റെ പേര് നൽകി സേവ് ചെയ്യുക.‬
‭***5.ടെക്സ്റ്റിനെ ടേബിൾ ആക്കി മാറ്റുന്ന വിധം   Converting text to table‬
‭Step 1 : ടേബിൾ ആയി മാറ്റേണ്ട ടെസ്റ്റുകൾ സെലക്ട് ചെയ്യുക.‬
‭Step 2:‬ ‭Table -> Convert Text to Table‬‭സെലക്ട് ചെയ്യുക.‬
‭Step 3:  കോളം സെപ്പറേറ്റർ സെലക്ട് ചെയ്യുക.‬
‭Step 4 : Ok ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
‭***6.ടെക്സ്റ്റുകളെ കോളങ്ങളായി വിഭജിക്കുന്ന വിധം    Splitting text into columns‬
‭Step 1 : ഡോക്യൂമെന്റിലെ ടെസ്റ്റുകൾ സെലക്ട് ചെയ്യുക.‬
‭Step 2 : Format -> Columns  സെലക്ട് ചെയ്യുക.‬
‭Step 3: കോളങ്ങളുടെ എണ്ണം, വീതി, അകലം തുടങ്ങിയവ സെറ്റ് ചെയ്യുക.‬
‭Step 4: OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക.‬
‭7.സ്പെല്ലിങ് & ഗ്രാമർ ( Spelling and Grammar )‬
‭മാർഗം 1‬
‭1. സ്റ്റാൻഡേർഡ് ടൂൾ ബാറിൽ ഓട്ടോ സ്പെൽ ചെക്ക് ബട്ടണിൽ ക്ലിക്ക് ചെയ്യുക.‬
‭2. അക്ഷര തെറ്റുള്ള വാക്കുകളുടെ താഴെയായി ചുരുണ്ട വരകൾ കളർ മാറി കാണപ്പെടും.‬
‭3.‬‭തെറ്റുള്ള വാക്കുകളുടെ മുകളിൽ മൗസിന്റെ റൈറ്റ് ബട്ടൺ‬‭ക്ലിക്ക് ചെയ്ത് ശരിയായ വാക്ക് സെലക്ട് ചെയ്യുക.‬

‭മാർഗം 2‬
‭1. Tools -> Spelling and Grammar എന്ന മെനു ഓപ്ഷൻ സെലക്ട് ചെയ്യുക‬
‭2.സ്പെല്ലിങ് ഡയലോഗ് ബോക്സ് ഉപയോഗിച്ച് സ്പെല്ലിങ് മിസ്റ്റേക്കുള്ള വാക്കിന് പകരം ശരിയായ‬
‭വാക്കിനെ സെലക്ട് ചെയ്യാം.‬
‭** Auto Correct :‬‭സ്പെല്ലിങ് തെറ്റിയ ഓരോ വക്കും ടൈപ്പ്‬‭ചെയ്ത ഉടനെ ശരിയാക്കുന്നതിന് ഉള്ള സൗകര്യം.‬

‭***8.ഡിഫൈനിംഗ് ടേബിൾ ഓഫ് കോൺടെന്റ്     Defining table of contents ( TOC )‬
‭ഒരു ഡോക്യൂമെന്റിന്റെ അല്ലെങ്കിൽ ഒരു ബുക്കിന്റെ പ്രധാനപ്പെട്ട ഉള്ളടക്കത്തെപറ്റി സൂചന നൽകുന്നതിനാണ് TOC‬
‭ഉപയോഗിക്കുന്നത്. ഡോക്യൂമെന്റിലെ പ്രധാനപ്പെട്ട ഹെഡിങ്ങുകൾ, സബ് ഹെഡിങ്ങുകൾ അവയുടെ പേജ്‬
‭നമ്പറുകൾ എന്നിവ ഇതിൽ ദൃശ്യമാകും.‬
‭Step 1:‬‭TOC എൻട്രി നിർമിക്കുന്നു‬

‭1.‬ ‭ഡോക്യുമെന്റ് തുറക്കുന്നു.‬
‭2.‬ ‭Insert -> Indexes and Tables ->  Index entry സെലക്ട് ചെയ്യുക‬
‭3.‬ ‭ഇൻഡക്സ് എന്ന ബോക്സിൽ,‬‭ടേബിൾ ഓഫ് കോൺടെന്റ്‬‭സെലക്ട്‬‭ചെയ്യുക‬
‭4.‬ ‭entry എന്ന ബോക്സിൽ ഹെഡിങ്ങും, സബ് ഹെഡിങ്ങും ഉൾപെടുത്തുക‬
‭5.‬ ‭ഓരോ entryക്ക് ശേഷം അതിന്റെ ലെവൽ കൊടുത്ത് insert ക്ലിക്ക് ചെയ്യുക.‬

‭Step 2:‬‭TOC പേജുകൾ നിർമിക്കുന്നു‬
‭1.‬ ‭TOC നിർമിക്കേണ്ട ഡോക്യുമെന്റ് പേജിൽ ക്ലിക്ക് ചെയ്യുക.‬
‭2.‬ ‭Insert -> Indexes and Tables ->  Indexes and Tables സെലക്ട് ചെയ്യുക.‬
‭3.‬ ‭Index / Tableഎന്ന ടാബിൽ ക്ലിക്ക് ചെയ്യുക.‬
‭4.‬ ‭ടൈപ്പ് ബോക്സിൽ‬‭ടേബിൾ ഓഫ് കോൺടെന്റ്‬‭എന്ന് സെലക്ട് ചെയ്യുക‬
‭5.‬ ‭OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക‬
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‭9. ഡിഫൈനിംഗ്  ഇൻഡക്സ് എൻട്രി Defining index entries :‬‭ബുക്കുകളുടെയും മറ്റും അവസാന‬
‭ഭാഗത്തെ പേജിൽ ബുക്കിലുപയോഗിച്ച പ്രത്യേക വാക്കുകൾ അക്ഷരമാല ക്രമത്തിൽ പേജ് നമ്പറുകൾ‬
‭സഹിതം ഉൾപ്പെടുത്തിയിരിക്കുന്നു.ഇത്തരം പേജുകളാണ് ഇൻഡക്സ്.‬
‭Step 1:‬‭Index എൻട്രി നിർമിക്കുന്നു‬

‭1.‬ ‭ഡോക്യുമെന്റ് തുറക്കുന്നു.‬
‭2.‬ ‭Insert -> Indexes and Tables ->  Index entry സെലക്ട് ചെയ്യുക‬
‭3.‬ ‭Index എന്ന ബോക്സിൽ,‬‭അൽഫബെറ്റിക്കൽ ഇൻഡക്സ്‬‭സെലക്ട്‬‭ചെയ്യുക.‬
‭4.‬ ‭entry‬‭എന്ന ബോക്സിൽ ഇൻഡക്സിൽ ഉൾപ്പെടുത്തേണ്ട വാക്കുകൾ‬‭ഓരോന്നായി ഉൾപെടുത്തുക‬

‭5.‬ ‭ഓരോ entryക്ക് ശേഷം insert ക്ലിക്ക് ചെയ്യുക.‬
‭Step 2:‬‭Index പേജുകൾ നിർമിക്കുന്നു‬

‭1.‬ ‭Index നിർമിക്കേണ്ട ഡോക്യുമെന്റ് പേജിൽ ക്ലിക്ക് ചെയ്യുക‬
‭2.‬ ‭Insert -> Indexes and Tables ->  Indexes and Tables സെലക്ട് ചെയ്യുക.‬
‭3.‬ ‭Index / Tableഎന്ന ടാബിൽ ക്ലിക്ക് ചെയ്യുക.‬
‭4.‬ ‭ടൈപ്പ് ബോക്സിൽ‬‭അൽഫബെറ്റിക്കൽ ഇൻഡക്സ്‬‭എന്ന് സെലക്ട്‬‭ചെയ്യുക‬
‭5.‬ ‭OK ബട്ടൺ ക്ലിക്ക് ചെയ്യുക‬

‭10.ടെംപ്ലേറ്റ്സ്  ( Concept of templates ) :‬‭മുൻകൂട്ടി‬‭നിർവചിച്ച ഡോക്യുമെന്റ് ഫോർമാറ്റ്.‬
‭Step 1 : File -> New ->  Templates‬
‭Step 2: ടെംപ്ലേറ്റ് മാനേജർ ഡയലോഗ് ബോക്സ് ദൃശ്യമാകുന്നു.‬
‭Step 3 : വേണ്ട ടെംപ്ലേറ്റ് ക്ലിക്ക് ചെയ്യുക‬

‭*****11.മെയിൽ മെർജ്‬ ‭Mail merge‬

‭ഒരു പ്രധാന ഡോക്യൂമെന്റിനെ ഒരു കൂട്ടം ഡാറ്റയുമായോ ഡാറ്റാ സ്രോതസ്സുകളുമായോ ലിങ്ക്‬
‭ചെയ്തുകൊണ്ട് കത്തുകളും, മെയിലിംഗ് ലേബലുകളും എൻവലപ്പുകളും സൃഷ്ടിക്കാൻ മെയിൽ‬
‭മെർജ് ഉപയോഗിക്കുന്നു.‬

‭മെയിൽ മെർജ് പ്രോസസ്സിന്റെ സ്റ്റെപ്പുകൾ‬

‭Step 1 :Select starting document    /  ആരംഭിക്കുന്ന ഡോക്യുമെന്റ് തിരഞ്ഞെടുക്കുക‬
‭Step 2: Select document type        /   ഡോക്യുമെന്റ് ടൈപ്പ് തിരഞ്ഞെടുക്കുക‬
‭Step 3: Insert address book          /    അഡ്രസ് ബുക്ക് ചേർക്കുക‬
‭Step 4 :Create salutation‬ ‭/     സല്യൂട്ടഷൻ തയ്യാറാക്കുക‬
‭Step 5: Adjust layout‬ ‭/      ലേഔട്ട് ക്രമീകരിക്കുക‬
‭Step 6 : Edit documents‬ ‭/       ഡോക്യുമെന്റ്കൾ എഡിറ്റ് ചെയ്യുക‬
‭Step 7: Personalize documents /‬ ‭ഡോക്യുമെന്റ്കൾ വ്യക്തിഗതമാക്കുക‬
‭Step 8: Save, print or send‬ ‭/        സേവ്, പ്രിന്റ് ചെയ്യുക അല്ലെങ്കിൽ അയയ്ക്കുക‬
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‭XII  - CHAPTER - 4‬
‭WEB TECHNOLOGY‬

‭1. വെബ് സൈറ്റ് :‬ ‭വെബ് പേജുകളുടെ കൂട്ടമാണ് വെബ് സൈറ്റ്.‬
‭HTML കോഡുകൾ ഉപയോഗിച്ച് വെബ് പേജുകൾ നിർമിക്കുന്നു.‬
‭➤ www -‬‭വേൾഡ് വൈഡ് വെബ്‬ ‭➤HTML -‬ ‭ഹൈപ്പർ ടെക്സ്റ്റ്‬‭മാർക്ക് അപ്പ് ലാംഗ്വേജ്‬

‭2. വെബിലൂടെയുള്ള ആശയവിനിമയം‬
‭വെബിലൂടെയുള്ള ആശയവിനിമയം‬‭2  തരം :‬
‭(i) ക്ലയന്റ് (യൂസർ /ബ്രൗസർ) നിന്നും വെബ് സെർവറിലേക്കുള്ള  ആശയവിനിമയം: യൂസറിന്റെ അവശ്യ‬

‭- പ്രകാരം വെബ് സെർവർ വെബ് പേജുകൾ നൽകുന്നു.‬
‭(ii) വെബ് സെർവറിൽ നിന്നും വെബ് സെർവറിലേക്കുള്ള  ആശയവിനിമയം:രണ്ടു വെബ് സെർവറുകൾ‬

‭- തമ്മിൽ ഇന്റർനെറ്റിലൂടെയുള്ള സന്ദേശ കൈമാറ്റം.‬
‭** Payment Gateway ( പേയ്‌മെന്റ് ഗേറ്റ് വേ ) :‬‭വ്യാപാരികളുടെ‬‭സെർവറും ബാങ്ക് സെർവറും തമ്മിൽ‬
‭ഓൺലൈൻ പണമിടപാട് നടത്തുവാൻ സഹായിക്കുന്നു.‬

‭*3.വെബ് സെർവർ ( Web Server )‬
‭വെബ്‌ സൈറ്റുകൾ പ്രവർത്തിപ്പിക്കുന്ന കമ്പ്യൂട്ടറാണ് വെബ് സെർവർ. വെബ് പേജുകൾ‬
‭സംഭരിക്കുകയും, പ്രോസസ്സ് ചെയ്യുകയും, ഉപയോക്താക്കൾക്ക് ആവശ്യപ്പെടുമ്പോൾ കൈമാറുകയും‬
‭ചെയ്യുക എന്നതാണ് വെബ് സെർവറിന്റെ അടിസ്ഥാന ലക്ഷ്യം. ഹൈപ്പർടെക്സ്റ്റ് ട്രാൻസ്ഫർ‬
‭പ്രോട്ടോക്കോൾ (HTTP+Port 80) ഉപയോഗിച്ചാണ് ഈ ആശയവിനിമയം നടത്തുന്നു.‬

‭4.‬‭സോഫ്റ്റ്‌വെയർ പോർട്ടിന്റെ ഉപയോഗം‬

‭ഇത് ഒരു ലോജിക്കൽ കണക്ഷനാണ്. ഒരു വെബ് സെർവറിന്റെ ഏതു തരം സർവീസ് (വെബ്‌പേജ്, FTP ,‬
‭ഇമെയിൽ) ഉപയോഗിക്കണമെന്ന് പോർട്ട് നമ്പറുകൾ ഉപയോഗിച്ചു കൃത്യമായി നിർണയിക്കുന്നു.ഒരു‬
‭പോർട്ട് IP Addressമായി ബന്ധപ്പെട്ടിരിക്കുന്നു. ഉദാ: 215.114.85.17‬‭:80‬

‭*4.1 പോർട്ട് നമ്പറുകളും അവയുടെ ഉപയോഗങ്ങളും‬

‭Port Number‬ ‭Service‬

‭53‬ ‭***Domain Name System(DNS)service‬

‭80‬ ‭***HyperText Transfer Protocol(HTTP)‬

‭443‬ ‭***HyperText Transfer Protocol Secure(HTTPS)‬

‭20 &21‬ ‭File Transfer Protocol (FTP )‬

‭22‬ ‭Secure Shell (SSH)‬

‭25‬ ‭Simple Mail Transfer Protocol (SMTP)‬

‭110‬ ‭Post Office Protocol(POP3)‬
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‭*****5 സ്റ്റാറ്റിക് & ഡൈനാമിക് വെബ് പേജുകൾ‬

‭സ്റ്റാറ്റിക് വെബ് പേജുകൾ‬ ‭ഡൈനാമിക് വെബ് പേജുകൾ‬

‭വെബ് പേജിന്റെ ഉള്ളടക്കവും ലേഔട്ടും‬
‭സ്ഥിരമായിരിക്കും.‬

‭ഉള്ളടക്കവും ലേഔട്ടും മാറിക്കൊണ്ടിരിക്കും‬

‭ഡാറ്റാബേസ് ഉപയോഗിക്കുന്നില്ല.‬ ‭ഡാറ്റാബേസ് ഉപയോഗിക്കുന്നു.‬

‭വെബ് പേജുകൾ ബ്രൗസറിൽ നേരിട്ട്‬
‭പ്രവർത്തിക്കുന്നു‬

‭വെബ് പേജുകൾ സെർവറിൽ പ്രവൃത്തിച്ചതിനു ശേഷം
‭ഫലം ബ്രൗസറിൽ പ്രദർശിപ്പിക്കുന്നു.‬

‭വെബ് പേജുകൾ വികസിപ്പിക്കാൻ എളുപ്പമാണ്‬ ‭വെബ് പേജുകൾ വികസിപ്പിക്കാൻ പ്രയാസമാണ്.‬

‭6. സ്ക്രിപ്റ്റുകൾ :‬‭HTML പേജുകൾക്കുള്ളിൽ എഴുതിയിരിക്കുന്ന‬‭പ്രോഗ്രാം കോഡുകളാണ്‬
‭സ്ക്രിപ്റ്റുകൾ.         ടാഗ് : < SCRIPT > ,   ആട്രിബ്യുട്ട് : Type, Src‬

‭6.1 രണ്ട് തരം സ്ക്രിപ്റ്റിംഗ് ഭാഷകൾ‬
‭6.1.1.‬‭ക്ലയന്റ് സൈഡ് സ്ക്രിപ്റ്റിംഗ്‬ ‭- JavaScript‬‭,VB Script‬

‭AJAX :‬ ‭Asynchronous JavaScript and Extensible‬‭Markup Language‬
‭ഒരു വെബ് പേജിന്റെ  മുഴുവൻ ഭാഗങ്ങൾ ലോഡ് ചെയ്യാതെ തന്നെ സ്ക്രീനിനു‬
‭അനുയോജ്യമായ രീതിയിൽ വെബ് പേജിനെ പ്രദർശിപ്പിക്കാൻ കഴിയും.‬
‭6.1.2.‬‭സെർവർ സൈഡ് സ്ക്രിപ്റ്റിംഗ് -‬ ‭PHP‬‭- 'PHP‬‭:Hypertext Preprocessor,‬

‭ASP‬‭- Active Server Pages ,‬‭JSP‬ ‭- Java‬‭Server Pages‬
‭***6.2ക്ലയന്റ് സൈഡ് സ്ക്രിപ്റ്റിംഗും സെർവർ സൈഡ് സ്ക്രിപ്റ്റിംഗും താരതമ്യം ചെയ്യുക‬

‭ക്ലയന്റ് സൈഡ് സ്ക്രിപ്റ്റിംഗ്‬ ‭സെർവർ സൈഡ് സ്ക്രിപ്റ്റിംഗ്‬

‭ഇത് ഉപയോക്താവിന്റെ കമ്പ്യൂട്ടറിൽ‬
‭പ്രവർത്തിക്കുന്നു.‬

‭ഇത് വെബ് സെർവറിൽ പ്രവർത്തിക്കുന്നു.‬

‭ക്ലയന്റ് ബ്രൗസറിൽ സ്ക്രിപ്റ്റ് എക്സിക്യൂട്ട്‬
‭ചെയ്യുന്നു‬

‭വെബ് സെർവറിൽ സ്ക്രിപ്റ്റ് എക്സിക്യൂട്ട് ചെയ്യുന്നു‬
‭ശേഷം വെബ് പേജ് ബ്രൗസറിൽ പ്രദർശിപ്പിക്കുന്നു‬

‭വെബ് ബ്രൗസറിൽ ക്ലയന്റ് നൽകുന്ന ഡാറ്റയുടെ‬
‭മൂല്യനിർണ്ണയത്തിനായി ഉപയോഗിക്കുന്നു‬

‭യൂസർ റിക്വസ്റ്റ് പ്രകാരം ബന്ധപ്പെട്ട‬
‭ഡാറ്റാബേസിലേക്ക് ആക്സസ് നൽകുക.‬

‭***7. HTML കോഡിന്റെ ഘടന Structure of HTML code‬
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‭***8. കണ്ടെയ്നർ ടാഗ് & എംപ്റ്റി ടാഗ്  Container tags and empty tags‬

‭കണ്ടെയ്നർ ടാഗ് :‬‭ഓപ്പണിംഗ് ടാഗും ക്ലോസിംഗ് ടാഗും ആവശ്യമുള്ള ടാഗുകളെ കണ്ടെയ്‌നർ ടാഗുകൾ‬
‭എന്ന് വിളിക്കുന്നു.        Eg: <HTML></HTML>, <HEAD></HEAD>, <BODY></BODY>,<P></P> etc.‬
‭എംപ്റ്റി  ടാഗ്  :‬‭ഇതിന് ഓപ്പണിംഗ് ടാഗ് മാത്രമേയുള്ളൂ.‬ ‭Eg: <BR>, <IMG>,<HR>‬

‭***9.ടാഗുകളുടെ ആട്രിബ്യൂട്ടുകൾ‬‭: ഒരു HTML എലമെന്റിന്റെ‬‭സ്വഭാവമോ പ്രദർശനമോ ക്രമീകരിക്കാൻ‬
‭ഉപയോഗിക്കുന്ന മാർക്ക്അപ്പ് ഭാഷയുടെ ഒരു ഭാഗം.‬

‭ടാഗ്‬ ‭ആട്രിബ്യൂട്ടുകൾ ‭ഉപയോഗം‬

‭HTML‬
‭Lang‬ ‭വെബ് പേജിലെ ഭാഷ വ്യക്തമാക്കാൻ‬

‭Dir‬ ‭വെബ് പേജിൽ പ്രദർശിപ്പിക്കേണ്ട വാചകത്തിന്റെ ദിശ‬
‭വ്യക്തമാക്കാൻ‬

‭BODY‬

‭Bgcolor‬ ‭വെബ് പേജിലെ ബോഡിയുടെ പശ്ചാത്തല നിറം‬
‭വ്യക്തമാക്കുന്നു‬

‭Background‬ ‭വെബ് പേജിൽ പശ്ചാത്തലമായി ചിത്രം സജ്ജമാക്കുക.‬

‭Text‬ ‭വെബ് പേജിലെ ടെക്സ്റ്റ്കളുടെ നിറം വ്യക്തമാക്കുന്നു‬

‭Link‬ ‭സന്ദർശിക്കാത്ത ലിങ്കുകളുടെ നിറം‬
‭വ്യക്തമാക്കുന്നു.ഡിഫോൾട്ട് നിറം നീലയാണ്.‬

‭Vlink‬ ‭സന്ദർശിച്ച ലിങ്കിന്റെ നിറം വ്യക്തമാക്കുന്നു.‬
‭ഡിഫോൾട്ട് നിറം പർപ്പിൾ.‬

‭Alink‬ ‭ഇത് സജീവമായ ഹൈപ്പർലിങ്കിന്റെ നിറം.‬
‭ഡിഫോൾട്ട് നിറമാണ് പച്ച‬

‭Leftmargin,‬
‭Topmargin‬

‭ഇത് വെബ്‌പേജിന്റെ ഇടത്,മുകളിലെ മാർജിൻ‬
‭വ്യക്തമാക്കുന്നു‬

‭9.2. ചില പൊതുവായ ടാഗുകൾ‬

‭ടാഗ് &ആട്രിബ്യൂട്ടുകൾ‬ ‭ഉപയോഗം & ആട്രിബ്യുട്ട് values‬

‭ഹെഡിങ് ടാഗുകൾ (Heading ta
‭<H1>,<H2>,<H3>,<H4>,‬
‭<H5>,<H6>‬
‭ആട്രിബ്യൂട്ടുകൾ : Align‬

‭വ്യത്യസ്ത വലുപ്പത്തിലുള്ള തലക്കെട്ടുകൾ സൃഷ്ടിക്കാൻ അ
‭ഉപയോഗിക്കുന്നു. വലിപ്പമുള്ളതു H1ഉം, ഏറ്റവും ചെറിയ‬
‭ഹെഡിങ് H6ഉം ആകുന്നു.‬
‭ആട്രിബ്യുട്ട് values  : left,right,center‬
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‭<P> tag-  പാരഗ്രാഫ് ടാഗ്‬
‭ആട്രിബ്യൂട്ടുകൾ : Align‬

‭പാരഗ്രാഫ് സൃഷ്ടിക്കാൻ ഇത് ഉപയോഗിക്കുന്നു.‬
‭ആട്രിബ്യുട്ട് values  : left,right,center, justify‬

‭<BR> tag - ബ്രേക്ക് ടാഗ്‬ ‭ലൈൻ ബ്രേക്ക് സൃഷ്ടിക്കാൻ ഇത് ഉപയോഗിക്കുന്നു.‬

‭<HR> - ഹൊറിസോണ്ടൽ tag‬
‭ആട്രിബ്യൂട്ടുകൾ :‬
‭Align,Size,Width,Color‬

‭ഒരു തിരശ്ചീന( ഹൊറിസോണ്ടൽ ) രേഖ സൃഷ്ടിക്കാൻ‬
‭ഉപയോഗിക്കുന്നു.‬

‭<CENTER> tag‬ ‭ഒരു വെബ് പേജിലെ വാചകം, ചിത്രം, പട്ടിക മുതലായവ‬
‭മധ്യഭാഗത്തേക്ക് കൊണ്ടുവരുന്നു.‬

‭9.3. ടെക്സ്റ്റ് ഫോർമാറ്റിംഗ് ടാഗുകൾ‬

‭<B> - ബോൾഡ് ടാഗ്  &‬
‭<STRONG> സ്ട്രോങ്ങ് ടാഗ്‬

‭ടെക്സ്റ്റ്നെ ബോൾഡ് ആക്കുന്നു.‬

‭<I> ടാഗ് & <EM> ടാഗ്‬ ‭ടെക്സ്റ്റ്നെ ഇറ്റാലിക്‌ ആക്കുന്നു.‬

‭<U> ടാഗ്‬ ‭ടെസ്റ്റിന് അണ്ടർ ലൈൻ നൽകുന്നു.‬

‭<S> ടാഗ് & <STRIKE>ടാഗ്‬ ‭ടെസ്റ്റിന് സ്ട്രൈക്ക് നൽകുന്നു‬

‭<BIG>ടാഗ് & <SMALL>ടാഗ്‬ ‭ടെക്സ്റ്റിനെ വലുതാക്കുവാനും( BIG ) ചെറുതാക്കുവാനും‬
‭(SMALL)‬

‭<Q> ടാഗ്‬ ‭"ടെക്സ്റ്റ് ഡബിൾ ക്വാട്സ്നുള്ളിൽ കൊടുക്കുവാൻ"‬

‭<PRE> ടാഗ്‬ ‭മറ്റു ഫോർമാറ്റുകൾ ഒന്നും തന്നെ ഇല്ലാതെ വെബ്‬
‭ഡോക്യൂമെന്റിൽ ടൈപ്പ് ചെയ്ത അതെ ഫോർമാറ്റിൽ‬
‭ടെക്സ്റ്റ്നെ ദൃശ്യമാകുന്നു.‬

‭<ADDRESS> ടാഗ്‬ ‭ഒരു ഡോക്യുമെന്റ് നിർമിച്ച വ്യക്തിയുടെ അഡ്രസ്‬
‭നൽകുന്നു.‬

‭<DIV> ടാഗ്‬ ‭വെബ് പേജിൽ പ്രത്യേക ബ്ലോക്കോ സെക്ഷനോ‬
‭നിർവചിക്കുന്നതിന് ഉപയോഗിക്കുന്നു.‬
‭ആട്രിബ്യൂട്ടുകൾ :  Align, Id, Style‬

‭<FONT>  ടാഗ്‬ ‭<FONT> എന്ന ടാഗിനുള്ളിൽ ഉൾപ്പെടുത്തിയിരിക്കുന്ന‬
‭വാചകങ്ങളുടെ വലുപ്പവും ശൈലിയും നിറവും മാറ്റാൻ‬
‭അനുവദിക്കുന്നു.‬
‭ആട്രിബ്യൂട്ടുകൾ : Color, Face, Size‬
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‭9.4.‬‭<MARQUEE> ടാഗ്‬

‭<MARQUEE> ടാഗ്‬

‭വെബ് പേജിൽ ടെക്സ്റ്റുകളും ചിത്രങ്ങളും‬
‭സ്ക്രോൾ ചെയ്യാൻ ഉപയോഗിക്കുന്നു. ഇടത്തേക്ക്,‬
‭വലത്തേക്ക്, താഴേക്ക് അല്ലെങ്കിൽ മുകളിലേക്ക്‬
‭എന്നിങ്ങനെ <MARQUEE> ടാഗിന്റെ  ആട്രിബ്യൂട്ടുകൾക്ക്‬
‭പ്രത്യേക നിർദ്ദേശങ്ങൾ നൽകി സ്ക്രോൾ ചെയ്യിക്കാം.‬

‭ആട്രിബ്യൂട്ടുകൾ‬ ‭ഉപയോഗം & ആട്രിബ്യുട്ട് values‬

‭Direction‬ ‭ഏത് ദിശയിലേക്കാണ് മാർക്യൂ സ്ക്രോൾ‬
‭ചെയ്യേണ്ടതെന്ന് ഇത് വ്യക്തമാക്കുന്നു.‬
‭Value :-‬‭left, right, up or down‬

‭ഉദാഹരണം‬‭Code :‬
‭<MARQUEE  Direction="left">‬
‭Have a nice day < /MARQUEE >‬

‭width‬ ‭മാർക്യൂ ടെക്സ്റ്റിന്റെ വീതി നൽകുന്നു‬
‭ഉദാ:  width="10" or width="20%"‬

‭height‬ ‭മാർക്യൂ ടെക്സ്റ്റിന്റെ നീളം നൽകുന്നു‬
‭ഉദാ:‬‭height‬‭="10" or‬‭height‬‭="20%"‬

‭Behaviour‬ ‭മാർക്യൂ ടെക്സ്റ്റ് ഏതു രീതിയിലാണ്‬
‭ചലിക്കേണ്ടത് എന്ന് നിശ്ചയിക്കുന്നു.‬
‭Value:scroll,slide, alternate.‬

‭scrollamount‬ ‭മാർക്യൂ ടെക്സ്റ്റിന്റെ വേഗത നൽകുന്നു.‬

‭Scrolldelay‬ ‭മാർക്യൂ ടെക്സ്റ്റിന്റെ ചലനത്തിന്റെ‬
‭ഇടയ്ക്കുള്ള സമയ പരിധി നിശ്ചയിക്കുന്നു.‬

‭Loop‬ ‭മാർക്യൂ ടെക്സ്റ്റ്നെ എത്ര തവണ സ്ക്രോൾ‬
‭ചെയ്യണം എന്ന് നിശ്ചയിക്കുന്നു‬

‭Bgcolor‬ ‭മാർക്യൂ ടെക്സ്റ്റിന്റെ പശ്ചാത്തല നിറം‬
‭നൽകുവാൻ‬
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‭9.4.‬‭<IMG> ടാഗ്‬

‭<IMG>‬

‭ഒരു വെബ് പേജിൽ ചിത്രം ചേർക്കാൻ ഉപയോഗിക്കുന്നു.‬
‭ഇതൊരു empty ടാഗ് ആണ്.‬
‭ഉദാഹരണം‬‭Code :‬
‭<‬‭img‬‭src‬‭="banasura.jpg"‬‭alt‬‭="wayanad Dam"‬‭width‬‭="500"‬
‭height‬‭="600">‬

‭ആട്രിബ്യൂട്ടുകൾ ‭ഉപയോഗം & ആട്രിബ്യുട്ട് values‬

‭Src‬ ‭ഒരു വെബ് പേജിൽ ചേർക്കേണ്ട ചിത്രത്തിന്റെ
‭ഫയലിന്റെ ലൊക്കേഷൻ ( പാത്ത് )‬
‭വ്യക്തമാക്കുന്നു.‬

‭Align‬ ‭വെബ് പേജിൽ ചിത്രത്തിന്റെ പൊസിഷൻ‬
‭വ്യക്തമാക്കുന്നു. Value : top ,middle, bottom‬

‭Width‬ ‭ചിത്രത്തിന്റെ വീതി പിക്സലിൽ‬
‭വ്യക്തമാക്കുന്നു.‬

‭Height‬ ‭ചിത്രത്തിന്റെ നീളം പിക്സലിൽ‬
‭വ്യക്തമാക്കുന്നു.‬

‭Alt‬ ‭ബ്രൗസറിന് ചിത്രം പ്രദർശിപ്പിക്കാൻ‬
‭കഴിയുന്നില്ലെങ്കിൽ പ്രദർശിപ്പിക്കേണ്ട‬
‭വാചകം ദൃശ്യമാകുന്നു‬

‭Border‬ ‭ചിത്രത്തിന് ചുറ്റും ബോർഡർ‬
‭സജ്ജീകരിക്കാൻ.‬

‭<SUP>  ടാഗ്സൂപ്പർ സ്ക്രിപ്റ്റ്‬
‭ടെക്സ്റ്റ്‬
‭ടാഗ്‬

‭<sup> എന്നതിനുള്ളിലെ ടെക്‌സ്‌റ്റ്, ചുറ്റുപാടുമുള്ള‬
‭ടെക്‌സ്‌റ്റ്നേക്കാൾ ചെറിയ ഫോണ്ടിൽ മുകളിലായി‬
‭ദൃശ്യമാകുന്നു.‬
‭ഉദാ    :    a‬‭2‬‭+2ab+b‬‭2‬

‭Code :-‬ ‭a<SUP>2</SUP>+2ab+b<SUP>2</SUP>‬

‭<SUB>  ടാഗ്‬
‭സബ് സ്ക്രിപ്റ്റ് ടെക്സ്റ്റ്‬
‭ടാഗ്‬

‭<sub> എന്നതിനുള്ളിലെ ടെക്‌സ്‌റ്റ്, ചുറ്റുപാടുമുള്ള‬
‭ടെക്‌സ്‌റ്റ്നേക്കാൾ ചെറിയ ഫോണ്ടിൽ താഴെയായി‬
‭ദൃശ്യമാകുന്നു.‬
‭ഉദാ    :    H‬‭2‬‭O , H‬‭2‬‭SO‬‭4‬

‭Code :-‬ ‭H<SUB>2</SUB>O‬
‭H<SUB>2</SUB>SO<SUB>4</SUB>‬
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‭10. HTML ലെ റിസേർവ്ഡ് കാരക്ടർസ്‬
‭സ്പെഷ്യൽ കാരക്ടറുകളെ HTML ഡോക്യൂമെന്റിൽ ഡയറക്റ്റ് ഉപയോഗിക്കാൻ സാധിക്കുകയില്ല. ആയത്‬
‭ദൃശ്യമാക്കുവാൻ ചില കോഡുകൾ ഉപയോഗിക്കുന്നു.‬

‭ഉദാഹരണം:A > B‬ ‭എന്ന് html ഡോക്യൂമെന്റിൽ ദൃശ്യമാക്കുന്നതിനായി‬‭A &gt B‬‭എന്ന കോഡ്‬
‭ഉപയോഗിക്കുന്നു.‬

‭Symbol‬ ‭Description‬ ‭Entity Name‬

‭Non-breaking space‬
‭പുതിയ വരിയിലേക്ക് കടക്കാതെ ടെക്സ്റ്റുകൾ തമ്മിൽ
‭സ്പേസ് നൽകുന്നു.‬

‭&nbsp;‬

‭"‬ ‭quotation mark‬ ‭&quot;‬

‭'‬ ‭apostrophe‬ ‭&apos;‬

‭&‬ ‭ampersand‬ ‭&amp;‬

‭<‬ ‭less-than‬ ‭&lt;‬

‭>‬ ‭greater-than‬ ‭&gt;‬

‭©‬ ‭Copyright‬ ‭&copy;‬

‭TM‬ ‭Trade Mark‬ ‭&trade;‬

‭®‬ ‭Registered‬ ‭&reg;‬

‭11. HTML ൽ കമെന്റുകൾ ഉൾപ്പെടുത്തുന്ന വിധം (  Adding comments in HTML document )‬

‭html കോഡ് ഡെവലപ്പ് ചെയ്യുന്ന വ്യക്തികൾക്ക് കോഡ് മനസിലാക്കുവാനും എന്നാൽ ബ്രൗസറിൽ‬
‭പ്രവർത്തിക്കാത്തതും ( ദൃശ്യമാകാത്തതും ) ആയ ഒരു സവിശേഷതയാണ് comment കോഡ്.‬
‭സോഴ്സ് കോഡ് എഡിറ്റ് ചെയ്യുന്ന സമയത് ഇത് സഹായിക്കും.‬
‭കമെന്റുകൾ‬‭<!- -            - ->‬‭ൽ ഉൾപ്പെടുത്തണം.‬

‭ഉദാഹരണം  :‬
‭<!--This is a comment. Comments are not displayed in the browser-->‬
‭<‬‭p‬‭>‬‭This is a paragraph.‬‭<‬‭/p‬‭>‬
‭മുകളിൽ കൊടുത്ത ഉദാഹരണത്തിൽ “‬‭This is a paragraph.”‬‭മാത്രമേ ബ്രൗസറിൽ ദൃശ്യമാകുകയുള്ളു.‬
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‭XII  - CHAPTER - 5‬
‭Web Designing Using HTML‬

‭1. HTML ലെ ലിസ്റ്റുകൾ‬ ‭3ലിസ്റ്റുകൾ-അൺ ഓർഡേർഡ്‌ ലിസ്റ്റ്,ഓർഡേർഡ്‌‬‭ലിസ്റ്റ്,ഡെഫിനിഷൻ ലിസ്റ്റ്.‬
‭1.1. അൺ ഓർഡേർഡ്‌ ലിസ്റ്റ് -‬‭ഓർഡർ ചെയ്യാത്ത ലിസ്റ്റുകൾ‬‭ബുള്ളറ്റുകൾ കൊണ്ട്‬

‭അടയാളപ്പെടുത്തിയിരിക്കുന്നു.‬
‭< UL>‬‭ടാഗ് ഉപയോഗിച്ചാണ് ഓർഡർ ചെയ്യാത്ത ലിസ്റ്റുകൾ‬‭സൃഷ്ടിക്കുന്നത്.‬
‭<LI >‬‭ടാഗിനുള്ളിൽ ഓരോ ലിസ്റ്റ് ഇനങ്ങൾ എഴുതുന്നു.‬

‭<UL> ടാഗിന്റെ‬
‭ആട്രിബൂട്ട്‬

‭<UL> ടാഗിന്റെ‬
‭വാല്യൂ‬

‭ഉപയോഗം‬

‭TYPE‬

‭none‬ ‭വാല്യൂ ഒന്നും ഇല്ലെങ്കിൽ ബുള്ളറ്റ് ഡിസ്ക് രൂപത്തിലാണ്‬
‭<ul>‬
‭<li>RAM</li></ul>‬ ‭Output:    ⬤‬‭RAM‬

‭disc‬ ‭<ul type=”disc”>‬
‭<li>RAM</li></ul>‬ ‭Output:    ⬤‬‭RAM‬

‭circle‬ ‭<ul type=”circle”>‬
‭<li>RAM</li></ul>‬ ‭Output:    ❍‬‭RAM‬

‭square‬ ‭<ul type=”square”>‬
‭<li>RAM</li></ul>‬ ‭Output:    ❒‬‭RAM‬

‭1.2. ഓർഡേർഡ്‌ ലിസ്റ്റ് -‬‭നമ്പർ,റോമൻ നമ്പർ,അക്ഷരങ്ങൾ‬‭കൊണ്ട് അടയാളപ്പെടുത്തിയിരിക്കുന്നു.‬
‭< OL>‬‭ടാഗ് ഉപയോഗിച്ചാണ് ഓർഡർ ചെയ്യാത്ത ലിസ്റ്റുകൾ‬‭സൃഷ്ടിക്കുന്നത്.‬
‭<LI >‬‭ടാഗിനുള്ളിൽ ഓരോ ലിസ്റ്റ് ഇനങ്ങൾ എഴുതുന്നു‬

‭<UL>‬
‭ആട്രിബൂട്ട്‬

‭<UL>‬
‭ടാഗിന്റെ‬
‭വാല്യൂ‬

‭Type അട്രീബൂട്‬
‭നൽകുമ്പോൾ‬

‭Type & start അട്രീബൂട്‬
‭നൽകുമ്പോൾ‬

‭TYPE‬

‭&‬

‭START‬

‭1‬
‭(ഡീഫോൾ
‭വാല്യൂ‬

‭1 ആണ് )‬

‭<ol type=”1”>‬ ‭Output:‬
‭<li>RAM</li>                 1. RAM‬
‭<li>ROM</li>                 2. ROM‬

‭</ol>‬

‭<ol type=”1” start=”5”>‬ ‭Output:‬
‭<li>RAM</li>                 5. RAM‬
‭<li>ROM</li>                 6. ROM‬

‭</ol>‬

‭a‬ ‭<ol type=”a”>‬ ‭Output:‬
‭<li>RAM</li>                 a. RAM‬
‭<li>ROM</li>                 b. ROM‬

‭</ol>‬

‭<ol type=”a” start=”4”>‬ ‭Output:‬
‭<li>RAM</li>                 d. RAM‬
‭<li>ROM</li>                 e. ROM‬

‭</ol>‬

‭A‬ ‭<ol type=”A”>‬ ‭Output:‬
‭<li>RAM</li>                 A. RAM‬
‭<li>ROM</li>                 B. ROM‬

‭</ol>‬

‭<ol type=”A” start=”4”>‬ ‭Output:‬
‭<li>RAM</li>                 D. RAM‬
‭<li>ROM</li>                 E. ROM‬

‭</ol>‬

‭i‬ ‭<ol type=”i”>‬ ‭Output:‬
‭<li>RAM</li>                 i. RAM‬
‭<li>ROM</li>                 ii. ROM‬

‭</ol>‬

‭<ol type=”i” start=”4”>‬ ‭Output:‬
‭<li>RAM</li>                 iv. RAM‬
‭<li>ROM</li>                 v. ROM‬

‭</ol>‬

‭I‬ ‭<ol type=”I”>‬ ‭Output:‬
‭<li>RAM</li>                 I. RAM‬
‭<li>ROM</li>                 II. ROM‬

‭</ol>‬

‭<ol type=”I” start=”4”>‬ ‭Output:‬
‭<li>RAM</li>                 IV. RAM‬
‭<li>ROM</li>                 V. ROM‬

‭</ol>‬
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‭1.3. ഡെഫിനിഷൻ ലിസ്റ്റ് -‬
‭ഡെഫനിഷൻ ലിസ്റ്റുകൾ‬‭< DL>‬‭ടാഗ് ഉപയോഗിക്കുന്നു.‬‭<DT >‬‭ടാഗിൽ‬
‭ഡെഫിനിഷൻ നിർവചനവും,‬‭<DD>‬‭ടാഗ് വിവരണം വ്യക്തമാക്കുന്നു.‬

‭Code :‬ ‭OUTPUT:‬
‭<DL>‬

‭<DT> Data : </DT>‬ ‭Data :‬
‭<DD> Set of raw facts and figures </DD>‬ ‭Set of raw facts and figures‬
‭<DT>  Information: </DT>‬
‭<DD>  Processed data </DD>‬ ‭Information :‬

‭</DL>‬ ‭Processed data‬

‭2. ലിങ്കുകളുടെ നിർമാണം :‬‭( Hyperlink )‬
‭ഒരു വെബ് പേജിലെ ടെക്സ്റ്റിലോ, ഇമേജിലോ, എലെമെന്റിലോ ക്ലിക്ക് ചെയ്യുമ്പോൾ മറ്റൊരു‬
‭പേജിലോയ്ക്കോ അതേ പേജിന്റെ മറ്റൊരു ഭാഗത്തേക്കോ മൂവ് ചെയ്യാൻ ഹൈപ്പർലിങ്ക്‬
‭ഉപയോഗിക്കുന്നു.‬

‭⏩ലിങ്കുകൾക്ക്‬ ‭<A> ടാഗ് ( ആങ്കർ ടാഗ് )‬‭ഉപയോഗിക്കുന്നു.‬‭പ്രധാന ആട്രിബ്യൂട്ട്‬‭Href‬‭ആണ് ,‬
‭വാല്യൂ ആയി വെബ്‌പേജിന്റെ/വെബ്സൈറ്റിന്റെ URL ഉപയോഗിക്കുന്നു.‬

‭രണ്ടു തരത്തിലുള്ള ലിങ്കുകൾ :‬
‭a.എക്സ്റ്റേണൽ ലിങ്ക് :‬ ‭ഒരു വെബ്പേജിൽ‬‭നിന്ന് മറ്റൊരു വെബ്പേജിലേക്കുള്ള ലിങ്കിംഗ്.‬

‭ഉദാഹരണം :    <A Href=”Sample.html”> Sample </A>‬
‭b.ഇന്റേണൽ ലിങ്കിംഗ്‬‭: ഒരു വെബ്പേജിന്റെ ഒരു‬‭ഭാഗത്തുനിന്നും മറ്റൊരു ഭാഗത്തേക്കുള്ള‬

‭ലിങ്കിംഗ്. ഇതിനായി Href, Name ഉപയോഗിക്കുന്നു.‬

‭Concept of URL‬‭( യൂണിഫോം റിസോഴ്സ് ലൊക്കേറ്റർ )‬‭: രണ്ടുതരം URLകൾ‬
‭a.‬‭റിലേറ്റീവ്  URL‬ ‭: Href ന്റെ വാല്യൂ ആയി വെബ്‬‭അഡ്രസ് URLനൽകുന്നു.‬

‭ഉദാഹരണം :    <A Href=”dhsekerala.gov.in”> DHSE </A>‬
‭b.‬‭അബ്സല്യൂട് URL‬‭: href ന്റെ വാല്യൂ ആയി ലിങ്ക്‬‭ചെയ്യേണ്ട ഫയലിന്റെ പേര് നൽകുന്നു‬

‭ഉദാഹരണം :    <A Href=”Sample.html”> Sample </A>‬

‭ഇമേജിനെ ഹൈപ്പർലിങ്കായി നൽകുന്ന വിധം‬‭:‬
‭<A Href=”wayanad.com”><IMG Src=”wayanad.jpg”>‬‭</A>‬

‭3. മ്യൂസിക് വീഡിയോ വെബ്പേജിൽ  ഉൾപ്പെടുത്തുന്ന വിധം‬
‭3.1  <EMBED>‬‭ടാഗ്  :‬‭വെബ്പേജിൽ മ്യൂസിക്കും വീഡിയോയും‬‭ഉൾപ്പെടുത്തുന്നതിനുള്ള ടാഗ്.‬

‭ആട്രിബ്യൂട്ടുകൾ  -   Src, Height, Width, Align, Alt,‬‭Hidden‬
‭Hidden :‬ ‭മൾട്ടിമീഡിയ കമ്പോണന്റുകൾ ദൃശ്യമാകണോ‬‭വേണ്ടയോ എന്ന്  നിശ്ചയിക്കുന്നു.‬

‭Values : false ( default ) & true‬
‭3.2  <NOEMBED> :‬ ‭ബ്രൗസർ <EMBED> ടാഗ് സപ്പോർട്ട്‬‭ചെയ്യുന്നില്ല എങ്കിൽ <NOEMBED>‬

‭ടാഗിലെ കണ്ടന്റ് ഡിസ് പ്ലേ ചെയ്യും.‬
‭3.3. <BGSOUND> :‬ ‭വെബ് പേജ് റൺ ചെയ്യുന്ന അവസരത്തിൽ‬‭ബാഗ്രൗണ്ട് മ്യൂസിക് പ്ലേ ചെയ്യും.‬

‭ആട്രിബ്യൂട്ടുകൾ  -   Src,Loop ,Volume‬
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‭4. Use of Table Tag :‬
‭ടാഗ്‬ ‭ആട്രിബ്യൂട്ടുകൾ‬ ‭**ഉപയോഗം‬‭& വാല്യൂ‬

‭<TABLE>‬
‭ടാഗ്‬

‭<table>‬‭ടാഗ് :‬‭ടേബിൾ നിർമിക്കാൻ ഉപയോഗിക്കുന്നു‬

‭Border‬ ‭ബോർഡർ ലൈനിനു കനം നൽകുന്നു‬

‭Bordercolor‬ ‭ബോർഡർ ലൈനിനു നിറം നൽകുന്നു‬

‭Align‬ ‭ബ്രൗസറിൽ ടേബിളിന്റെ സ്ഥാനം നിശ്ചയിക്കുന്നു.‬
‭Value : left ( default), center, right‬

‭Bgcolor‬ ‭ടേബിളിനു ബാക്ക്ഗ്രൗണ്ട് കളർ നൽകുന്നു.‬

‭Cellspacing‬ ‭സെല്ലുകൾക്കിടയിലെ സ്പേസ് നിർവചിക്കുന്നു‬

‭Cellpadding‬ ‭സെല്ലും ,സെൽബോർഡറും തമ്മിലുള്ള അകലം നിർവചിക്കുന്നു

‭<TR> ടാഗ്‬ ‭ടേബിൾ റോ (വരി ) നിർമിക്കുവാൻ‬

‭<TD> ടാഗ്‬ ‭ഓരോ സെല്ലിലും ഡാറ്റ ഇൻസേർട് ചെയ്യുവാൻ‬

‭<TH> ടാഗ്‬ ‭ഓരോ കോളത്തിനും ഹെഡിങ് നൽകുന്നു‬

‭<TR> <TD> &‬
‭<TH> ടാഗ്‬
‭ആട്രിബ്യൂട്ടുകൾ‬

‭Align‬ ‭ഒരു റോയിലെ സെല്ലുകളിലെ ഡാറ്റയുടെ ഹൊറിസോണ്ടൽ  സ്ഥാനം‬
‭നിശ്ചയിക്കുന്നു.      Value : left ( default), center, right‬

‭Valign‬ ‭ഒരു റോയിലെ സെല്ലുകളിലെ ഡാറ്റയുടെ വെർട്ടിക്കൽ   സ്ഥാനം‬
‭നിശ്ചയിക്കുന്നു.      - top, middle, bottom or baseline.‬

‭Bgcolor‬ ‭ഓരോ റോയ്ക്കും ബാക്ക്ഗ്രൗണ്ട് കളർ നൽകുന്നു.‬

‭<TD> & <TH>‬
‭ടാഗ്‬

‭ആട്രിബ്യൂട്ടുകൾ‬

‭Colspan‬ ‭ഒരു സെല്ലിന്റെ വലിപ്പം ഒന്നിലധികം കോളങ്ങളിൽ വ്യാപിപ്പിക്കുന്നു‬

‭Rowspan‬ ‭ഒരു സെല്ലിന്റെ വലിപ്പം ഒന്നിലധികം റോകളിലേക്ക് വ്യാപിപ്പിക്കുന്നു‬

‭<CAPTION>‬ ‭ടേബിളിനു ഹെഡിങ് നൽകുന്നതിന് ഉപയോഗിക്കുന്നു‬

‭ഉദാഹരണം :‬
‭<table border="1" >‬
‭<CAPTION> STUDENTS  </CAPTION>‬
‭<tr>‬

‭<th>Roll No</th>‬
‭<th>Name</th>‬

‭</tr>‬
‭<tr>‬

‭<td>1</td>‬
‭<td>Anoop</td>‬

‭</tr>‬
‭<tr>‬

‭<td>2</td>‬

‭Output :‬

‭STUDENTS‬

‭Roll No‬ ‭Name‬

‭1‬ ‭Anoop‬

‭2‬ ‭Beena‬

‭<td>Beena</td>‬
‭</tr>‬

‭</table>‬
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‭5. <FORM> ടാഗ് :‬

‭ടാഗ്‬ ‭ആട്രിബ്യൂട്ടുകൾ‬ ‭**ഉപയോഗം‬‭& വാല്യൂ‬

‭<FORM>‬
‭ടാഗ്‬

‭യൂസർ  ഇൻപുട്ട് ശേഖരിക്കാൻ ഒരു HTML ഫോം ഉപയോഗിക്കുന്നു.‬

‭Action‬ ‭ഒരു ഫോം സമർപ്പിക്കുമ്പോൾ ഫോം-ഡാറ്റ എവിടേക്കാണ്‬
‭അയയ്ക്കേണ്ടതെന്ന് വ്യക്തമാക്കുന്നു. Value : “URL”‬

‭Method‬ ‭ഫോം-ഡാറ്റ അയക്കുമ്പോൾ ഉപയോഗിക്കേണ്ട HTTP രീതി‬
‭വ്യക്തമാക്കുന്നു. Value :  “POST”, “GET”‬

‭Target‬ ‭ഫോം സമർപ്പിച്ചതിന് ശേഷം ലഭിക്കുന്ന പ്രതികരണം എവിടെ‬
‭പ്രദർശിപ്പിക്കണമെന്ന് വ്യക്തമാക്കുന്നു‬
‭Value :  _blank, _self, _parent, _top, name‬

‭Form controls :‬‭HTML ഫോം ഉപയോഗിച്ച് ഡാറ്റ ശേഖരിക്കാൻ‬‭നമുക്ക് ഉപയോഗിക്കാവുന്ന വ്യത്യസ്ത‬
‭തരത്തിലുള്ള ഫോം എലെമെന്റ്സ്.എല്ലാം എംപ്റ്റി ടാഗുകളാണ്‬

‭<INPUT> ടാഗ്‬

‭ഫോം കോൺട്രോൾസ് സൃഷ്ടിക്കാൻ ഉപയോഗിക്കുന്നു.‬

‭Attribute‬ ‭Value‬

‭Type:‬
‭<INPUT>‬‭ടാഗ്‬
‭ഏതു‬
‭ടൈപ്പിലുള്ള‬

‭കൺട്രോൾ‬
‭നിർമിക്കണമെന്ന് 
‭തീരുമാനിക്കും‬

‭Text‬‭: ഒരു ടെക്സ്റ്റ് ബോക്സ് സൃഷ്ടിക്കുക‬
‭Password‬‭: ഒരു പാസ് വേർഡ് ബോക്സ് സൃഷ്ടിക്കുന്നു‬
‭Checkbox :‬‭ഉപയോക്താവിന് Yes/NOഎന്ന് രേഖപ്പെടുത്താൻ‬

‭കഴിയുന്ന ഒരു ചെക്ക്ബോക്സ് സൃഷ്ടിക്കുക.‬
‭Radio :‬ ‭ഒരു ഗ്രൂപ്പിൽ നിന്ന് ഒരൊറ്റ വാല്യൂ‬‭തിരഞ്ഞെടുക്കുന്നു.‬
‭Submit‬‭:  ഫോമിൽ നൽകിയ എല്ലാ എൻട്രികളും‬

‭സെർവറിലേക്ക് സമർപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.‬
‭Button‬‭:ഫോമിൽ സാധാരണ ഗ്രാഫിക്കൽ ബട്ടൺ സൃഷ്ടിക്കുന്നു.‬
‭Reset‬‭:  ഫോമിലെ എല്ലാ എൻട്രികളും ക്ലിയർ ചെയ്യുന്നു‬

‭Name‬ ‭ഇൻപുട്ട് എലെമെന്റിനും പേര് നൽകാൻ ഉപയോഗിക്കുന്നു.‬

‭Value‬ ‭ഓരോ ഫോം എലെമെന്റിൽ ഡിഫോൾട്ട് വാല്യൂ നൽകാൻ‬

‭Size‬ ‭ഇൻപുട്ട് എലെമെന്റിന്റെ വലുപ്പം വ്യക്തമാക്കുന്നു (ടെക്സ്റ്റ് ബോക്സും‬
‭പാസ്‌വേഡും)‬

‭6.‬‭< FRAMESET>‬‭:  ബ്രൌസർ വിൻഡോയെ പല സെക്ഷനുകളായി തിരിക്കുന്നു.‬ ‭ഇതൊരു‬
‭കണ്ടെയ്നർ  ടാഗാണ്.‬‭ആട്രിബ്യൂട്ടുകൾ:‬‭Rows,Cols,Border,Bordercolor‬

‭< FRAME> ടാഗ്‬ ‭: <FRAMESET> ടാഗ് കൊണ്ട് തരാം തിരിച്ച‬‭ബ്രൌസർ വിൻഡോയിൽ html‬
‭ഡോക്യൂമെന്റിനെ ലോഡ് ചെയ്യാം.‬

‭ഉദാഹരണം :‬‭<FRAMESET Cols=”30%,70%”>‬
‭<FRAME Src=” Code1.html”>  <FRAME Src=” Code2.html”>‬

‭< /FRAMESET>‬
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‭XII  - CHAPTER - 6‬
‭CASCADING STYLE SHEETS (‬‭CSS‬‭)‬

‭1.  കാസ്‌കേഡിംഗ് സ്‌റ്റൈൽ ഷീറ്റ് (CSS)‬‭: വെബ്സൈറ്റുകളുടെ‬‭ഭംഗി വർധിപ്പിക്കുന്നതിന് HTML ന്റെ കൂടെ‬
‭ഉപയോഗിക്കുന്ന കോഡുകളാണിവ.വാചകത്തിന്റെ നിറം, ഫോണ്ടുകളുടെ ശൈലി, ഖണ്ഡികകൾ തമ്മിലുള്ള‬
‭അകലം,ചിത്രങ്ങളുടെ സ്ഥാനം എന്നിവ വളരെ എളുപ്പത്തിൽ നിയന്ത്രിക്കാനാകും.‬

‭വെബ് പേജിൽ CSS ഉപയോഗിക്കുന്നതിന്റെ ഗുണങ്ങൾ‬
‭❖‬ ‭ലേഔട്ട് എളുപ്പത്തിൽ മാറ്റം‬
‭❖‬ ‭വെബ്‌പേജിലെ കോഡുകളുടെ എണ്ണംകുറയ്ക്കാം‬
‭❖‬ ‭ബാൻഡ് വിഡ്ത്‬ ‭കുറയ്ക്കാം‬
‭❖‬ ‭വെബ്സൈറ്റിലെ പേജുകൾ എല്ലാ ഒരേപോലെ ദൃശ്യമാക്കാം‬
‭❖‬ ‭വ്യത്യസ്ത സ്ക്രീൻ സൈസിൽ വെബ്‌പേജ് ഡിസ്പ്ലേ ചെയ്യാൻ സാധിക്കും‬
‭❖‬ ‭കുറഞ്ഞ സമയം കൊണ്ട് ഒന്നിലേറെ വെബ്‌പേജുകൾ വേഗത്തിൽ നിർമിക്കാം‬

‭3. css ലെ style rules  :‬‭ഒരു വെബ്‌പേജിൽ ടെക്സ്റ്റ്,ചിത്രം,പാരഗ്രാഫ്,ബട്ടൺ‬‭etc എങ്ങനെ‬
‭പ്രദർശിപ്പിക്കണമെന്ന് ബ്രൗസറിൽ നൽകുന്ന നിർദേശം. സ്റ്റൈൽ റൂളിന്റെ രണ്ടു ഭാഗങ്ങൾ :‬
‭3.1‬‭Selector‬‭: സ്റ്റൈൽ റൂൾ അപ്ലൈ ചെയ്യുന്ന HTML എലെമെന്റാണ്‬‭സെലക്ടർ.‬
‭3.2‬‭Declaration‬‭:‬‭പ്രോപ്പർട്ടിയും വാല്യൂവും സെമിക്കോളതിനാൽ‬‭സെപ്പറേറ്റ് ചെയ്തിരിക്കുന്ന ബ്ലോക്ക്.‬

‭*Property : സ്റ്റൈൽ റൂളിൽ  ഉപയോഗിക്കുന്ന കീവേഡുകളാണ് പ്രോപ്പർട്ടികൾ.‬
‭Syntax :‬ ‭Selector{ property:value; }   or സെക്ടർ{‬‭പ്രോപ്പർട്ടി:വാല്യൂ;}‬

‭3.1.1  വിവിധ തരം സെലെക്ടറുകൾ‬
‭3.1.1.1‬‭യൂണിവേഴ്സൽ സെലക്ടർ‬‭:‬‭ഒരു HTML പേജിന്റെ എല്ലാ‬‭ടാഗ് ഘടകങ്ങൾക്കും ഒരേപോലെ‬
‭ഡിക്ലറേഷൻ നല്കുന്നതാണിത്. ഇതിനായി സെലെക്ടർ ഭാഗത്ത് ടാഗിന് പകരം * ചിഹ്നം ഉപയോഗിക്കുന്നു.‬
‭Syntax :‬ ‭*{ പ്രോപ്പർട്ടി:വാല്യൂ;}       Eg:‬ ‭*{‬‭color: white;}‬

‭3.1.1.2‬‭ടൈപ്പ് സെലക്ടർ‬‭:‬‭ഇവിടെ സെലെക്ടർ ആയി ടാഗിന്റെ‬‭പേര് നൽകുന്നു.‬
‭Syntax :‬ ‭Selector{ പ്രോപ്പർട്ടി:വാല്യൂ;}‬ ‭Eg:‬ ‭P{ color: white;}‬

‭3.1.1.3‬‭ക്ലാസ് സെലക്ടർ‬‭:‬‭വെബ് പേജിലെ ആവശ്യമുള്ള ഘടകത്തിലേക്ക്‬‭മാത്രം ഒന്നോ‬

‭അതിലധികമോ സ്റ്റൈൽ റൂൾ പ്രയോഗിക്കാൻ കഴിയും.ഇവിടെ ക്ലാസ് സെക്ടർ പേരിനു മുൻപായി  (‬‭.‬‭)‬
‭ഡോട്ട് ചിഹ്നം ഉപയോഗിക്കുന്നു.‬‭Syntax :‬ ‭. Selector{‬‭പ്രോപ്പർട്ടി:വാല്യൂ;}   Eg:   .‬‭bgcolor{ color: white;}‬

‭3.1.1.4‬‭ഐഡി സെലക്ടർ‬‭:‬‭വെവെബ് പേജിലെ ആവശ്യമുള്ള ഘടകത്തിലേക്ക്‬‭മാത്രം ഒറ്റത്തവണ സ്റ്റൈൽ‬
‭റൂൾ പ്രയോഗിക്കാൻ കഴിയും. ഇവിടെ ക്ലാസ് സെക്ടർ പേരിനു മുൻപായി # ചിഹ്നം ഉപയോഗിക്കുന്നു.‬

‭Syntax :   #‬‭Selector{ പ്രോപ്പർട്ടി:വാല്യൂ;}   Eg:‬ ‭#‬‭bgcolor{ color: white;}‬
‭CSS-ലെ വ്യത്യസ്ത പ്രോപ്പർട്ടികൾ ആണ് - ഫോണ്ട് പ്രോപ്പർട്ടികൾ,ടെക്സ്റ്റ് പ്രോപ്പർട്ടി.‬
‭3.3.1   CSSലെ ഫോണ്ട്പ്രോപ്പർട്ടികൾ:ഫോണ്ട്-ഫാമിലി,ഫോണ്ട്-സ്റ്റൈൽ,ഫോണ്ട്-വെയ്റ്റ്,ഫോണ്ട്-സൈസ്‬

‭➤ വെബ്‌പേജിലെ എല്ലാ പാരഗ്രഫ്ഉകൾക്കും "Arial  ഫോണ്ടും 30pixelകളുടെ മാർജിനും സെറ്റ്‬
‭ചെയ്യാൻ CSS സ്റ്റൈൽ റൂൾ എഴുതുക.‬‭ഉത്തരം‬‭:‬ ‭P { font-family : “Arial” ; margin: 30px;‬

‭3.3.2   CSSലെ ടെക്സ്റ്റ്പ്രോപ്പർട്ടി ടെക്സ്റ്റ്അലൈൻ,ടെക്സ്റ്റ്ഡെക്കറേഷൻ,ടെക്സ്റ്റ്ഇൻഡന്റ്,ലൈൻ-ഹൈറ്റ്.‬
‭➤ വെബ്‌പേജിലെ എല്ലാ പാരഗ്രഫ്ഉകൾക്കും "Arial  ഫോണ്ടും 30pixelകളുടെ മാർജിനും സെറ്റ്‬

‭ചെയ്യാൻ CSS സ്റ്റൈൽ റൂൾ എഴുതുക.‬‭ഉത്തരം‬‭:‬‭P { font-family : “Arial” ; margin: 30px}‬

‭4. ഒരു വെബ് പേജിലേക്ക് CSS ചേർക്കുന്നതിനുള്ള മാർഗങ്ങൾ‬ ‭:‬
‭4.1 ഇൻലൈൻ സ്റ്റൈൽ ഷീറ്റ്‬‭: HTML ടാഗിനുള്ളിൽ ‘STYLE’ ആട്രിബ്യൂട്ട് ഉപയോഗിക്കുന്നു.  പ്രോപ്പർട്ടീസുകളും‬

‭വാല്യൂവും ആട്രിബ്യൂട്ടിലേക്ക് നേരിട്ട് ഉപയോഗിക്കുന്നു.  ഉദാ:‬ ‭<‬‭p‬‭style‬‭="color:red;">‬‭This is a paragraph.‬‭<‬‭/p‬‭>‬
‭4.2 ഇന്റെർണൽ സ്റ്റൈൽ ഷീറ്റ് :‬‭സ്റ്റൈൽ റൂൾ HTML പേജിന്റെ <HEAD> ടാഗിനുള്ളിൽ   <STYLE>, </STYLE>‬

‭ടാഗുകൾക്കിടയിൽ എഴുതുന്നു.      ഉദാ:‬ ‭<HEAD> <STYLE> P {color:red;} </STYLE> </HEAD>‬
‭4.3 എക്സ്റ്റേണൽ സ്റ്റൈൽ ഷീറ്റ്:‬‭സ്റ്റൈൽ റൂളുകൾ പ്രത്യേക ഫയൽ(.css)ആയി സേവ് ചെയ്യുന്നു.  ഈ‬

‭ഫയലിനെ<LINK>എന്ന ടാഗ് ഉപയോഗിച്ച് HTML പേജുമായി അറ്റാച്ച് ചെയ്യുന്നു.‬

‭ഉദാ:‬ ‭<‬‭head‬‭> <‬‭link‬‭rel‬‭="stylesheet"‬‭href‬‭="mystyle.css"><‬‭/head‬‭>‬
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‭XII  - CHAPTER - 7‬
‭വെബ് ഹോസ്റ്റിംഗ്‬

‭1. വെബ് ഹോസ്റ്റിംഗ് :‬ ‭ഇന്റർനെറ്റിൽ ഒരു വെബ്സൈറ്റ്‬‭പ്രസിദ്ധീകരിക്കാൻ അനുവദിക്കുന്ന സേവനമാണ്‬
‭വെബ് ഹോസ്റ്റിംഗ്. വെബ്‌സൈറ്റ് ഫയലുകൾ സെർവറിൽ സംഭരിക്കുകയും വെബ് ബ്രൗസറിലൂടെ ആളുകൾക്ക്‬
‭ഫയലുകൾ ആക്‌സസ് ചെയ്യാനും സാധിക്കുന്നു.‬

‭വെബ് ഹോസ്റ്റിംഗ് സേവനം നൽകുന്ന കമ്പനികളാണ്‬ ‭വെബ് ഹോസ്റ്റ്‬‭.‬
‭2.വിവിധതരം വെബ് ഹോസ്റ്റിംഗുകൾ‬
‭2.1 ഫ്രീ ഹോസ്റ്റിംഗ് :‬‭വെബ് പേജുകൾ യാതൊരു ചെലവും കൂടാതെ‬‭ഹോസ്റ്റ് ചെയ്യാൻ സാധിക്കുന്നു. എന്നാൽ‬
‭ഇതിനു യൂസർ സപ്പോർട്ട് ഉണ്ടാവില്ല,കൂടാതെ കുറഞ്ഞ ബാൻഡ്‌വിഡ്‌ത്തും ആയിരിക്കും.ഹോസ്റ്റ് കമ്പനി ചെയ്ത‬
‭വെബ്സൈറ്റുകളിലൂടെ പരസ്യങ്ങൾ നൽകി ലാഭം കണ്ടെത്തുന്നു.‬
‭2.2 ഷെയേർഡ് ഹോസ്റ്റിങ് :‬‭റാം, സിപിയു,സ്റ്റോറേജ് സ്പേസ്‬‭തുടങ്ങിയ റിസോർസുകൾ പങ്കിടുകയും അതിലൂടെ‬
‭ചില കമ്പനികൾക്കു ഒന്നിൽ കൂടുതൽ വെബ്സൈറ്റുകൾ ഒരേ സമയം വെബ് സെർവറിൽ ഹോസ്റ്റ് ചെയ്യാനും‬
‭സാധിക്കും.ഇത്തരം ഹോസ്റ്റിങ് വിലക്കുറവും,ട്രാഫിക് കുറവുള്ള ചെറിയ വെബ്‌സൈറ്റുകൾക്ക്  ഉപയോഗിക്കാൻ‬
‭എളുപ്പവുമാണ്.ബാൻഡ്‌വിഡ്ത്ത് നിരവധി വെബ്‌സൈറ്റുകൾ പങ്കിടുന്നതിലൂടെ  മറ്റെല്ലാ വെബ്‌സൈറ്റുകളും‬
‭ഡൗണാകും എന്നതാണ് ഇതിന്റെ പോരായ്മ.‬
‭2.3 ഡെഡിക്കേറ്റഡ് ഹോസ്റ്റിങ് :‬‭ഒരു ക്ലയന്റ്/വെബ്‌സൈറ്റിന്‬‭വേണ്ടി മാത്രം സെർവർ സ്പേസും,CPU ,RAM‬
‭തുടങ്ങിയ റിസോർസുകൾ ഉപയോഗപ്പെടുത്തുന്നു. അതിലൂടെ ഉയർന്ന ബാൻഡ് വിഡ്ത്തും മികച്ച പ്രവർത്തന‬
‭വേഗതയും ലഭ്യമാകുന്നു.ചെലവ് കൂടുതലാണ് എന്നതാണ് പ്രധാന ന്യൂനത‬
‭2.4 വെർച്വൽ പ്രൈവറ്റ് സെർവർ  ഹോസ്റ്റിങ്‬‭( VPS - Virtual‬‭Private Server )‬‭:‬‭ഒരു വെബ് സെർവറിനെ നിരവധി‬
‭സ്വതന്ത്ര സെർവറുകളായി വിഭജിക്കുകയും ആയതിന്റെ CPU ,RAM തുടങ്ങിയ റിസോർസുകൾ ഷെയർ ചെയ്യുന്നു.‬
‭ഷെയേർഡ് ഹോസ്റ്റിംഗിനേക്കാൾ കൂടുതൽ സൗകര്യവും, ഡെഡിക്കേറ്റഡ് നേക്കാൾ ചെലവ് കുറവുമാണിതിന്.‬
‭3. ഡൊമെയ്ൻ നെയിം രജിസ്ട്രേഷൻ സ്‌റ്റെപ്സ്‬ ‭DNS‬‭( Domain Name System )‬
‭i) വെബ്‌സൈറ്റിനായി ഡൊമെയ്ൻ നെയിം തീരുമാനിക്കുക‬
‭ii) ICANN-ന്റെ ഡാറ്റാബേസ് ഉപയോഗിച്ച് ഡൊമെയ്ൻ നെയിം ലഭ്യമാണോയെന്ന് പരിശോധിക്കുക‬
‭iii)‬‭‘‬‭WHOIS’ ഡാറ്റാബേസിൽ പേര്, വിലാസം, ഫോൺ നമ്പർ,‬‭ഇ-മെയിൽ വിലാസം മുതലായവ നൽകുക‬
‭iv) വാർഷിക ഫീസ് അടയ്ക്കുക‬
‭v) 'A റെക്കോർഡ്' പരിഷ്ക്കരിക്കുക‬

‭4 .FTP ക്ലയന്റ് സോഫ്റ്റ് വെയർ‬ ‭: നമ്മുടെ കമ്പ്യൂട്ടറിൽ‬‭നിന്നുള്ള  വെബ്സൈറ്റ് ഫയലുകളെ വെബ്‬
‭സെർവറിലേക്ക് അപ്‌ലോഡ് ചെയ്യുന്നതിനുള്ള സോഫ്റ്റ് വെയർ.‬
‭FTP ക്ലയന്റ് സോഫ്റ്റ്‌വെയർ പ്രവർത്തനം‬
‭FTP  സോഫ്റ്റ് വെയർ വിൻഡോയിൽ, ഇടതുവശത്തുള്ള ഭാഗം നമ്മുടെ കമ്പ്യൂട്ടറിലെ ഫോൾഡറുകളും‬
‭ഫയലുകളും പ്രദർശിപ്പിക്കുന്നു,വലത് വശം വെബ് സെർവർ കമ്പ്യൂട്ടറിലെ ഫയലുകൾ ഫോൾഡറുകളും‬
‭പ്രദർശിപ്പിക്കുന്നു.'ഡ്രാഗ് ആൻഡ് ഡ്രോപ്പ്' രീതി ഉപയോഗിച്ച് നമ്മുടെ കമ്പ്യൂട്ടറിൽ നിന്ന് വെബ് സെർവറിലേക്ക്‬
‭ഫയലുകൾ കൈമാറാൻ കഴിയും.‬‭സോഫ്റ്റ് വെയറുകളുടെ പേര്  :‬‭FileZilla,CuteFTP, Smart FTP‬
‭➤‬‭FTP സോഫ്‌റ്റ്‌വെയറിൽ SFTP (സെക്യൂർ ഫയൽ ട്രാൻസ്ഫർ‬‭പ്രോട്ടോക്കോൾ) ഉപയോഗിക്കുന്നതിന്റെ പ്രയോജനം?‬

‭ഉത്തരം :‬ ‭FTP സോഫ്റ്റ് വെയർ സുരക്ഷിതമല്ലാതെ അയക്കുമ്പോൾ,‬‭SFTP സോഫ്റ്റ് വെയർ ഉപയോഗിച്ച് യൂസർ‬
‭നെയിം,പാസ്സ്‌വേർഡ്,ഡാറ്റ എന്നിവ സെർവറിലേക്ക് എൻക്രിപ്ട് ചെയ്ത് സുരക്ഷിതമായി അയക്കുന്നു.‬
‭5 .കണ്ടെന്റ് മാനേജ്‌മന്റ് സിസ്റ്റം :‬‭ഡൈനാമിക് വെബ്‌സൈറ്റുകൾ‬‭എളുപ്പത്തിൽ നിർമിക്കുന്നതിനും‬
‭നിയന്ത്രിക്കുന്നതിനും പബ്ലിഷ് ചെയ്യുന്നതിനും ഉപയോഗിക്കുന്ന വെബ് അധിഷ്ഠിത സോഫ്റ്റ് വെയറാണിത്.‬
‭CMSൽ ധാരാളം ടെംപ്ലേറ്റുകൾ ലഭ്യമാണ്.‬‭സോഫ്റ്റ് വെയറുകളുടെ‬‭പേര്  :  WordPress, Drupal, Joomla‬

‭6 .റെസ്പോൺസീവ് വെബ് ഡിസൈൻ:‬‭സ്ക്രീൻ വലിപ്പം പരിഗണിക്കാതെ എല്ലാ ഡിവൈസുകളിലും‬
‭ഒരേപോലെ വെബ്സൈറ്റ് ദൃശ്യമാക്കുന്നതിനായി ഉപയോഗിക്കുന്നു.ഫ്ലെക്സിബിൾ ഗ്രിഡ് ലേഔട്ട്, മീഡിയ‬

‭ക്വാറീസ് എന്നിവ ഉപയോഗിക്കുന്നു.‬
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‭XII  - CHAPTER - 8‬
‭ഡാറ്റബേസ് മാനേജ്‌മന്റ് സിസ്റ്റം ( DBMS )‬

‭1.‬ ‭ഡാറ്റബേസ് :‬‭ഘടനാപരമായ വിവരങ്ങളുടെ അല്ലെങ്കിൽ ഡാറ്റയുടെ‬‭സംഘടിത ശേഖരമാമാണിത്.‬
‭DBMS :‬‭ഡാറ്റാബേസിൽ ഡാറ്റയെ സ്റ്റോർ ചെയ്യുന്നതിനും,എടുക്കുന്നതിനും,കൈകാര്യം‬
‭ചെയ്യുന്നതിനും ഉപയോഗിക്കുന്ന സോഫ്റ്റ് വെയർ ടൂളാണ്.  ഉദാ:MySQL, Oracle, SQLite, DB-2‬

‭2. DBMS ന്റെ ഗുണങ്ങൾ‬
‭2.1‬‭ഡാറ്റ റിഡൻഡൻസി നിയന്ത്രിക്കുന്നു :‬‭ഡാറ്റയുടെ‬‭ആവർത്തനം നിയന്ത്രിക്കുന്നു.‬
‭2.2‬‭ഡാറ്റ കൺസിസ്റ്റൻസി  :‬‭ഡാറ്റ സ്ഥിരത  കൂടുന്നു.‬
‭2.3‬‭എഫിഷ്യന്റ് ഡാറ്റ ആക്സസ് :‬‭ഫലപ്രദമായി ഡാറ്റ ഉപയോഗിക്കാൻ‬‭സാധിക്കും‬
‭2.4‬‭ഡാറ്റയുടെ ഇന്റെഗ്രിറ്റി :‬‭ഡാറ്റയുടെ സമ്പൂർണത‬
‭2.5‬‭ഡാറ്റ സെക്യൂരിറ്റി :‬‭ഡാറ്റയുടെ സുരക്ഷാ ഉറപ്പുവരുത്തുന്നു‬
‭2.6‬‭ഷെയറിങ് ഓഫ് ഡാറ്റ :‬‭ഡാറ്റയെ പങ്കുവെക്കാൻ സഹായിക്കുന്നു‬
‭2.7‬‭ക്രാഷ് റിക്കവറി :‬‭നഷ്ടപെട്ട ഡാറ്റ തിരിച്ചെടുക്കാൻ‬‭സഹായിക്കുന്നു‬
‭2.8‬‭എൻഫോഴ്‌സ്‌മെന്റ് ഓഫ് സ്റ്റാൻഡേർഡ്‌സ് :‬‭നിലവാരം‬‭ഉറപ്പാക്കുന്നു.‬

‭3. DBMSന്റെ ഘടകങ്ങൾ  :‬
‭3.1 ഹാർഡ്‌വെയർ :‬‭ഡാറ്റാബേസിൽ ഡാറ്റ കൈകാര്യം ചെയ്യുന്നതിനുപയോഗിക്കുന്ന‬‭ഉപകരണങ്ങൾ.‬
‭3.2‬‭സോഫ്റ്റ് വെയർ‬‭:‬‭യൂസറിനെയും ഡാറ്റാബേസിനെയും‬‭തമ്മിൽ ബന്ധിപ്പിക്കുന്നു.‬
‭3.3‬‭ഡാറ്റ :‬‭ഡാറ്റാബേസിൽ സംഭരിച്ചിരിക്കുന്ന എല്ലാ‬‭ഇനങ്ങളും.‬
‭3.4 പ്രൊസീജിയർ :‬‭ഒരു നിർദ്ദിഷ്‌ട ടാസ്‌ക് നിർവഹിക്കുന്ന‬‭SQL സ്റ്റേറ്റ്‌മെന്റുകൾ.‬

‭3.5 യൂസർ : DBMSൽ ഡാറ്റാബേസ് ഉപയോഗിക്കുന്ന 4 യൂസേഴ്സ് ഉണ്ട്.‬
‭3.5.1 ഡാറ്റാബേസ് അഡ്മിനിസ്ട്രേറ്റർ  (DBA) :‬‭ഡാറ്റാബേസിനെ‬‭പൂർണമായും നിയന്ത്രിക്കുന്നു.‬

‭ഡാറ്റാബേസ് അഡ്മിനിസ്ട്രേറ്ററുടെ കർത്തവ്യങ്ങൾ‬
‭●‬ ‭Conceptual സ്കീമ  & ഫിസിക്കൽ സ്കീമ ഡിസൈൻ ചെയ്യുന്നു‬
‭●‬ ‭സെക്യൂരിറ്റി & ഓതറൈസഷൻ‬
‭●‬ ‭ഡാറ്റ അവൈലബിലിട്ടി & റിക്കവറി ഫ്രം ഫെയിലേർസ്‬

‭3.5.2 അപ്ലിക്കേഷൻ പ്രോഗ്രാമർ:‬‭ആപ്ലിക്കേഷൻ പ്രോഗ്രാമുകൾ‬‭വികസിപ്പിക്കുന്നതിന് DBMSമായി‬
‭ബന്ധപ്പെടുന്നവർ.‬

‭3.5.3 സോഫിസ്റ്റിക്കേറ്റഡ് യൂസേഴ്സ് :‬‭എഞ്ചിനീയർമാർ,ശാസ്ത്രജ്ഞർ,ബിസിനസ്അനലിറ്റിക്‌സ്‬‭എന്നിവർ‬

‭3.5.4 നേവ് യൂസേഴ്സ് :‬‭ഏതെങ്കിലും അപ്ലിക്കേഷൻ‬‭പ്രോഗ്രാം ഉപയോഗിച്ചു DBMS മായി‬
‭ബന്ധപ്പെടുന്ന പരിചയമില്ലാത്ത യൂസർ.‬

‭4. ഡാറ്റ അബ്സ്ട്രാക്ഷൻ :‬‭യൂസറിൽ നിന്ന് ആവശ്യമില്ലാത്തതോ‬‭അപ്രസക്തമായതോ ആയ‬
‭വിശദാംശങ്ങൾ മറയ്ക്കുന്ന ഒരു പ്രക്രിയയാണിത്. ഇതിനു 3 ലെവലുകളുണ്ട് :‬

‭4.1 ഫിസിക്കൽ ലെവൽ : ഡാറ്റ യഥാർത്ഥത്തിൽ എങ്ങനെ സംഭരിക്കുന്നു എന്ന് നിർവചിക്കുന്നു‬
‭4.2 ലോജിക്കൽ ലെവൽ :‬‭ഡാറ്റബേസിൽ എന്ത് ഡാറ്റയാണ് സംഭരിചിരിക്കുന്നു‬‭എന്ന് നിർവചിക്കുന്നു.‬

‭4.3 വ്യൂ ലെവൽ : ഡാറ്റാബേസിന്റെ ഒരു ഭാഗം മാത്രമാണ് ഉപയോക്താക്കൾ കാണുന്നത്‬
‭5. ഡാറ്റ ഇൻഡിപെൻഡൻസ്  :‬‭പ്രോഗ്രാമുകളെയും ആപ്ലിക്കേഷനെയും‬‭ബാധിക്കാതെ സ്കീമയിൽ‬

‭മാറ്റം വരുത്താനുള്ള കഴിവാണ് ഡാറ്റ ഇൻഡിപെൻഡൻസ്.ഇതിനു 2 ലെവലുകളുണ്ട്.‬
‭5.1‬‭ഫിസിക്കൽ ഡാറ്റ ഇൻഡിപെൻഡൻസ്:‬‭ലോജിക്കൽ ലെവലിനെ ബാധിക്കാതെ‬‭ഫിസിക്കൽ‬

‭ലെവലിൽ മാറ്റം വരുത്തുന്നു.‬
‭5.2‬‭ലോജിക്കൽ ഡാറ്റ ഇൻഡിപെൻഡൻസ്: :‬ ‭വ്യൂ ലെവലിനെ ബാധിക്കാതെ ലോജിക്കൽ ലെവലിൽ‬
‭മാറ്റം വരുത്തുന്നു.‬
‭6. RDBMS : റിലേഷനൽ‬‭ഡാറ്റബേസ് മാനേജ്‌മന്റ് സിസ്റ്റം‬

‭ഉദാഹരമാണ്: Oracle ,Microsoft SQL Server, MySQL, DB2 ,Informix and Ingress‬
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‭7. Terminologies in RDBMS (  RDBMS ലെ സാങ്കേതികപദങ്ങൾ )‬
‭7.1‬‭എന്റിറ്റി :‬‭മറ്റുള്ളവരിൽ നിന്ന് വേർതിരിച്ചറിയാൻ‬‭കഴിയുന്ന ഒരു വ്യക്തി അല്ലെങ്കിൽ വസ്തു.‬
‭7.2‬‭റിലേഷൻ‬‭( ടേബിൾ ):വരികളുടെയും നിരകളുടെയും അടിസ്ഥാനത്തിൽ‬‭ക്രമീകരിച്ചിരിക്കുന്ന‬

‭ഡാറ്റ ഘടന.‬
‭7.3‬ ‭ടപ്പിൽ‬‭: റിലേഷനിലെ റോകളാണിത്‬
‭7.4‬‭ആട്രിബിയൂട്ട്‬‭: റിലേഷനിലെ കോളങ്ങളാണിത്‬
‭7.5‬‭ഡിഗ്രി :‬‭റിലേഷനിലെ ആട്രിബ്യുട്ടുകളുടെ എണ്ണം‬
‭7.6‬‭കാർഡിനാലിറ്റി‬‭: റിലേഷനിലെ ടപ്പിളുകളുടെ എണ്ണം‬
‭7.7‬‭ഡൊമൈൻ :‬‭ഒരു കോളത്തിൽ ദൃശ്യമാകുന്ന യഥാർത്ഥ മൂല്യങ്ങളെ‬‭വിളിക്കുന്നു.‬
‭7.8‬‭സ്കീമ :‬‭ഡാറ്റാബേസിന്റെ സ്‌ട്രെച്ചറിനെ ഡാറ്റാബേസ്‬‭ടേബിൾ എന്നി പറയുന്നു.‬
‭7.9‬‭ഇൻസ്റ്റൻസ് :‬‭ട്യൂപ്പിളുകളുടെ കൂട്ടമാണിത്,‬‭അതിൽ‬‭ഓരോ ട്യൂപ്പിളിനും തുല്യമായ ഫീൽഡുകൾ ഉണ്ട്.‬

‭8. KEY (  RDBMS ലെ കീ കൾ  )‬
‭ഒരു ടേബിളിലെ ഓരോ റെക്കോർഡും (ട്യൂപ്പിൾ) തിരിച്ചറിയുന്ന‬‭ആട്രിബ്യൂട്ട് / ആട്രിബ്യൂട്ടുകളുടെ‬
‭ശേഖരമാണ് കീ.‬

‭8.1‬ ‭ക്യാൻഡിഡേറ്റ് കീ :‬‭ഒരു റിലേഷനിലെ ഓരോ റോയെയും‬‭തിരിച്ചറിയുന്നതിനു സഹായിക്കുന്നു.‬
‭8.2‬‭പ്രൈമറി കീ (Primary key ):‬‭ഒരു റിലേഷനിലെ ഓരോ‬‭റോയെയും(ടപ്പിൾ) തിരിച്ചറിയുന്നതിനു‬

‭ഡാറ്റാബേസ് ഡിസൈനർ തിരഞ്ഞെടുക്കുന്ന ക്യാൻഡിഡേറ്റ് കീയാണിത്.‬
‭8.3‬‭ആൾട്ടർനേറ്റ് കീ(Alternate key) :‬‭പ്രൈമറി കീ‬‭അല്ലാത്ത ക്യാൻഡിഡേറ്റ്കീ യാണിത്.‬
‭8.4‬‭ഫോറിൻ കീ (Foreign key ) :‬‭ഒരു ടേബിളിലെ ഒരു കീ‬‭മറ്റൊരു പട്ടികയിലെ പ്രൈമറികീ ആണെങ്കിൽ‬

‭അതിനെ ഫോറിൻ കീ എന്ന് വിളിക്കാം.രണ്ടോ അതിലധികമോ പട്ടികകൾ ലിങ്ക് ചെയ്യാൻ സാധിക്കുന്നു.‬

‭9.റിലേഷണൽ ഓപ്പറേഷൻസ്‬

‭ഓപ്പറേഷൻ‬ ‭സിംബൽ‬ ‭ഉപയോഗം‬

‭സെലക്ട്‬ ‭σ‬ ‭കണ്ടിഷനെ അടിസ്ഥാനമാക്കി റിലേഷനിൽ നിന്നും ടപ്പിൾ(റോ)‬
‭തിരഞ്ഞെടുക്കുന്നു.‬

‭പ്രൊജക്റ്റ്‬ ‭π‬ ‭റിലേഷനിൽ നിന്നും ആട്രിബൂട്ട്(കോളം) തിരഞ്ഞെടുത്തു പുതിയ‬
‭റിലേഷൻനിർമിക്കുന്നു.‬

‭യൂണിയൻ‬ ‭U‬ ‭രണ്ടു റിലേഷനുകളിലെ റോകളെ കൂട്ടിച്ചേർത്തു പുതിയ റിലേഷൻ‬
‭നിർമിക്കുന്നു.‬

‭ഇന്റർസെക്ഷൻ‬ ‭∩‬ ‭രണ്ടു റിലേഷനുകളിലെ പൊതുവായ റോകളെ കണ്ടെത്തി പുതിയ‬
‭റിലേഷൻ നിർമിക്കുന്നു.‬

‭സെറ്റ് ഡിഫറെൻസ് ‭-‬ ‭ഒന്നാമത്തെ റിലേഷനിൽ ഉള്ളതും രണ്ടാമത്തെ റിലേഷനിൽ‬
‭ഇല്ലാത്തതുമായ റോകളെ കണ്ടെത്തി പുതിയ റിലേഷൻ നിർമിക്കുന്നു.‬

‭കാർടീഷ്യൻ‬
‭പ്രോഡക്റ്റ്‬

‭X‬ ‭രണ്ടു റിലേഷനുകളിലെ മുഴുവൻ റോകളും ചേർന്ന് ഉണ്ടാകുന്ന എല്ലാ‬
‭കൂട്ടുകെട്ടുകളുമാണിത്.‬
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‭XII  - CHAPTER - 9‬
‭സ്ട്രക്ചേർഡ് ക്വറി ലാംഗ്വേജ്  ( SQL )‬

‭1.‬‭ക്വറി :‬ ‭ഡാറ്റാബേസിൽ നിന്ന് ഡാറ്റ ലഭിക്കുന്നതിനുള്ള‬‭അഭ്യർത്ഥനയാണ്.‬
‭***2. SQLന്റെ  ഘടകങ്ങൾ ( Components of SQL) & ഉപയോഗം‬

2.1 ഡാറ്റ ഡെഫനിഷൻ ലാംഗ്വേജ് (DDL)‬‭:‬‭ഡാറ്റാബേസിൽ‬‭ടേബിൾ നിർമിക്കുക, പരിഷ്കരിക്കാം,നീക്കം ചെയ്യാം.‬

‭DDL Commands‬

     കമാൻഡ്‌സ് :‬ ‭ഉപയോഗം‬

‭CREATE TABLE‬ ‭പുതിയ ടേബിൾ നിർമിക്കാൻ‬

‭ALTER TABLE‬ ‭ടേബിൾ മോഡിഫൈ ചെയ്യുന്നതിന്‬

‭DROP TABLE‬ ‭ടേബിളിനെ ഡിലീറ്റ് ചെയ്യുന്നു.‬

‭2.2 ഡാറ്റ മാനിപുലേഷൻ ലാംഗ്വേജ് (DML) :‬‭ടേബിളിലേക്ക് പുതിയ റോകൾ കൂട്ടിച്ചേർക്കാം,നിലവിലെ‬
‭റോകളെ പരിഷ്കരിക്കാം,റോകളെ നീക്കം ചെയ്യാം.‬

‭DML Commands‬

     കമാൻഡ്‌സ് :‬ ‭ഉപയോഗം‬

‭INSERT INTO‬ ‭ടേബിളിലേക്ക് റെക്കോർഡുകൾ ചേർക്കാൻ.‬

‭SELECT‬ ‭ടേബിളിൽ നിന്ന് ഇൻഫർമേഷൻ എടുക്കുന്നു.‬

‭UPDATE‬ ‭ടേബിളിലെ ഓരോ റെക്കോർഡും മോഡിഫൈ ചെയ്യുന്നു.‬

‭DELETE‬ ‭ടേബിളിലെ ഓരോ റെക്കോർഡും ഡിലീറ്റ് ചെയ്യുന്നു.‬

‭2.3 ഡാറ്റ കൺട്രോൾ ലാംഗ്വേജ് (DCL) :‬‭ഡാറ്റാബേസിലേക്കുള്ള‬‭ആക്സസ് നിയന്ത്രിക്കാൻ ഉപയോഗിക്കുന്നു.‬

‭DCL Commands‬

     കമാൻഡ്‌സ് :‬ ‭ഉപയോഗം‬

‭GRANT‬ ‭യൂസെറിന് ഡാറ്റ എടുക്കുന്നതിനു അനുവാദം നൽകുന്നു.‬

‭REVOKE‬ ‭നൽകിയ അനുവാദം തിരിച്ചെടുക്കുന്നു‬

‭***3. SQLലെ  ഡാറ്റ ടൈപ്സ്  ( Datatypes ) in SQL‬‭:‬‭ടേബിളിന്റെ കോളത്തിൽ നൽകിയേക്കാവുന്ന‬
‭വാല്യൂവിന്റെ ടൈപ്പ് (ടെക്സ്റ്റ്,നമ്പർ) നിർവചിക്കുന്നു.MySQLലെ 3 തരം ഡാറ്റാടൈപ്പുകൾ:‬

‭3.1 ന്യൂമെറിക് ഡാറ്റ ടൈപ്പ്‬‭:‬
‭3.1.1) INT or INTEGER :‬‭ഒരു പൂർണ്ണസംഖ്യകളെ പ്രതിനിധീകരിക്കുന്നു.‬
‭3.1.2) DEC or DECIMAL :‬ ‭ദശാംശ സംഖ്യകളെ പ്രതിനിധീകരിക്കുന്നു.‬

‭3.2 സ്ട്രിംഗ് (ടെക്സ്റ്റ് ) ഡാറ്റ ടൈപ്പ്‬‭:‬‭അക്ഷരങ്ങളുടെ കൂട്ടമാണ് സ്ട്രിംഗ്.‬
‭3.2.1 CHAR or CHARACTER :‬‭അക്ഷരങ്ങളെയും പ്രതിനിധീകരിക്കാൻ‬‭ഉപയോഗിക്കുന്നു.‬
‭3.2.2 VARCHAR :‬‭വാക്കുകളെ പ്രതിനിധീകരിക്കാൻ ഉപയോഗിക്കുന്നു.‬

‭3.3 ഡേറ്റ് & ടൈം ഡാറ്റ ടൈപ്പ്‬‭:‬‭തീയതികൾ സംഭരിക്കുന്നതിന്‬‭DATE ഡാറ്റാ ടൈപ്പും‬
‭സമയ മൂല്യങ്ങൾ സംഭരിക്കുന്നതിന് TIME ഡാറ്റാ ടൈപ്പും ഉപയോഗിക്കുന്നു.‬
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‭***4. SQLലെ CHAR,VARCHAR എന്നീ ഡാറ്റ ടൈപ്പുകൾ തമ്മിലുള്ള വ്യത്യാസം  :‬

‭CHAR‬ ‭VARCHAR‬

‭ഇത് fixed length ഉള്ള സ്ട്രിംഗ് ഡാറ്റ ടൈപ്പാണ്.‬ ‭ഇത് variable length ഉള്ള സ്ട്രിംഗ് ഡാറ്റ ടൈപ്പാണ്.‬

‭ഇതിൽ പരമാവധി 255 character സ്റ്റോർ ചെയ്യാം ‭ഇതിൽ പരമാവധി 65535 character സ്റ്റോർ ചെയ്യാം.‬

‭മെമ്മറി അലോക്കേഷൻ സ്റ്റാറ്റിക്കാണ്.‬ ‭മെമ്മറി അലോക്കേഷൻ ഡൈനാമിക് ആണ്.‬

5. കോൺസ്ട്രയിന്റ്സ്‬ ‭:‬ ‭ടേബിളിലെ ഡാറ്റയ്ക്കുള്ള‬‭നിയമങ്ങൾ/നിയന്ത്രണങ്ങൾ നൽകുന്നതിന് ഉപയോഗിക്കുന്നു.‬

‭SQL Constraints‬

    KEY‬ ‭ഉപയോഗം‬

‭NOT NULL‬ ‭കോളത്തിൽ ഒരു വാല്യൂ വും ശൂന്യമാകാൻ പാടില്ല.‬

‭AUTO_INCREMENT‬ ‭പുതിയ റെക്കോർഡുകൾ ചേർക്കുമ്പോൾ ഒരു കോളത്തിലെ നമ്പർ
‭ഓട്ടോമാറ്റിക് ആയി വർധിക്കുന്നു.‬

‭UNIQUE‬ ‭കോളത്തിൽ വാല്യൂ ആവർത്തിക്കാതിരിക്കാൻ ഉപയോഗിക്കുന്നു‬

‭DEFAULT‬ ‭യൂസർ ഒരു കോളത്തിൽ വാല്യൂ ഒന്നും നൽകിയില്ല എങ്കിൽ ഡീഫോ
‭ആയി നിശ്ചയിച്ച വാല്യൂ നൽകുന്നു.‬

‭PRIMARY KEY‬ ‭ടേബിളിലെ കോളം PRIMARYKEY ( NOTNULL & UNIQUE )‬
‭ആണെങ്കിൽ സമാനമില്ലാതെ കോളത്തെ തിരിച്ചറിയാൻ സാധിക്കും.

‭FOREIGNKEY‬ ‭രണ്ടു ടേബിളിലെ ഡാറ്റകൾ തമ്മിൽ ബന്ധിപ്പിക്കാൻ ഒരു ടേബിളിലെ
‭PRIMARYKEY കോളം മറ്റൊരു ടേബിളിലെ  FOREIGNKEY ആക്കുന്നു.‬

‭6.ഡാറ്റാബേസുമായി ബന്ധപ്പെട്ട കമാൻഡ്കൾ :‬
‭CREATE DATABASE : ഡാറ്റാബേസ് നിർമിക്കുന്നതിന്‬
‭USE : ഡാറ്റാബേസ് ഓപ്പൺ ചെയ്യുന്നതിന്‬
‭SHOW DATABASES : ടേബിൾ നിർവചനത്തിന്റെ ഘടന കാണുന്നതിന്.‬

‭7. അഗ്ഗ്രിഗേറ്റ് ഫങ്‌ഷൻസ് (ബിൽറ്റ് –ഇൻ- ഫങ്‌ഷൻസ് )‬

‭ഫങ്‌ഷൻസ്‬ ‭തിരിച്ചു തരുന്ന വാല്യൂ‬

‭SUM ( )‬ ‭ആർഗ്യുമെന്റായി നൽകുന്ന കോളത്തിലെ വിലകളുടെ തുക ലഭിക്കുന്നു.‬

‭AVG ( )‬ ‭ആർഗ്യുമെന്റായി നൽകുന്ന കോളത്തിലെ വിലകളുടെ ആവറേജ് ലഭിക്കുന്നു.‬

‭MIN ( )‬ ‭ആർഗ്യുമെന്റായി നൽകുന്ന കോളത്തിലെ വിലകളുടെ ഏറ്റവും ചെറിയ വില ലഭിക്കുന്നു.‬

‭MAX ( )‬ ‭ആർഗ്യുമെന്റായി നൽകുന്ന കോളത്തിലെ വിലകളുടെ ഏറ്റവും വലിയ വില ലഭിക്കുന്നു.‬

‭COUNT ( )‬ ‭ആർഗ്യുമെന്റായി നൽകുന്ന കോളത്തിലെ ശൂന്യം അല്ലാത്ത വിലകളുടെ എണ്ണം ലഭിക്കുന്നു.‬

‭**8 ORDER BY ക്ലോസ് :‬‭ഒന്നോ അതിലധികമോ കോളത്തെ അടിസ്ഥാനമാക്കി‬‭ഒരു ടേബിളിലെ റോകളെ‬
‭ആരോഹണ ക്രമത്തിലോ, അവരോഹണ ക്രമത്തിലോ സോർട് ചെയ്യുന്നതിന് ഉപയോഗിക്കുന്നു.‬
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‭XII  - CHAPTER - 10‬
‭ട്രെൻഡ്‌സ് & ഇഷ്യൂസ് ഇൻ ICT‬

‭1.  മൊബൈൽ കമ്മ്യൂണിക്കേഷനിലെ തലമുറകൾ‬
‭1G:‬‭അനലോഗ് സിഗ്നൽ ഉപയോഗിച്ചുള്ള വോയിസ് കോളിംഗ്‬
‭2G:‬‭ഡിജിറ്റൽ സിഗ്നലുകൾ ഉപയോഗിച്ച് സിം കാർഡുകളുടെ സഹായത്താൽ‬‭GSM,CDMA എന്നീ‬

‭ടെക്നോളജി വഴി കോളിംഗ്,മൾട്ടീമീഡിയ മെസ്സേജ് സാധ്യമാക്കുന്നു.‬
‭3G:‬‭കമ്മ്യൂണിക്കേഷൻ വേഗത 2Gയെക്കാൾ കൂടുതലും , കൂടുതൽ‬‭ഡാറ്റ അയക്കാനും സ്വീകരിക്കാനും‬

‭സാധിക്കും.‬
‭4G:‬‭ലോങ്ങ് ടെം എവലൂഷൻ എന്ന് വിളിക്കുന്നു.ഉയർന്ന ഗുണനിലവാരം,വേഗത,കപ്പാസിറ്റി‬‭ഉണ്ട്.‬
‭5G:‬‭മുൻ ജനറേഷനേക്കാൾ വേഗത കൂടുതൽ,ഗുണനിലവാരം കൂടിയ‬‭ദൂരപരിധിയിൽ കണക്റ്റിവിറ്റി‬

‭2.***മൊബൈൽ കമ്മ്യൂണിക്കേഷൻ സർവീസ്സ് :‬

‭⏩‬‭ഷോർട് മെസ്സേജ് സർവീസ് ( SMS ) :‬ ‭മൊബൈൽ ഫോണുകൾ തമ്മിൽ‬‭പരമാവധി 160‬
‭അക്ഷരങ്ങൾ വരെയുള്ള ചെറിയ ടെക്സ്റ്റ് മെസ്സേജ് അയക്കാനുള്ള സംവിധാനം.‬
‭ഇവിടെ‬‭SS7 (സിഗ്നലിങ് സിസ്റ്റം )‬‭എന്ന പ്രോട്ടോകോൾ‬‭ഉപയോഗിക്കുന്നു.‬

‭⏩‬‭മൾട്ടീമീഡിയ മെസ്സേജിങ് സർവീസ്  :‬‭മൾട്ടിമീഡിയ സന്ദേശങ്ങൾ‬‭(ടെക്‌സ്റ്റ്, ഗ്രാഫിക്‌സ്, സംഗീതം,‬
‭വീഡിയോ etc ) അയയ്‌ക്കാനുള്ള  സംവിധാനം.‬

‭⏩ഗ്ലോബൽ പൊസിഷനിംഗ് സിസ്റ്റം :‬‭ഉപഗ്രഹത്തെ അടിസ്ഥാനമാക്കിയുള്ള‬‭നാവിഗേഷൻ സംവിധാനമാണ്.‬

‭⏩സ്മാർട്ട് കാർഡുകൾ :‬‭യൂസറിന്റെ ഹാർഡ് വെയർ  ഉപകരണത്തിനും‬‭അപ്ലിക്കേഷൻ സോഫ്റ്റ്‬
‭വെയറിനും പ്രവർത്തിക്കുന്ന ഇന്റർഫേസ് ആണിത്.‬‭ഉദാഹരണം‬‭: സിം കാർഡ്, ATM കാർഡ്‬

‭3.***മൊബൈൽ ഓപ്പറേറ്റിംഗ് സിസ്റ്റം  :‬
‭യൂസറിന്റെ ഹാർഡ് വെയറിനും, അപ്ലിക്കേഷൻ സോഫ്റ്റ് വെയറിനും ഇടയ്ക്ക് പ്രവർത്തിക്കുന്ന‬
‭ഇന്റർഫേസ് ആണിത്.‬
‭ഉദാഹരണം  :‬‭iOS from ആപ്പിൾ, ബ്ലാക്ബെറി OS, വിൻഡോസ്‬‭ഫോൺ from മൈക്രോസോഫ്ട്,‬
‭ആൻഡ്രോയിഡ് from ഗൂഗിൾ( Android OS ന്റെ‬‭kernel ലിനക്സ്‬‭ആണ് )‬

‭4.Intellectual പ്രോപ്പർട്ടി   :‬

‭4.1 ഇൻഡസ്ട്രിയൽ പ്രോപ്പർട്ടി :‬
‭4.1.1 പേറ്റന്റ്സ് :‬‭ഒരു കണ്ടുപിടുത്തത്തിന് അനുവദിച്ചിട്ടുള്ള‬‭പ്രത്യേക അവകാശമാണ് പേറ്റന്റ്.‬
‭4.1.2 ട്രേഡ്മാർക് :‬‭ഒരു കമ്പനിയെയോ ഉൽപ്പന്നത്തെയോ‬‭പ്രതിനിധീകരിക്കുന്ന രീതിയിൽ‬

‭നിയമപരമായി രജിസ്റ്റർ   ചെയ്തതോ സ്ഥാപിച്ചതോ ആയ ഒരു ചിഹ്നം, വാക്ക്‬
‭അല്ലെങ്കിൽ വാക്കുകൾ ആണിത്.  രണ്ടുതരം ട്രേഡ്മാർക് ഉണ്ട്,‬

‭4.1.2.1 ഇൻഡസ്ട്രിയൽ ഡിസൈൻ :‬‭വൻതോതിൽ ഉല്പാദിപ്പിക്കുന്ന‬‭ഉത്പന്നങ്ങൾക്ക് നൽകുന്ന‬
‭ഡിസൈൻ പ്രോസസ്സ് ആണിത്.     ഉദാ: കൊക്കകോള കുപ്പിയുടെ രൂപകൽപ്പന‬

‭4.1.2.2 ജോഗ്രഫിക്കൽ ഇൻഡിക്കേഷൻസ് :‬‭ഒരു പ്രത്യേക സ്ഥലത്ത് ഉൽപ്പാദിപ്പിക്കുന്ന‬
‭പ്രകൃതിദത്തവും കാർഷികവുമായ ഉൽപ്പന്നങ്ങളുടെ പേരാണിത്. ഉദാ: കോഴിക്കോടൻ ഹൽവ‬

‭4.2 കോപ്പിറൈറ് പകർപ്പവകാശം:‬‭പുസ്‌തകങ്ങൾ, സംഗീതം, തുടങ്ങിയ‬‭സൃഷ്ടികൾക്കായി‬
‭സ്രഷ്‌ടാക്കൾക്ക് നൽകുന്ന നിയമപരമായ അവകാശമാണ് പകർപ്പവകാശം.‬
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‭5.സൈബർസ്പേസ് :‬‭ഓൺലൈൻ ആശയവിനിമയം സുഗമമാക്കാൻ ഉപയോഗിക്കുന്ന ഒരു‬
‭ഇലക്ട്രോണിക് മീഡിയം അല്ലെങ്കിൽ വെർച്വൽ ലോകം.‬

‭6 സൈബർ കുറ്റകൃത്യങ്ങൾ :‬‭കമ്പ്യൂട്ടർ, മൊബൈൽ ഫോൺ, ഇന്റർനെറ്റ്‬‭എന്നിവ ഉപയോഗിച്ചുള്ള‬
‭ക്രിമിനൽ പ്രവർത്തനങ്ങളെ സൈബർ കുറ്റകൃത്യങ്ങൾ എന്ന് വിളിക്കുന്നു.‬

‭6.1. വ്യക്തിക്കെതിരായ സൈബർ കുറ്റകൃത്യങ്ങൾ :‬‭ഒരു വ്യക്തിക്ക്‬‭ശാരീരികമോ മാനസികമോ ആയ‬
‭പ്രശ്‌നങ്ങൾ ഉണ്ടാക്കുന്ന സൈബർസ്‌പേസിലെ മറ്റൊരു വ്യക്തിയുടെ പ്രവൃത്തിയാണിത്.‬

‭6.1.1 വ്യക്തികൾക്കെതിരായ വിവിധ സൈബർ കുറ്റകൃത്യങ്ങൾ‬
‭ഐഡന്റിറ്റി തെഫ്‌റ് :‬‭ഒരാളുടെ യൂസർ നെയിം,പാസ്സ്‌വേർഡ്‬‭തുടങ്ങിയവ മോഷ്ടിക്കുന്നതാണിത്.‬
‭ശല്യപ്പെടുത്തൽ‬‭: വ്യക്തികൾക്കെതിരെയുള്ള അപമാനകരമായ‬‭കമന്റുകൾ പോസ്റ്റ് ചെയ്യുക.‬
‭ആൾമാറാട്ടവും വഞ്ചനയും :‬‭വ്യാജ അക്കൗണ്ടുകൾ നിർമിച്ചു‬‭മറ്റുള്ളവരെ ചതിക്കുന്നു.‬
‭സ്വകാര്യതയുടെ ലംഘനം :‬ ‭മറ്റുള്ളവരുടെ ഡാറ്റ,ഫോട്ടോ‬‭തുടങ്ങിയവ വിതരണം ചെയ്യുന്നു.‬
‭അശ്ലീലമായവ പ്രചരിപ്പിക്കുക:‬‭അശ്ലീല വീഡിയോ,ഫോട്ടോ വിതരണം‬‭ചെയ്യുക.‬

‭6.2 സ്വത്തിനെതിരായ സൈബർ കുറ്റകൃത്യങ്ങൾ‬
‭i) ക്രെഡിറ്റ് കാർഡ് തട്ടിപ്പ്    ii) ബൗദ്ധിക സ്വത്ത് മോഷണം  iii) ഇന്റർനെറ്റ് തെഫ്‌റ്‬

‭6.3 സർക്കാരിനെതിരെയുള്ള സൈബർ കുറ്റകൃത്യങ്ങൾ‬
‭i)സൈബർ ടെറോറിസം ii) വെബ്‌സൈറ്റ് അപകീർത്തിപ്പെടുത്തൽ‬
‭iii) ഇ-ഗവേണൻസ് വെബ്‌സൈറ്റുകൾക്കെതിരായ ആക്രമണം‬

‭7. സൈബർ ഫോറൻസിക്സ് :‬‭നിയമവും കമ്പ്യൂട്ടർ സയൻസും സംയോജിപ്പിച്ചു‬‭കമ്പ്യൂട്ടർ സിസ്റ്റം,നെറ്റ്‬
‭വർക്ക്,കമ്മ്യൂണിക്കേഷൻ സംവിധാനം,സ്റ്റോറേജ് ഉപകരണങ്ങൾ എന്നിവയിൽ നിന്നുള്ള ഡാറ്റകൾ‬
‭വിശകലനം ചെയ്തു കോടതിക്ക് തെളിവുകൊടുക്കുന്ന ശാസ്ത്രശാഖയാണിത്.‬

‭8. ഇൻഫോമാനിയ :‬‭ഫോണുകൾ, ഇ-മെയിൽ തുടങ്ങിയ സാങ്കേതികവിദ്യകളിൽ‬‭നിന്നുള്ള‬
‭തുടർച്ചയായ തടസ്സങ്ങളും പ്രോസസ്സ് ചെയ്യാനുള്ള വിവരങ്ങളുടെ ബാക്ക്‌ലോഗും സംയോജിപ്പിച്ച്‬
‭ഉണ്ടാകുന്ന ഓവർലോഡിന്റെ ദുർബലപ്പെടുത്തുന്ന അവസ്ഥയാണ് ഇൻഫോമാനിയ.‬

‭പൂർണരൂപങ്ങൾ‬
‭ICT - ഇൻഫർമേഷൻ & കമ്മ്യൂണിക്കേഷൻ‬
‭ടെക്നോളജി‬
‭GSM - : ഗ്ലോബൽ സിസ്റ്റം ഫോർ മൊബൈൽ‬
‭CDMA - കോഡ് ഡിവിഷൻ മൾട്ടിപ്പിൾ‬
‭അക്സസ്സ്‬
‭SIM -  സബ്സ്ക്രൈബർ ഐഡന്റിറ്റി‬
‭മൊഡ്യൂൾ‬

‭GPRS - ജനറൽ പാക്കറ്റ് റേഡിയോ സെർവീസ്സ്‬
‭EDGE - എൻഹാൻസെഡ് ഡാറ്റ റേറ്റ്സ് ഫോർ GSM‬
‭എവൊല്യൂഷൻ‬
‭SMS - ഷോർട് മെസ്സേജ് സർവീസ്‬
‭MMS - മൾട്ടീമീഡിയ മെസ്സേജിങ് സർവീസ്‬
‭GPS - ഗ്ലോബൽ പൊസിഷനിംഗ് സിസ്റ്റം‬
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